Bios Option Removed - High Precision Timer


This option (High Precision Timer) was available in the bios before but Gigabyte removed it. What do i have to do to add this option back in the new bios if it is possible of course. This is my motherboard

"Gigabyte Z370 HD3P Rev 1.0" and the bios missing the option is the "F12" bios. Thank you.

@NewFX - Which BIOS did you use before with this option visible? Can you see PCH-I/O section in your current BIOS? That is where this setting is in F12, and that doesn’t sound like a usual visible area for Gigabyte BIOS, but maybe you can see this section?
If you can see PCH-I/O area then I can make visible easy, if you can’t then I need to check older BIOS to see where you used to have it, and then move it there in this BIOS instead (or make PCH-I/O visible to you).

I don’t know about the F11 and F10 bios because i didn’t use them but the F8 bios “” had that option. I am using the F12 bios and i don’t have the PCH-I/O section. The option was avaible under the chipset section in the F8 bios below “Wake on LAN Enable”. Also i forgot to say that the F12 bios i am using i updated the CPU microcode with the “UBU Tool” do you think that’s what made the option disapear ? Thank you for your help.

Chipset Section.png

@NewFX - thanks. All BIOS have this option, it’s just hidden in ones you don’t see, but yes I get what you mean about you didn’t check if others had it visible in their BIOS version or not.
Thanks for linking version you know you had it in

No, updating microcodes wouldn’t make BIOS option disappear. On the MIT system info page, or in HWINFO, can you see the new microcode version you updated BIOS to?
If it’s a broken BIOS mod then microcode may not be loading properly, in that case I don’t know if BIOS option would disappear or not, some things are only shown for certain CPU’s, but in this instance I do know Gigabyte has hid this option a lot so it’s probably hidden from you on purpose here (aside from any microcode issue or not)
I will redo mod for you, all microcodes updated without UBU, and make this option visible. If I cannot add it back in same area, I will make PCH-I/O visible for you instead.

To make things easier for me, so I don’t have to add an element entry, is there any setting on that chipset page that you don’t care about, that I can replace with High Precision Timer instead?
For example, I can replace audio controller with this option, and leave that enabled just you wont have this option anymore (so you can’t disable it, without BIOS mod)
Or Wake on LAN, or IOAPIC 24-119 Entries, or etc, all same, pick one you don’t need and I’ll leave it set as default just replace what you see in BIOS.

Thank you for helping me, you can replace PCH LAN Controller or Wake on LAN Enable or both if that helps. But if the easiest way for you is just to add the PCH-I/0 section you can do that. About the CPU microcode here is a screenshot of HWINFO.


Sorry i can’t remember the version of the UBU Tool or the date of when i used it. Here is a backup of my bios, i used QFLASH from the bios to make it “”. Also i forgot to add in my last message maybe the best option is to simply disable HPET without adding the option or another section but maybe that’s not possible. Thank you.

  • Edit - @NewFX - Here is mod, should be all OK but I am not able to test on my end


1. Update all microcodes to latest version as of 7/24/19
2. Swap setting in “Chipset >> Wake On Lan” For >> “Chipset >> High Precision Timer”
3. Remove Qflash mod BIOS block - allow Qflash mod BIOS

Main Mod - Setting Swap >> Unsuppressed both HPET entries in setup, swapped in place ID Info WOL/HPET
+ AMITSE/SetupData module >> WOL Element full info swap for High Precision Timer Element info

Flash via DOS/EFIFlash or Qflash (suggested)…757665747682749

If you cannot enter chipset now, control-Alt-Del out and let me know, there is one byte I was not sure if it needed left as-is or not for the parent pageID
If this is the case, easy fix! Hang tight if this happens and let me know

I checked your BIOS, it’s microcode EA from 2/3/19 because that’s the version that was in the UBU you used, so all is as expected there, no issues.
That BIOS is a little bit messed up, but luckily for you it was booting

You should have mentioned just disable HPET, that would have been much easier
You can do that without a BIOS mod, by using Grub and setup_var

I just flashed the bios and it works thank you. I can go to the chipset section and the option is there now. Again thank you very much for your help.


@NewFX - Sweet, thanks for quick reporting back! I always hate when doing some mods blindly, not testing on my end, and this kind of edit is one of those
I was about to setup a Z170N-Gaming 5 I have which has similar BIOS, but once I got done it was easier than some others I’ve edited in similar ways, mainly those were moving submenus around within menus though and that’s a bit more involved.

About your LAN MAC ID - how did you flash the BIOS??? This can be fixed with FPT, give me your LAN MAC ID and I will make you a file and show you how to fix it.
This ID is usually on a sticker near the LAN, or on the LAN or Audio metal block. If this model has the plastic I/O shield covering all the rear ports it may be stuck on or inside that plastic piece

If you flashed with FPT, the full BIOS file, and you have a FPT backup from before, please send me your FPT backup from before (any time before).
This way I can confirm if MAC goes into GbE once or twice. If you don’t have, it’s OK

Sorry i made a mistake and didn’t use DOS/EFIFlash or Qflash as you suggested. Instead i used fptw64 that i found in “Intel Management Engine: Drivers, Firmware & System Tools” in this forum. Thank you for your help and patience.

Yes, I suspected as much See my edit above.
This is why I gave instructions on how to flash. Stock BIOS should never be used to flash with FPT, except in certain rare cases, or for specific reasons.
Only flash a backup made with FPT originally, before any stock FPT flash, that is how you use FPT. Make a backup, edit as needed, then reflash, never flash stock or all board specific details will be lost.

Thanks for MAC ID, you can now edit out. I will tell you how to fix once you reply about my above questions, because if you have a FPT backup you need to reflash your BIOS region with the backup as well, otherwise your original NVRAM volumes will be lost and this can cause all sorts of random issues later.

I don’t have a backup, i didn’t even knew you could make a backup with this tool. Did i damaged my motherboard ? I’m really new to all this, sorry.

Why are you using this tool then if you don’t even know how to use it? Not meant in a bad way, but you said you didn’t know how to use so it’s kind of funny to see happening
FPT is dangerous tool to use, especially without any instructions and not knowing what you are doing, you can brick a board in a single click easily.
No, you didn’t damage the board, but you did loose all NVRAM data you had in the NVRAM volumes, luckily for you if you have to RMA Gigabyte only goes by the sticker on board
Reboot and check for windows updates, then reboot again, and check system properties and be sure windows stays activated too.

This board has Qflash, easily flash BIOS from USB stick from within the BIOS, once in BIOS hit F8 or press END key at startup instead of DEL to enter BIOS.
Have BIOS on root (not in folder) of FAT32 formatted USB stick, before you enter Qflash, then select the file and flash away, this is safest method outside of DOS/EFIFlash.
And this method would not have erased all your board specific details. Luckily you did not brick the board, so there’s that at least

Here, take this file and flash via >> FPTw.exe -gbe -f gbe.bin
Then reboot and LAN will be fixed

From here on out, any time you flash BIOS, always make a backup first.
This way you can always recover, or always have a backup made in case someone needs to get something out of it to fix anything for you.

To make backup with FPT. This doesn’t help now, but so you know in the future, and yes of course you can still backup now too but this will only contain what you’re at now (stock BIOS, minus all your board specific details and NVRAM etc)
Full BIOS (not always possible) >> FPTw.exe -d SPI.bin
Main BIOS Region >> FPTw.exe -d biosreg.bin
ME (Sometimes you can’t) >> FPTw.exe -me -d ME.bin
GbE (only if GbE present = Intel Gigabit LAN) >> FPTw.exe -gbe -d gbe.bin
Flash Descriptor (FD) >> FPTw.exe -desc -d fd.bin

FPTw.exe -d <<< This (-d) = backup/dump
FPTw.exe -f << < This (-f) = program/flash

BIOS is made of the following regions FD, GbE, ME, and then Main BIOS region (in this case)

Please link me to the thread where you read how to flash BIOS with FPT, thanks! I want to see if it’s a guide here, if so I will see about getting a warning put in the thread so users know not to flash stock BIOS with FPT in most instances

There is no real explanation it was a really stupid mistake. Thank you for the file it corrected the problem with the MAC ID, it’s showing properly now and my windows is still activated. Also if there is others problems i will report it back here. You have been really helpful and patient thank you very much.

@NewFX - It’s OK, don’t be too worried about it You’re welcome, glad to hear all is fixed now and windows still activated too!

Please see my edits above, especially the last bit I edited in later and maybe you missed, thanks

I searched "How to flash bios with fptw64" used the "-f" command from here "". I wanted to try out flashing the bios from windows, i saved your instructions above thanks for that. Everything seems to be working fine. Thank you.

OK, thanks, I thought maybe you saw it here on a guide rather than a general thread here or elsewhere.
Anywhere FPT flashing is discussed, especially in a guide, it needs to be stated to users in most instances you should never flash stock BIOS with FPT or you’ll loose board specifics or worse brick the system if BIOS is wrong size (ie in a Asus Capsule), or does not contain all regions and a BIOS region only flag is not used etc.

Good all is still working properly, hopefully all will be fine for your board!