Bios reflash caused loss of xmp recognition?

I thought the folks here might have come across this and have some answers.

I was recently messing around with my oldmotherboard trying to understand secure boot.
ASRock fatality z68 Professional gen3 with 2600k and 16 gig of 1866 memory

In the process, I at some point reflashed my bios 2.23a (modded to use nvme). This bios had been working fine for a couple of years since I had modded an original 2.23a beta from asrock.

Since the flash no bios old or new recognizes the memory XMP profiles on any of my ddr3 memory sticks.

On top of that I can no longer set the cpu multiplier above 38x. If I try to set it anything above 38x it reverts to 38 as soon as I move the cursor to a new entry field. No OS OC utilities see any multiple above 38 for the cpu.

Any idea on what may have happened here?


NVRam values…???
Try a cold CMOS drain after a ME FW -greset
Same with 2.26? (As it reports “Improve memory compatibility”)

If the above solution don’t fix it. You can buy a new bios chip or reprogram bios chip using CH341A.
This will fix it.
This is intel management engine corruption.


I tried 2.20, 2.24. 2.26, 2.23a and my modded version of 2.23a. Besides the expected differences all acted the same in regards to multipliers and xmp. I tried a cmos drain but not the ME FW -greset. I’ll try that next.
I don’t have any bios screenshots

By the way, how do I do an ME FW reset? My experience with ME is limited to simple updates.

You need the ME8r3 tool package here on C2. (CS)ME System Tools
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (

Flash Programming Tool
cmd admin: fptw64 -greset

That didn’t help. I couldn’t tell anything changed except my Win10 efi disappeared from my boot menu.

The given command doesnt delete OS EFI or EFI disk entries, it just reinitializes the ME Engine state and nothing touched on bios.
Remember that on bios as CSM ON (Legacy) the NVme is seen as PATA_SS and is not bootable, so the system needs to be PURE UEFI CSM off (No AUTO) in order to boot from the current UEFI OS on the NVMe drive…or dont you remember this anymore from Fernando’s guide?

Regarding or XMP issue… nothing new to add, we dont know what users do in their systems and its easy to say that all was ok for yrs and now is gone, what should we bet/guess???
Did you had any specific settings in bios? Do you remember those settings? Dont tell me, you never changed anything and its all, as it was for yrs…
All the best, cheers.

EDIT: Sry for my misunderstanding of the boot drive and OS, dont know what GPU u have but pure UEFI also requires compatible HW, in this case an EFI GOP driver on the gpu.
Gona be honest… i dont think a new SPI chip is reason here… still is not expensive, good luck

EDIT: A Z68 and a 650 TI EFI… enough for UEFI…
How about a new vbios (80.06.3C.00.82) and GOP driver (Nvidia GOP 0x10017 to 0x10038)… it may fix your UEFI boot issue
VGA Bios Collection: Gigabyte GTX 650 Ti 2048 MB | TechPowerUp
AMD and Nvidia GOP update (No requests, DIY) - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (

EDIT: Yeah the “machine check exception” is a pain… old gen hw makes it even more painful to debug. I would be necessary to do some tests with single drive fresh OS install, with another EFI gpu and/or iGPU and removing all other add ons devices as drives, wifi etc…

I did not checked the IDs of it as i didn’t had yours, these IDs can be changed with NBitor or HEXedit to match and/or Nvflash cmd overrides, i’ve done plenty of it, off course sometimes we need to recover the vbios back… its still a mod so…
The GOP driver has little impact on OS as its only used on bios init of the system, the vbios can contain more important fixes, but i wouldn’t have that trouble without the previous debug tests i referred regarding the “machine check exception”

EDIT: Some motherboards, mostly high tier chipset Z68/Z77 only enables iGPU when no dedicated GPU card is installed or both when LucidLogix Virtu MVP is present

1 Like

Oh there may be some confusion the windows 10 install is on a sata SSD no nvme currently in the system.

Nothing actually changed in regards to the data on the ESP the windows entry just disappeared (from the nvram?). I don’t know why and I eventually was able to put it back (I’m still not completely sure how).

CSM on this bios doesn’t work as I expect. If I disable CSM I am not able to boot into win10 (I get a machine exception error) But if I enable CSM I can still enable secure boot and secure boot shows as active in both windows10 and linux. This is unlike any other system I’ve set up. I imagine you understand the why’s of this behavior.

I don’t have it documented but as for the 43x vs 38x multiplier this I know with certainty I ran the system at 43x from the initial purchase (summer2011?). The xmp I paid less attention to. The last time I remember checking was when I warranty replaced the ram about 2 years ago. I know I checked at that time because I had to verify the ram was compatible with the system (that xmp profiles were being seen).

I actually left most of the bios as default or auto. cpu multi, xmp profile and cpu voltage offset were the only changes made on the OC tweaking tab.

Over the years it was run in a raid config for most of it’s life but changed over to ahci within the last 2 years.

A couple of years ago With the help of fine folks here I added the nvme boot capability to the bios but I only did that for testing purposes I never used it after confirming that it worked.

Most recently I decided to see if secure boot was possible so I added a gpt drive and installed win10 to it. This worked fine, but as described above csm didn’t work as I expected.

A new bios chip is cheap enough that i’ll give that a try. If it doesn’t help it won’t be the end of the world at this stage this system is used for tinkering as much as anything.

Thanks for the help if I get any new info I’ll update the thread for the record.

edit: for completeness

The above vbios has a slightly different subsystem id 1458 3618 vs 1458 3554 on my card it is a slightly smaller/newer model but all of the particulars seem to be the same. Same clock speeds, same outputs and same memory. I don’t know if that is important.
I’ll read the first post in the thread and see if I can figure out how to add gop to this or my current vbios.
thanks for the links.

edit: looks simple enough - drag and drop old vbios check output for glaring red error warnings and out pops updates rom

edit: updated gop to 0x10038 on original rom didn’t change anything still “machine check exception” when CSM disabled and booting windows

edit: interesting you bring up iGPU. That is another feature that disappeared from my bios. There is no option to enable iGPU. I’m almost certain I used it for testing at some point in the past but none of the bios builds from 2.20 onward (I didn’t test anything older) have it as an option. I know it was active at some point because my earlier windows 10 installation had loaded drivers for it. The newest install of windows doesn’t see it at all.

edit: I tried uninstalling the video card and nothing happened. just 4 error beeps. I’ll try installing lucid if I have it.
Yeah won’t install lucid. Says integrated video not found. No surprise if bios doesn’t see it either.

Well thats not a good sign my friend… on a normal behaviour of the system and doesn’t matter if its a Z68, the 2600k cpu has an HD3000 iGPU, the system should boot/display without any GPU dedicated card…
Intel Core i72600K Processor 8M Cache up to 3.80 GHz Product Specifications

Lucid Virtu Installation Guide

EDIT: “0xD6 No Console Output Devices are found”, so no video signal output detected…
Primary Graphics Adapter by default is PCI express but this setting usually doesn’t need to be touched as the system detects NO add on GPU
IGD Multi-Monitor also by default is Enable, this option is for both iGPU and GPU work at the same time.
This makes me believe that your initial issue with XMP is not alone… as the system should boot with only RAM and the 2600k (HD3000) on it, also this information, you can verify in the manual, if my words sound suspicious to you, not that i need to make proof of my knowledge to anyone.

EDIT: Oh man… this is getting better, does that mod was only added the NVMe DXE driver or the bios was tweaked/mod in other aspects…
You need to seriously debug that motherboard back to original bioses/settings and test it again or indeed the board is affected and dying.
Others had lucky in similar situation, when performing a full/deep clean to the motherboard

I double checked. I pull the video card and I get 4 beeps and a “55” code on motherboard. No video out on any of the mainboard video outs. Just cycles off the back on to repeat endlessly.

edit: Okay ignore the 55 error code I had jarred a memory stick loose and that cause it.

Instead I get 5 beeps a d6 error code and no video out when I remove video card.

edit: I think you are correct about all of this. Something has failed somewhere. Whether it a hardware or firmware problem I don’t know enough to guess. That it seems to work fairly well except for these odd quirks makes me think that if it is hardware it is very specific.

edit: I just tried some thing new just raise more questions. I added 2 more memory sticks to the system but the bios didn’t detect them. Strangely though if I boot into windows and use CPUz they show up there. The bios and OS don’t see the additional ram but CPUz does. Once again I don’t know what that means.

edit: I only added nvme no other changes. I just reflashed and no changes.

For what it is worth I just installed a replacement bios chip with 2.20 installed and both xmp and overclock work again :confused: I’m nervous about updating the bios back to 2.23a even though it worked in the past and my system is set up to make use of the uefi feature.

edit: intel video 3000 appears again also.

edit:I almost wonder if the original bios chip is bad or has a bad section. I wouldn’t think the flash updates would complete without error or the chip would even boot the computer. I really didn’t expect a replacement bios chip to fix anything.

Bios update doesn’t overwrite everything, for example settings and machine specific information doesn’t get changed. Sometimes settings from an earlier version might conflict with a newer bios, can be possibly solved with emptying NVRAM (= like a new chip programmed with ‘emty’ stock bios)

Post the content of the old chip, it you have a programmer.

I don’t have a programmer

Well, then try at least to make a backup of the spi or the bios region, might be possible to restore it when things go wrong next time.

Download from Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)
ME System Tools v8

Run Flash Programming Tool (fpt)
fpt(w(64)).exe -d spi.bin

or if this doesn’t work:
fpt(w(64)).exe -bios -d biosreg.bin

If your eager to know if you can write to the bios region with fpt try to write back the dump of the bios region you just created (recommend non windows- version - DOS bootable usb stick - for dumping and flashing/writing):
fpt.exe -bios -f biosreg.bin

But be careful, fpt writes without checking the content of the file or the area it writes to!

Thanks for suggestions.

Using my new working bios chip:

I tried “fpt(w(64)).exe -d spi.bin” it gave me a not readable error.

I tried “fpt(w(64)).exe -bios -d biosreg.bin” it worked and created a bin file.
I switched to the broken bios chip and flashed the bin file to it.

I got “PDR region does not Exist” and “GBE region does not exist” warnings but the flash completed.

On rebooting after the flash the settings had changed to match working chip but the problems remained
can’t OC multiplier above 38, no xmp profiles and no intel gpu 3000 video.

I guess that means the problem is not in the bios portion of the SPI chip ?

edit: On the working chip apparently me is locked but desc is readable as that portion dumps to desc.bin.

FD is most often readable, but nor writeable, and ME is often locked for reading and writing, yes.

ME version got updated from 20 to 23, but 23 is same as 26. If a vendor bios update overwrites the ME and under which conditions isn’t reproducable. But I did check the ME configuration and there’s no change in settings for all 3 versions.

So it’d interesting if cleaning the ME of your defect spi would solve the problem. A CH341 is cheap and always ‘nice to have’, you got a socketed chip, so it’d be easy and risk free.

ME cleaning guide:

Follow up: I ordered a CH341a and was able to reflash my original chip with my modified nvme bootable version of 2.23a and all works fine. Memory profiles and OC multiplier are back to normal.

The only oddity was that the first replacement spi chip that was sent to me didn’t work. It was a GD 25q64bpig instead of winbond 25q64vaig (my original spi chip type). The seller I bought from sent me a winbond replacement with no problems but I’m not sure why the GD wouldn’t work I’d have thought the two were interchangeable. I tried reflashing it with programmer but it still wouldn’t boot.

No matter - all is well and both new (winbond) chip and original work fine.