[BIOS REQUEST] - x79a MSI GD45 (8D) - NVME Boot + Bifurcation


I have the latest v12.8 BIOS on my motherboard.

I was wondering does anybody have the v12.8 BIOS with NVME Boot + Bifurcation support enabled?

I have brought a Dual NVME adapter board to put in the machine, but I have the issue that the BIOS seems to not support Bifurcation, so the O/S only sees a single NVME drive, rather than the two NVM’s I have mounted on the card.

If nobody has a pre-build BIOS with this support, does anybody have any ideas how I can mod my current BIOS myself.


Edit by Fernando: Thread title shortened

@ipdialup - Ahh! MSI BIOS is such a pain to add a hidden menu, but I can do if absolutely necessary. Give me some images of your BIOS (none of easy mode, all advanced).
Show me the main screen inside advanced, then inside OC section from top to bottom, and inside “Settings” at root, and inside Advanced top to bottom. You can possibly use F12 to screenshot to USB, if not use camera and resize images to 800 wide or so, then pack in zip/rar with max compression
The IOH submenu you need is inside Hidden Overclock section, but I can swap it out into some other already visible section for you, replacing some submenu that you don’t need, or one you maybe can’t even see right now anyway.
For now, here is NVME mod BIOS only, flash via M-Flash, do not rename the file - https://ufile.io/ab84lzax

YOu can use this BIOS and change bifurcation options with AMIBCP 4.55, set what you want in optimal column, but it will take you some trial and error to find which IOU1 is which slot on the board.


Thanks for this, I think I already managed to add the NVME boot options myself, using MMTool, however dealing with the Bifurcation stuff was a little more challenging :slight_smile:

I’ve been reading up on it.

I may give it a go, but I think it needs a bit of figuring out in terms of IOU1 refers to which slot.

My Goal, is to have video card in first 16x16 slot, the a dual port NIC in next 16x1 slot, noting in the 1x1 slot, then I have a PERC H800 (Raid controller) in the 2nd 16x16 slot (4th slot on the board), with nothing in the next 16x1 slot (5th slot on the board), with the 6th slot which is an 16x8 slot split into 2x4x lanes for my Dual SSD NVME, either that or I could swap my PERC H800 into the 16x8 slot, and use the 2nd 16x16 slot, in dual 8x mode for my dual NVME, in theory one of them for booting, the other to run VMs on.

If you could do the BIOS for me to enable change the bifurication options, that would be great I have attached the screen shots you asked for, please let me know if you need more.

If you can’t manage I guess I’ll have to deal with the trial an error option using AMIBCP 4.55.

Thanks for your time and response.


BiosImages.zip (1.86 MB)

Yes, IOU & Slot will take you some testing, you can see which slot is what as you change by using HWINFO64 and look in the “BUS” section. This applies even if you can see the BIOS options too!
Give me some time and I will do the menu edit for you, thanks for the images

I will edit Settings >> Advanced >> And make EuP 2013 submenu visible (hidden from you now, only contains >> Deep S5 << Disabled by default), and replace that with other hidden Overclocking section that has all the settings you need inside it.


I’ve had a look at doing this manually, but when I load the BIOS into AMIBCP I don’t see the IOU sections anywhere.

Also looking at the guides other people have written for the Asus x79 & other boards they seem to have sections that don’t exist in my BIOS…


@ipdialup - This kind of edit is probably not something you can easily do, it requires some deeper BIOS understanding, and is done by hex editing with lots of manual data collection via hex as well before the actual edit is applied
Swap OC for OC would be a bit easier to figure out, but then you loose original OC, and no body wants that

AMIBCP is not used for this at all, but if you wanted to use it to test as initially mentioned, the IOH settings are at hidden Overclocking (ie first one you see) >> North Bridge >> IOH

Please wait, this takes time, I am working on it

Ok thanks I will wait, sounds like it’s a little beyond my ability :slight_smile:

@ipdialup - Quick test needed before final mod is done. Please test both of these BIOS, do not rename and don’t get them mixed up w/ stock BIOS, I need to know result from each (so don’t mix these up either)
Flash via M-Flash, let me know which of these, or if both, show you Advanced >> EUP 2013 submenu (contents are not relevant here, and this is the ONLY change, for this specific test only - so look no further, all is stock)

Hi, ok I will let you know which Bios has which menus visible I will feed back as BIOS ‘S’ and BIOS ‘U’ as those are the folders in the zip file.


“S” : BIOS - No EUP 2013 submenu under Settings -> Advanced

"U" : BIOS - No EUP 2013 submenu under Settings -> Advanced

I don’t see it from either of the two BIOS’se


@ipdialup - OK, thanks, forgot something I see, sorry about that! First test this, then if it’s not there, I’ll send you the same + the above edits
Those were supposed to go on top of this one, if needed, but I think this should get it

Hi, ok, I see the EuP2013 menu option now, just contains a single entry, "Deep S5" which is currently disabled :slight_smile:

@ipdialup - Thanks! Here is final mod, now in place of that UEP 2013 menu will be the hidden OC menu, inside you will find North Bridge Submenu, and inside that is IOH submenu and this is where your bifurcation settings will be
Contents inside the new menu @ Advanced >> Overclock should match what you see in AMIBCP at First Overclocking Menu. If you are missing any submenus in there, or any important settings inside IOH submenu let me know and I will get them revealed for you.
As of now, I did not edit anything inside there because we need to see if you can see it all by default first or not.

Also, if you want to find out, you can try renaming the file and see if M-Flash still allows it (sometimes yes, sometimes no), so maybe less chance to mix things up. Keep stock extension, so example >> ADVOCMod.C80
If M-Flash says no, then rename back to stock name.extension E7760IMS.C80

Hi, ok with the latest BIOS the EUP2013 Menu is gone and replaced with one called “Overclocking”, however I can’t move into this Menu, when I press return on the new menu in Settings->Advance->Overclocking it does not expand into further sub menus.

Thanks for your help here, I guess something is still not set quite right?


@ipdialup - OK, thanks! Sorry about that, hard to get perfect first time always when I don’t have the board in hand I’ll check it out and fix
Here, try these two simple changes, and if neither let you in then I will look back over the major edit I made to get that done initially. These are similar change to the Access Level U/S that I sent you for something previously, but we didn’t get to test out because setup edit got it instead

Don’t worry, I’ll get it, just may take some more trial and error on this final part to allow you in

* Edit - @ipdialup - If neither of the above get it, try these and let me know, then if still nothing I will check over the original edit and make sure I didn’t miss something there.

Hi, no worries, I understand how tricky this must be to get right without having the Board available, I do appreciate all the effort your putting in!

Its good of you to help in the first place, I’d have no way of getting this working myself !!

I naively thought that these PCIE to Dual / Quad M2 NVME adapters would just work, I only found out about this Bifurcation thing, once I googled after plugging it in and only one of the two SSD showed up, it’s an x79 board, so in theory supports it, I do wonder why these options were disabled and Hidden in the BIOS in the first place.

User v1 BIOS -> doesn’t allow me to enter the Overclock Menu
Super v1 BIOS -> doesn’t allow me to enter the Overclock Menu
User v2 BIOS -> doesn’t allow me to enter the Overclock Menu
Super V2 BIOS -> doesn’t allow me to enter the Overclock Menu

And annoyingly M-Flash on this board only picks up file names that match the original BIOS naming, so was a bit of back and forth to flash and test each one but results are above.

But none of them allow me into the Overclock menu you have added.


@ipdialup - Yes, kinds tricky when I can test right here and then send to you, AND MSI is one of the more tricky to get sometimes too
Thanks for the heads up about the name, sorry about that, I’ll start putting back into folders instead

So, when you try to enter, on any of those previous, does the BIOS lock and you have to CTRL-ALT-Del to reboot, or can you carry on in BIOS just no entry to Overclocking?
I looked over the major edit part of what I did, and all looks correct there. So, this non-entry is left down to permission, or magic string, which is used in this BIOS and I originally didn’t touch magic string because it all looked correct to allow entry into all by default.
So, added one more 01/yes in case that’s the issue here, if this works then it’s odd (MSI For ya) and magic string is out of order.
Quick test here - https://ufile.io/k1yi705d

Actually, here, similar edit w/ +2 more and +1 added in other direction in case it’s backwards or XMP menu entries are counted etc


I have tried these two, again same behaviour, the BIOS doesn’t crash, just when I select the “Overclocking” menu and press return or click on it with the mouse, nothing happens.

Mouse cursor just blinks once, then I can continue to other settings etc…


@ipdialup - Thanks for results and info, something out of the ordinary must be blocking it then, I’ll deep dive and see if I can find it!
If I can’t find what’s blocking that, I’ll just redo this edit to put IOH submenu itself there instead of the entire hidden OC section, that would not be blocked like a whole hidden main menu section could be, so should show up right away.

* Edit - @ipdialup - How about now, can you enter IOH Config - http://s000.tinyupload.com/index.php?fil…475436127216298


Just tried this BIOS now, and the menu has changed to IOH, but I still can’t seem to enter the new menu as before, nothing happens when I attempt to access the submenu.