Black Screen on Asus

Hello everyone, I have a problem with an asus k550JX. The PC suddenly stopped starting: power on, light flash of the display (more than flesh say backlight sign") and then remain in black screen. Once every tot the pc was able to turn on but going immediately in blue screen. I thought of a corrupted bios problem and tried to reprogram it with a CH341A programmer. I downloaded the bios from the asus site, through Uefitool I turned it into .rom and then copied it into the bios chip of the motherboard. Reassembled tried to turn on and the cou part ( the said heats), the fan also but the screen remains totally black. I also tried to connect it to an external monitor but the result is the same. The PC has 4GB of ram welded on the mobo and 2GB of Vram.
The sw I use to program does not have in the bios chip list exactly the same, but an extremely similar one.
First question, if the bios had been badly fleshed the cpu would be able to start as it does now (so I would rule out a possible failure of the bios flesh procedure)?
If the bios was ok, what could be the problem? Ram gone?
Thank you all

Update. I tried to verify that the copy of the bios was successful but it gives me a couple of errors. At this point maybe the problem (or one of them) is just the bios. Where did I go wrong?

I’m reading about bios dump but i don’t know what is it

Hi firend , could you point me to the Stock Bios link and site model’s link ?
Regards



Try this one :

https://www.badcaps.net/forum/attachment…89&d=1463405830

The Bios from Stock file is only Bios Region and you need a Firmware File …

was this message for me?

U asked help, BDmaster answered u and u still ask if the message is for u…
Yes, that a dump, that i mentioned in ur other post.
So BDMaster already helped u.



Try this one :

https://www.badcaps.net/forum/attachment…89&d=1463405830

The Bios from Stock file is only Bios Region and you need a Firmware File …



Thank you for the file. I downloaded it, unzipped. I connect my CH programmer, detect the chip, choose BV one, read, erase, and open the file you send me. Then I programmed. But when I “verify” the program give me an error. I post the pic. Can you help me?

Immagine3.png

update, i redo the procudure 2-3 times and no errors appear, but the pc still not shows nothing on screen. The cpu turns it up (the fan go and the heatsink is hot), but nothing on the screen. I tried also with a external monitor with the same results. It could be a hardware issues?

Hi friend, i used ASProgrammer and it work well on win10 , here is :

https://github.com/nofeletru/UsbAsp-flas…ases/tag/v1.4.1

Try wit this one, erase before to write the eeprom and then after wrote verify it , if you’ll get Done , then it’s all ok !
Let me know
Regards