Booting issue

My Mainboard is an ASUS P7H55M-PRO which has the BIOS stored on a Winbond W25Q64. When the pc is powered it starts, showing BIOS logo and detecting the components mounted on (IMAGE 1). On pressing some buttons for starting one of the options of the BIOS menu it won’t load anything, remaining stuck on BIOS menu (IMAGE 2).

So the problem is that I can’t start anything, BIOS config nor boot menu nor ASUS EZ flash utility.

What I tried:
- changed PSU
- changed RAM, both slot and module
- cleared CMOS memory
- flashing another BIOS ROM, (with success), following this guide
- booting the pc both with an internal and an external video card
- booting the pc with or without an hard disk
- booting the pc with or without a bootable USB drive

Now, I don’t know what can I try to start BIOS config or boot a OS. I don’t know either what could be broken, and I’d like to understand what it is in that case.


- I don’t know the history of this mb, I mean, I don’t know what they did before it was given to me for repairing it
- I tried clearing CMOS with and without the battery

EDIT: I tried to flash 3 different ROM versions, in particular 1709, 1604, 1330

@trimalcione :
Welcome at Win-RAID Forum!

Since I don’t know the BIOS specifications and options of your special mainboard, I cannot help you.
My advice: Contact the ASUS Support.

Dieter (alias Fernando)

Thank you for your reply.

I tried to contact ASUS support but they said to follow the usual instructions for recovering BIOS, or send it to the assistence office.
The second option would be too expensive.
I wanted to recover the mobo by myself.
Thank you anyway.

Since you tried everything else, including BIOS reflashing, reset etc, it should be hardware related. Meaning, motherboard (damaged traces, capacitors?) or cpu. Maybe you can get one of those debug code pci cards to see where it gets stuck.

ok, thank you. I checked all capacitors yet, and all seem to work. May you advise me some specific debug card?

Someone said to me it could be computrace chip which is blocking booting. Have you evere heard something about that?

I don’t know any models, just that they exist. My board has an onboard one so I never had to look.

I thought it might be some sort of TPM or similar chip but I cannot see such a thing at that board and unfortunately I don’t know these technologies to be able to help if the problem is really there.

Okay, thank you all for your help.