Bricked bios asus x507uf-ej101t need help fixing bios

i need help,a few days ago i bricked my asus x507uf laptop.Now only the power leds and battery leds light up and flash,nothing more.
I also tried to recover laptop by crashfree bios method by pressing ctrl + home on keyboard but it didn’t work,the battery led keeps flashing and the cpu keeps heating up.
I have managed to get a bios dump from the chip with the help of ch314a programmer,but i dont understand how can i fix it so i need help.
I am attaching the bios dump with the post below, also i am sorry for my bad english.
Also i dont have any bios dump of the time when the laptop was working before.

asus x507 bios (5.71 MB)

@ajay325 - What is BIOS chip ID, look with your eyes, do not rely on software to tell you. You may need magnifying glass and flashlight
What software/version did you make the above dump with?

I am attaching the bios chip photo in this post,and even though the bios chip name written on it, it looks wierd and i cant find it anywhere else,although the programmer does detect the chip as gigadevice GD25Q64 and the reason i think it’s working properly is because when i opened the dump with hex editor, there’s a model number of the laptop named X507UF so i think it does read the chip properly.and the software version for ch314a programmer (black colour) was v1.34


Are there any hopes of recovering the laptop? I have practically tried everything and cant seem to unbrick the bios so far.