Bricked, boot looping, Lenovo ideapad y700-15isk (Help me PLEASE!!)

Hello everyone.

I think I chose the right forum section to post on, but please excuse me if I didn’t since I’m new.

I’d like to ask for your help please, in order to try and save my laptop computer (Lenovo ideapad y700-15isk) and avoid myself a lot of trouble by migrating ALL my data to a working computer as well as setting it up with the programs I need among other perks.

I’m currently going through the last year of my thesis (I couldn’t l have picked another moment to be so courageous and mess around with my motherboard… ).

Motherboard: BY511-NMA541, core-i7-6700, Nvidia GTX 960.

EEPROMs: GD25B64CSIG (8M), W25Q32… (4M).

CONTEXT (skip if you wish so) :

I had done a BIOS update, which went perfectly fine, by running Lenovo’s UEFI capsule executable directly from Windows. The only problem being that for some reason VIRTUALIZATION setting must have gotten changed to OFF during the update cause my Ubuntu virtual machine, where I had quite a bit of work already done, stopped booting complaining about virtualization not being enabled.

Thing is my computer (which I bought on Amazon in 2016) came with a Supervisor password set whose existence I stumbled upon like 3 months after having received the machine.

It was IMPOSSIBLE to get either Amazon or Lenovo to take responsibility getting the password removed. They kept sending me back and forth one to the other.

So at the time I decided to keep on with my life and maybe one day I’d decide to find a way around that password since I didn’t really need to change any settings back then, even if I did want to have full control over the hardware capabilities I had paid for (as it should be, I bet you’d agree on that).

Well… Now this happened and I couldn’t access the BIOS settings.


As I had found over the web in some posts about Lenovo laptops with unknown Supervisor Passwords, I disassembled my laptop and tried to short-circuit the DI and CLK pins of the eeprom chip to get it to read NULL while i tried to enter the UEFI-BIOS menu at the same time. After 4 or 5 unsuccessful tries, on the last one I managed to corrupt the contents of the eeprom.

And so the laptop got stuck in a boot loop.


I dumped the old contents of the eeprom(s), my system has 2 of them, 8 and 4MiB, but the 4M one had just empty bytes inside and I don’t know what it does. The 8M one had the DE+ME+BIOS image which made me think that the 4M one probably isn’t firmware related, but I wouldn’t know for sure.

After reading many posts in here and in other forums, I’ve edited the stock UEFI image file by extracting 8MiB of data starting at next offset right after $_IFLASH BIOSIMG, and then using the build functionality on UEFItool to get the output image I’d flash afterwards. I also inputted the same extracted file into Intel FIT for also getting another potential image to flash in case my first try didn’t work.
Payed attention not to erase anything else, not to unalign the volumes and not to change their sizes or introduce any errors, following the information provided by the UEFItool parser.

Doing this I got two files which I have already tried, 8MiB each (the size of my big eeprom), and reflashed with an SIP clip and external programmer.
As you will see the stock image is about 8.6M in size and has a file right after the last FFS which talks about Insyde FLASH. I cut this part out because in my dump there wasn’t anything pointing to such a file.

After flashing I verified the write and it was identical to the file I flashed.

I don’t know if my test procedure was correct, but I didn’t put everything back together and only fed power to the motherboard while having an external monitor connected via HDMI (laptop screen is damaged), the speakers and a keyboard over USB. Didn’t reconnect the CMOS battery, hard drive, OEM keyboard, etc. Didn’t think it would make a difference in terms of getting the BIOS to POST, but I’d like your opinion on this.

The loop persists anyways, of course, and that’s why I’m coming over to you guys.

I’m attaching the stock BIOS file for my model (the latest release was cdcn54ww and believe the on before that was cdcn35ww) extracted from the Windows executable downloaded from Lenovo’s website, as well as the binary i built and flashed and the dump of the corrupted contents.

Excuse me if I forget anything you may need in case you decide to guide me into solving this problem.

Please help me. What am I doing wrong?!

I’m desperate. I beg you. PLEASE !!

CDCN54WW.rar (3.93 MB)

Ok friend,
try this one :…EV-1.0.rar/file

let me know

Thank you very much for your help.

I’ll be trying it out in the next few hours and I will let you know the result.


Hi @BDMaster ,

So I tried the file you kindly provided me with but unfortunately it didn’t work. The version of the BIOS file provided is CDCN35WW. I did a hex comparison between the stock file for that BIOS version, (which I extracted from a .exe), and the file you proposed me. They were not identical but they didn’t have that many differing bytes either.

Both images did have however the same nested main 3 volumes with the same structure and the same files inside, as I was able to see using UEFItool. For what i’ve gathered it seems to me that the .exe just contains sort of a “shell” of the BIOS, upon which the flashing utility executable builds up the contents it’ll be flashing once it’s run.

I think I’ll never get a working image just by extracting the NVRAM volume (which is the one I identified got damaged according to the dumped image of my corrupted BIOS) from a stock image and combining it with the “good” sections from my dump, nor by just flashing the stock BIOS as it is.

Those stock files have got to be “INCOMPLETE” somehow or kind of SPARSED. There’s something I’m missing and I haven’t been able to figure it out.


Looking around I found a dump from someone with the exact same laptop model and coming from the same market section as mine.

Their NVRAM volume was quite different from the stock one, which had (the stock) an entire VSS store file missing.

I took that dump, cleaned the ME region using Intel Flash Image Tool (Intel FIT) and then flashed the resulting file to my board’s BIOS EEPROM. Sadly, I had no luck.

I’m attaching both the dump I found and the ME cleaned version of it.

Would you have any suggestions for me, please ??


Lenovo IDEAPAD Y700 TOUCH-15ISK BY511 NM-A541 REV (4 MB)

Lenovo IDEAPAD Y700 TOUCH-15ISK BY511 NM-A541 REV (3.87 MB)

Hi friend, this is the Firmware extracted by Stock Bios File, so without NVRAM, but full …
Here you go :…CN54WW.rar/file

It has to work (it’is your file posted), if not this is not for your laptop , so we will find the right model and file …
let me know