BSOD 0x000000ED during install?

So I’m trying to install Windows Server 2003 x64 R2 SP2 in AHCI mode on my GIGABYTE GA-B85M-D3V motherboard, I’ve integrated your AHCI drivers with nlite and used WinSetupFromUSB to make an install USB. It booted fine, I could see my hard disk and the partitions in textmode but when it rebooted I got this BSOD.

@dab :
Welcome to te Win-RAID Forum!

The STOP: 0x000000ED BSOD is not caused by the integrated AHCI driver, but either by a faulty file system or a faulty HDD.
As first step I recommend to check the integrity of the HDD by using a diagnostic tool, which has been delivered by the HDD manufacturer, or by running the Check Disk command from the Windows Command Line (look >here<).

Dieter (alias Fernando)

Thanks, but I’m pretty sure it’s not that. I used CHKDSK from the 2003 install usb and it said that the volume appears fine. Also it worked fine when I installed it in IDE mode.

This might work to fix the issue. Run the installer again, get to the repair recovery console and then run bootrec.exe /fixmbr followed by bootrec.exe /fixboot.

This can also be done with diskpart, with the drive connected to another system, after selecting the correct drive volume.

When you mentioned it was fine in IDE mode, was that with this same setup install media (Configured as it is now?) Asking as a way to verify the modified install media is OK itself.

There’s no bootrec on recovery console but I did FIXMBR and FIXBOOT individually and that didn’t do anything. I used the same image when i installed it the first time, but it wasn’t modified by nLite.

Maybe nlite messed something up. Can you try same type of mod with another program, or manually instead?

That means you haven’t confirmed this modified nlite install image is OK, by installing with it in IDE mode, correct? You may need to do that, in case something was messed up during the modification steps.
Of course any change that is messed up still might only affect AHCI modes, but this is something I still would test myself

Can you connect the disk to another system? If yes, get to the root of the drive and copy the boot.ini file here.
Open it yourself too, does it all look correct, pointing to the correct disk and disk partition layout. Check disk layout while connected to the other system with disk manager or other partition managing program, and make sure if OS is only one disk and only one partition that boot.ini matches and says disk zero and partition 1

Does this current as-is messed up install, boot to windows now if you switch BIOS to IDE again? If yes, run SFC /SCANNOW and then stop after that there and let me know, I will help you check something in registry

What hard drive are you using, is it IDE or SATA, if SATA does it have jumper directions on the HDD label? If yes, what do they say, and what if anything is the jumper set to now?
I know that probably sounds odd, but if the drive is really old this may apply. If it’s a newer driver (made in last 5-8 years at least), then none of this applies or matters.

Thanks for help.

How would I even do that? The guide says to use nLite.

I did that, when I booted with AHCI i got 0x7b and in IDE i got 0xED for some reason, so it actually might be the problem.

I actually modified it a lot of times, but it mostly always was

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003 Enterprise x64 Edition"

It gave me error 0x7b.

My hard disk is a SATA OCZ Trion SSD, it’s from 2015 or so, so i guess it doesn’t matter.

Sorry, I have not modified XP in forever, but all this is possible manually, before nlite and vlite existed.

That boot.ini looks correct, provided there is only one hard drive and the OS is installed at the very first partition
Verify partition with disk management or partition tool, to be sure the OS is the first partition and there is not some other hidden small partition before the OS partition (you know, like Vista/Win7 likes to to)

Thanks for your test of IDE vs AHCI. 0x7b means you need to make registry edits in order to enable AHCI or IDE mode, whichever BIOS was set to that gives that error as this is a commonly known error when switching between modes without the changes below.
This means AHCI or IDE is not enabled for booting from within the OS. I am not sure how you can load the registry hive outside of the OS, but I do know it’s possible because you can copy/backup the registry from another system off the main system disk and open/edit there.
I’ve seen this done, and maybe even done it years ago, but don’t remember how, you’ll have to look around for editing registry hive from alternate disk or alternate system etc.

These are the changes you need to make
Enable switching between all IDE/AHCI/RAID modes by changing “Start” Values in these keys to 0



Thanks for the SSD info, yes that part I mentioned is not relevant in this instance then since you have SSD