BSOD when entering Intel Rapid Storage Technology with RAID5

Hello,
This my first post in this forum, and English isn’t my native language, so I would like to apologize for my mistakes, that will happen for sure :slight_smile:

I have problems with an array of 3ST2000DM001 drives, which gives me BSOD as soon as I click “Intel(R) Rapid Storage Technology” icon. Tried different different Intel RSTe drivers (12.9.0.1001 and 13.2.4.1000) with the same result. This isn’t the first time I have this problem, as earlier this day I had the same issue, which was resolved by deleting a volume in Intel OROM, so this makes me think, that it has something to do with this array, but I can’t figure it out.

I found a post on different site (first result in Google under “raid 5 rst bsod”) telling, that Intel RST has problems with larger capacity RAID5 arrays, but I can’t imagine that config of 3
2TB drives counts, as 2TB drives are very common since 2011. On the other hand, that would explain why problem was gone after reverting to non-RAID state.

Probably I should mention, that I was running RAID1 setup for almost year and a half without issue with 12.9.0.1001 driver (well, actually updated some time ago). Today I added third drive and started recreating array from scratch and ran into these issues. I even tried updating Intel OROM from 11.2 to 12.9 which was successful, but still problem persists. I ran out of options. Maybe when initialization finishes, everything will go back to normal? Do someone have had similar experience?

Last but not least, configuration of my pc (with omission of irrelevant components):
Intel Core i7-3770k @ 4,5GHz
Asus P8Z68-V Pro/Gen3
24GB RAM (2x8+2x4) @ 1800MHz 10-10-10-24
Crucial M4 128GB boot drive
3x Seagate ST2000DM001 in RAID5 = 3,6TB storage
Chieftec CFT-600-14CS
Windows 8.1 Pro x64

Thanks in advance!

PS: Tomorrow I will enable Page File, and type down BSOD message, as it disappears within quarter of second, and leaves no trace/memory dump.

@ forteller:
Welcome at Win-RAID Forum!

It is not easy to help you without knowing the exact BSOD message.
By the way: You can easily read the BSOD details and the error code, if enable the option “Don’t reboot at System failure” within the “Start and Recover” section of the “Advanced System Settings”.

Here are some general recommendations:
1. Update the Intel RST(e) driver to v12.9.4.1000 WHQL (reason: This newer version of the v12.9 development line will have less bugs.).
2. Make sure, that there is no overclocking by changing the default BIOS settings or using any tuneup software.

Does that mean, that you have totally disabled the use of a Page File? If yes, this may be the reason for all your troubles.

Regards
Fernando

So I enabled Page File and downgraded Intel RST Console/Driver to 12.9.4.1000 (btw, I have Intel OROM v12.9.0.2006), but that didn’t helped. On the other hand, I was able to make dump of that BSOD, but that wasn’t helpful at all, as this is very generic error code.

IntelRST_BSOD.PNG



I forgot to mention, that this RAID5 setup isn’t my boot drive, as I have SSD for OS. I will update first post with that. I should mention that reverting to stock frequencies/voltages didn’t helped.

@ forteller:
If I understood your first post correctly, everything is working fine, unless you are running the Intel RST Console Software.
So the problem seems to be caused by the software.
Since the RST Software is not really needed, why don’t you just uninstall it?

So… I was finally able to enter Intel RST Console. To do so I had to disconnect one drive (and this drive in particular), launch pc, and start RST Console. Then, I am able to connect this one drive, and rebuilding process starts.

Now, the thing is, this one drive is different from other two. The one that causes RST to throw BSOD is ST2000DM001-1E6164, while the other two are ST2000DM001-1CH164. This makes me think, that this drives is somehow faulty, as I cannot read SMART from it for most of the time (using HwInfo enables me to read SMART from RAID members, but not for this drive… but magically sometimes it works). When I launch PC with only this one drive connected (1E6164), Intel RST behaves in the same way - throws an BSOD.

I would like to keep RST installed, as this is the only tool which enables me to monitor exact array state. With RAID5 of such a big size, it takes few days to rebuild and initialize array, and it is helpful to know if it’s 20% complete, or 80% complete. I started rebuilding this array 26h hours ago, and it’s completed in only 31%.

As for now, I am going to leave this and wait while rebuilding and initializing is complete. I cannot see any rational explanation for this behavior, apart from that this one drive is somehow incompatible with others / Intel RST. Thank you Fernando for your time and help.

@ forteller:

Thanks for yourl report. It is fine, that you found at least the initiator of the BSODs.
So you obviously have a hardware issue and not an Intel RST driver or software one.

Time has passed, lot of things changed, but BSOD remained :smiley:

Since the last post I changed few things in my computer. First of all, I changed this one drive with exact model as the other two. Apart from this, my current setup looks like this:
- PSU: Chieftec CFT-600 changed with Corsair CX750M, and then with Corsair RM750
- OS: clean install of Windows 10 x64 on its premiere
- main drive: Corsair M4 exchanged with 2x Corsair MX100 256GB configured in RAID0
- mainboard: unfortunately, my Asus died a week ago and as for now, it’s very hard to obtain good mobo with Socket 1155. I’ve got MSI Z77A-GD55 and I am not very excited about it, but POST time (pure UEFI boot) and better OC (4,6GHz @ 1,304V. Earlier 4,5GHz was stable at 1,27V, but 4,6GHz was a no go even at 1,34V) are nice.

With new motherboard I’ve checked once again and BSOD remains. I think it will stay with me until I buy a whole new PC :smiley:

Also, I would like to thank you @Fernando for this great website. I helped my friend with his Gigabyte GA-Z68-DS3 to get TRIM on RAID0 few years ago with manually adding necessary components (RST OROM 11.6). Now we have tools that do this just with few click (UBU) - amazing! I created modded BIOS for my Z77A-GD55 just with few clicks. Your effort that you put in benchmarking, testing and developing things is just amazing. Keep up your good work :slight_smile:

Have you ever tried to run the OS without any overclocking?
According to my own experience RAID0 systems are very sensitive regarding overclocking.

I’d rather disassemble my RAID configuration than return to stock clocks - that’s just an overclocker in me :wink:

The thing is, it took 4 days to verify my array. I will not take any chances of breaking it again by making BSOD just when RST app tries to access the drive.

A temporarily return to stock BIOS settings regarding RAM and CPU will not brake your RAID array, but may verify the impact of your overclocking on the system’s stability.

A temporarily return to stock BIOS settings regarding RAM and CPU will not brake your RAID array, but may verify the impact of your overclocking on the system’s stability.



Returning clocks to stock won’t hurt, but launching RST UI most definitely will (as I’m pretty sure it will throw BSOD). I will check it some day probably, but as for now I don’t want to make it painfully slow for another 4 days.

Apart from that, my system was 24/7 stable for last 3 years.

EDIT:
I’ve read whole thread and it appears that I’ve tried returning to stock settings and BSOD remained.

Few months ago I have built NAS server to which I have moved my HDDs and currently I can use Intel RST software without a problem. Strange but this particular RAID5 array was somehow problematic (maybe specific firmware version of drives? I never tried to update it, but there is update available).

On a side note: I had one ST2000DM001 failed around 18 000 working hours mark. It was youngest one, but only one that was "Certified Repaired" as it came as replacement of first failed drive. I replaced it with ST2000DM006 (as DM001 is no longer available) and it works without issue - again thanks to this site, which enabled my P35-DS4 board in my NAS to take such big drives. Time passes, and I continuously use knowledge gained thanks to this site. Thanks again!