building new RAID 5 array in upgrades from Win 7 AMD system to Win 10 Intel system incredibly slow

So I upgraded this last week and I knew I couldn’t just transfer the 5 1 TB drives over and tell the UEFI to handle them as an existing RAID 5 array…

So I only had about 1TB of data and copied that over to a single 2TB drive before the conversion. The drives are 7 years old and have never given me any issues.
the performance was always good and the copy to backup drive went pretty quickly.
They’re Hitachi drives with a negotiated rate of 3 GBs per second.

When I build the array with the Intel RST on board software it went very smoothly .
Logical and physical sector size is 512 bytes.

At first I though I would do a regular format and not the quick one. In an hour it never got past 1%. When I first built this array years ago these were brand new drives so I only did a quick format.
So next I did the quick format and that finished in a reasonable amount of time.
When I tried to load the data it was like the original full format and said it would take 26 hours to load 1 TB.
I’m aware that writing does take longer but when I’ve loaded other large files on my old AMD based system it was never this slow.

So I think I must have done something wrong?

System Information
OS name: Microsoft Windows 10 Pro
OS version: 10.0.18363 18363
System name: DESKTOP-CJ9FFKV
System manufacturer: Gigabyte Technology Co., Ltd.
System model: C246-WU4
Processor: GenuineIntel Intel64 Family 6 Model 158 Stepping 13 3.696 GHz
BIOS: American Megatrends Inc., F5

Intel® Virtual RAID on CPU Information
User interface version:
Language: English (United States)
Intel controller: SATA (AHCI)
Number of SATA ports: 8
RAID option ROM version:
SATA driver version:
ISDI version:

Storage System Information
RAID Configuration

Array Name: SATA_Array_0000
Size: 4,657.57 GB
Available space: 232.89 GB
Number of volumes: 1
Volume member: Volume0
Number of array disks: 5
Array disk: JP9960HZ26TUHU
Array disk: JP9960HZ1WRZHU
Array disk: JP2940N02TVU2V
Array disk: STF604MH0RLMWB
Array disk: JP6911HD3ESGNF
Disk data cache: Enabled

Volume name: Volume0
Status: Initializing 51% complete
Type: RAID 5
Size: 3,539.74 GB
System volume: No
Data stripe size: 64 KB
Write-back cache: Disabled
Initialized: No
Close RAID Write Hole: Off
Parity errors: 0
Blocks with media errors: 0
Physical sector size: 512 Bytes
Logical sector size: 512 Bytes

Hardware Information

Controller name: Intel(R) C600+/C220+ series chipset SATA RAID Controller
Type: SATA
Mode: RAID
Number of volumes: 1
Volume: Volume0
Number of spares: 0
Number of available disks: 0
Rebuild on Hot Insert: Disabled
Manufacturer: 8086
Model number: 2826
Product revision: 16
Direct attached disk: JP9960HZ26TUHU
Direct attached disk: JP9960HZ1WRZHU
Direct attached disk: JP2940N02TVU2V
Direct attached disk: STF604MH0RLMWB
Direct attached disk: JP6911HD3ESGNF

Disk on Controller 0, Port 0
Status: Normal
Type: SATA disk
Location type: Internal
Usage: Array disk
Size: 932 GB
System disk: No
Disk data cache: Enabled
Command queuing: NCQ
Model: Hitachi HDS721010CLA332
Serial number: JP9960HZ26TUHU
SCSI device ID: 0
Firmware: JP4OA3MA
Physical sector size: 512 Bytes
Logical sector size: 512 Bytes

@staatsof :
Did you break the AMD RAID array before you transfered the former RAID5 members to your Intel system? You should have done it!

No I did not. I thought just formatting it would eradicate everything. When I went into the Intel RST raid build it saw the 5 drives, I selected them and I created the array. The numbers all look proper?
However when I first put the drives in and booted windows and before going to raid two of them appeared joined as one with a capacity of 2TB.

It might not be the best idea to use a RAID before it’s finished initializing. Afaik Intel does a sectorwise check of the complete disk area when initializing, that might take a while. And it’s initializing in the backgroud with low priority…

Raid information is stored on the disks on a level below formatting/ filesystem!

lfb6 is right - you cannot erase the RAID array information by formatting the RAID array member disks. Only a "Secure Erase" operation will delete these data.
It was a big mistake to create an Intel RAID array without having previously deleted the AMD RAID data from the disks.

Well I cannot go back and delete the AMD RAID array now from that environment.

So where do I go from here?
It sounds like I need to break this new array and then securely erase each drive individually or just buy 5 new drives.
Do you know of a utility that can run in windows 10 and do this in the background?

As an aside … I did have misgivings about going to an Intel based EUFI environment when I read about people losing their raid arrays because of a EUFI /BIOS updates. I never could get an answer that made me comfortable.
So now that I’ve actually gone through the process it doesn’t look to me as though there’s any way to avoid losing your RAID array when such an update happens. To me it appears that the Intel firmware needs to be told that those drives are part of an array and if you do that it necessarily wipes in some manner what’s on those discs.

Change my mind.

@lfb6 :
All the status displays coming from the EUFI firmware and Intel’s Virtual raid utility which runs under Windows 10 says and has been sting that the array is ready to use.

One issue with this machine is that the initial default setting to go to sleep after 15 minutes has had it turning off which pauses that initializing process. Another is that the said initializing shows as zero IO activity on that RAID set. Not helpful …
So I didn’t worry about anything still incomplete.
If this initializing finishes will that have fixed the situation?

Thanks for addressing this.

EDIT by Fernando: Unneeded fully quoted post replaced by directly addressing to the author (to save space)

@staatsof :
For a secure erase of my SSDs I always have used the tool "Parted Magic".
Your performance problems are caused by the fact, that within the track0 of your RAID array there are now the data of 2 different RAID arrays (Intel+AMD).
Provided, that your Intel system is still available, an alternative would be the following:
1. Make a backup of your important data outside the RAID array.
2. Break the AMD RAID array from within your AMD system.
3. Attach the RAID members to the Intel system.
4. Break the Intel RAID array.
5. Reinsert the former RAID members into your AMD system and create a new RAID array.
Good luck!

So you don’t think that if the Intel initialize process finishes, it’s at 80% now, that this process will have ensured proper reformatting at a lower level than the opsys file system will have been ensured?

Well, let the machine run…

As written before: The RAID is transparent to the OS! There is no I/O to a RAID set by the process of initialisation visible with OS tools…
If you’d open the Intel tool (for me ‘Intel(R) Virtual RAID on CPU’), you’d see information about initialisation in volume properties.

Concerning the RAID meta-data written on the disks by Nvidia and Intel- it’s ufortunelately pure guessing if they might affect each other. The Nvidia RAID information might either be destroyed by Intel initialisation, or- being written on another place on the disk- still available, but not interfering. I’d let the initialisation finish, check the performance anf decide thereafter.

That’s normally the case- a RAID disk normally isn’t readable itself without the proper RAID information and connected to the corresponding controller. Exceptions would possibly be a volume of an old Windows software mirror, a single RAID 1 disk on a compatible controller?

That 2 of the disk showed up as striped in Windows might as well be an communication error, or a residual of an earlier trial with striped disks in windows?

Buying five new disks- why would you want to have a (software) RAID 5?

That’s been fixed and it’s gone from 75% to 83% in a couple of hours.

Yes, that’s what I’ve done. Unfortunately my disk activity LED broke during this upgrade so the only indication I have is the sound of the drives.

Interesting though I suppose the safest thing is a complete lowest level wipe of the drives.

On my previous AMD bases system I could change the the various SATA ports to ACHI or Raid and on boot it would scan the disks on that control and present them as individual disks or as a part of the array. I don’t know if it knew the details in the bios or if it figured out by scanning the disks but it always reported the size and whether it was healthy of not?

This goes back to 2012. It’s worked well for me. No failures on that set of drives.

EDIT by Fernando: Unneeded double quotes removed and post completely reformatted by Fernando (for better readability and to save space)

Thanks for removing all of my carefully edited reply so that now it’s harder to read! It’s not really any shorter.

@staatsof :
I have customized you post, because you had quoted the text from 2 different authors (fb6 and yourself), but forgot to set the required double quotes-off at the end. Bad consequence: Everything was written in italic type, which should be only done regarding the quoted text (to make it very clear for the reader, which part is quoted and which part is the reply).
There was no need to quote yourself and to write your reply in red letters.

How about I just submit everything to you beforehand so that you can format it.

@staatsof :
It is my job as Admin to make your last post readable and to correct the wrong formatting (no need to post in red letters).

How about asking here how to transfer an existing AMD RAID array to an Intel RAID array before having done it? That would have been much better especially for you und would have saved us both a lot of wasted time!

How about asking here how to transfer an existing AMD RAID array to an Intel RAID array before having done it? That would have been much better especially for you und would have saved us both a lot of wasted time!

I’m just sorry I wasted the $10 on a forum with such a control freak in charge of it. I’m on a lot of forums and I administer four of them and I’ve never seen one run quite like you do this one. Most of us don’t have the time to waste being so persnickety. If you have any ethics you’d delete my threads and send me my $10 Euros back. Last post from me it’s not worth the hassle you seem to enjoy imposing.

@staatsof :
If I should ever get a donation from you, I will refuse to accept it.
Good luck with your RAID5 array!


The poster is obviously annoyed for having made an error, but rather than accepting responsibility, tries to blame the HELP!
“Fluchen und Schimpfen” is never a good response to computer travails.

The youtube link still has me laughing all these years later!

Man destroys computer

Keep smiling!