Bypass "press F1 to continue" warnings. Optiplex 7020.

First off, this forum has helped me mod my bios in such a way I wouldn’t think possible. I managed to add working AMT to my BIOS and updated the microcode and the VBIOS firmware and updated the RST driver too. Which improved my SATA throughput quite a bit. So thanks for that and the wealth of knowledge that can be found here. It’s been very useful to me.

I’ve figured out most my issues with posts on this forum but I am now at a place I can’t figure out myself anymore. I replaced the stock fans (system fan only for now) with silent Noctua fans. The system runs idle around 25-30c so the cooling is not an issue. However, the Dell BIOS keeps greeting me with a warning about the fan. Forcing me to press F1. It is not really issue unless the computer reboots on its own and never boots back into the OS while I’m not around it and need to access it remotely (luckily there is VPro/AMT) to press F1. But I’d like to have it removed if possible.

About the warning. There must be some kind of extra communication going on between the stock fan and the BIOS. I’m using all 4 wires on the new fans, wired up correctly using the 5 pin Dell to normal 4 pin diagram (one pin is unused on the Dell header). But somehow the BIOS knows it’s not an original fan. I read you can bypass this by running a wire to the cpu fan. But since I’m also going to replace that one I would like a better solution.

I’ve attached the bios region dumped with fptw. The full spi was too large to attach. Original Dell bios can be found here.

Thanks a lot for reading and helping.

Edit 1:
In some higher end Dell desktops/workstations and servers the BIOS has an option to disable/ignore these warnings and boot anyways. Could such an option also be hidden in the OptiPlex BIOS somewhere? I really hope it is possible to get rid of these errors on boot. The fan rpm is reported to the OS, the temperature sensors work, yet Dell doesn’t allow me to boot normally because I don’t use their stock fan? Not nice…

Edit 2:
I’ll be ready to go all the way! Hopefully soon and not in July. Programmer has arrived and works perfectly (3.7 MB)

I did some more digging and found the module that contains these errors. But where to go form here is a mystery to me. I’ve seen @Lost_N_BIOS mention it could be bypassed with some assembler but that is way above my pay grade. I had extracted it wrongly before, I had to use MMTool to extract the module.

Can someone help me out here? I would love to bypass all the useless warnings about no disk present, no rear or cpu fans, all those are useless cuz even if the fans work fine Dell will complain cuz it’s not an original Dell part. I replaced my fans with quieter and better performing Noctua fans but Dell keeps whining about them. Maybe it’s easier to just remove the pause and still print the error message? I opened the .bin file in a disassembler but it’s all magic to me in there

The module is called DellErrorLogConfig and was located at GUID 038CE287-B806-45B6-A819-514DAF4B91B9. I don’t think I can simply remove this module. I did receive my programmer so I am able to restore/recover the BIOS easily. Even did a test run of dumping and restoring a bios with flashrom. Works great. So no worries there.

Thank you! (7.45 KB)

@stovorsen Next time you reboot, please upload image of the F1 error, then I can see if I can bypass for you. This is usually not a BIOS setting in modern motherboards
PM coming for AMIBCP you can use for inspection only, DO NOT use this for BIOS editing (untested) - you have been warned, a few times now
Also, you have to browse to file with this, no drag-n-drop BIOS


* Edit - @stovorsen - Here, please tests, all errors gone now?…273658597486212

Thank you! I will test it out very soon. Will also take some pics of the errors before trying the new module just in case they do come from another place. But I really hope Dell didn’t add those to some other place. Dell isn’t Apple so I don’t expect it. Though it would be funny if there’s a little D2 chip somewhere on the board that throws errors as soon as a Dell part is replaced with another brand lol.

You’re welcome! And yes, please do get me an image of this error first, just in case I need to edit something else instead.
There, I just edited the module you mentioned using assembly/hex, to bypass two never-ending loops if reached, and that module name sounded familiar too, I think I’ve helped someone else do this on Dell already

They do put whitelist in some laptop BIOS, to only allow certain network cards, but that’s more HP’s thing than Dell but they do it too.

I’ve taken some pics, will upload them later. The literal texts are:

Alert! CPU 0 failure.
Alert! Rear fan failure.
Alert! Hard Drive not found.

Then sometimes, but not always it will also complain about a previous fan failure:

Alert! Previous fan failure.

I think that one only shows once it sees the original fans again. My guess is that the sense wire sends out either a “special” signal or temperatures or something. I’m no fan expert but I don’t think normal fans send temperatures. So if a BIOS mod isn’t possible attaching a temperature sensor to that wire might bypass this in a more clean way than running wires to the cpu fan.

This patched AMIBCP worked perfectly! I can see all the microcodes too and it has confirmed to me that there’s nothing (as far as I can see) hidden for me in the BIOS. There are suppressed items in the IFR I extracted but the options I checked weren’t hidden in the BIOS. Maybe I missed some though. There are some settings for RAM timing I saw in the IFR that are not in the BIOS but also not suppressed somewhere. Not important.

Your BIOS flashed ok but the error persists. I flashed it with fptw + -greset after flashing and loaded BIOS defaults. Hopefully that is the good procedure.


@stovorsen - 4 pin fans have PWM control signal wire + RPM signal wire, 3 pin fans only have RPM signal wire - That should be only differences, I doubt dell spent extra money for one of the cables to send some other signal vs a normal fan, so maybe only difference there is the type of fan you connected 3/4 pin
Try other 3 pin if that’s what was originally there, or other 4 pin, to confirm if this is true or not. Anyway, we will solve issue I bet, so you can use your intended fan once I find and fix

Be sure to look in the first folder after setup expands, with no name, this is a debug folder, you may find some setting there that could help, but I looked and didn’t notice one (only keyboard error one)

-greset only needed if you make major changes to ME FW

You flashed BIOS region only with FPT, correct? Like this >> FPTw.exe -bios -f filename.bin
If not, do that now, then reboot, load optimized and then test

If that did not work, then this is not the module that causes the error to happen, only the one that holds and or logs as it’s named the alerts.
Or, what I bypassed was not where the errors are invoked, or other edit needed. I will check again and see if I can find, thanks for the images

I found where I bypassed similar error before for another Dell user, it was this module, so just have to find the right edit
[Request] Dell Vostro 260 - Add Ivy Bridge support (7)

Looking at post #104-105 there, I see I did same edits as I did here for you, but from my image at post #105 only M2 edit works for the alert error and I did “MBoth” on your BIOS, so now just need to do the one edit by itself instead of both
So, here is that BIOS, I bet issue now solved with the Alerts! Flash BIOS region only >> FPTw.exe -bios -f filename.bin…725758954395120

Flashed, now I’m getting this screen instead of the fan warning:

I had to press F1 to continue booting. So nothing fatal is going on and no fan warning was showing so thats progress! I got those messages after first reboot and also after loading BIOS defaults. I have no optimised defaults in this one. Dell optimises nothing haha. With the original fan connected no message shows up when using this BIOS. So you’re in the right area.

(As for the fan header/pins, I expected exactly the same as you did. But even though all 4 wires are connected properly and the OS received the correct rpm and it spins up/down according to load Dell still complains. The starting/idle rpm is exactly the same as the original Dell fans too. From what I understood on some other forum is that the sense wire carries an extra signal. They bypass the F1 error by running a wire to the cpu fan cuz they didn’t replace that to tap into that signal for the system fan header. But that is not an option for me as I replaced both fans. It should also be possible to bypass the error by adding a thermistor/resistor on the sense wire. But I don’t have any equipment here to test that or even try it. I think we (well you) can bypass this in software. But if we can’t then a hardware hack is the only way.)

Weird! Maybe your system is different than the 260, it looks exactly same in assembly though, anyway I will do opposite and bypass the other loop instead and see if that fixes it for you
Here, try now - Actually, if I do the other way (M1 as mentioned in this post, probably = brick) What I sent you was “M2” as discussed at “Edit 3”, there is no other way to edit this (M1, M2, or Mboth as discussed there, I sent you MBoth first, then M2)
This file is tiny, and these edits are the ONLY routines out of 4 I think that even have a loop to pause in.
[Request] Dell Vostro 260 - Add Ivy Bridge support (7) (post 104)

Does subsequent reboots show this error too? I will look at it again tonight, but I don’t have high hopes

* Edit - Idea! Instead of bypassing these, I can make it carry on/to end, instead of bypassing (or pause in loop/original action), maybe this is the answer

* Edit - @stovorsen - Here, new method used, same area edited, test all three, let me know outcome of all three, thanks…492811841759598


Thanks again! I tested all 3 bios and all with same result; error message shows as normal. Only the first mod showed the HII string parsing error. It only seems to occur on cold boots. Strangely rebooting won’t trigger the warning about the fans even with stock bios. Does it only check on cold boots? That would make no sense but this is Dell, so I dunno haha.

I think I know what triggers the error! It’s the rpm reporting! If the bios sees the rpm below a certain threshold when booting or rebooting the error is shown. So I guess if we can change that check to like 0 rpm the error would never be triggered. On cold boots the Noctua fans spin up slowly towards the default 1500rpm Dell wants to drive that fan at. Their own fan spins up very fast so never triggers the error. But I did read on Dell forums that on some pc’s even their own fans trigger the warning when the pc is very cold or in a very cold environment. Seems like a bios bug to me. It should wait for fans to spin up before throwing an error about fans. It should also be more specific in the error, but it just says fails while it should say “rpm too low” haha.

Do you think it’s possible to find/change this check and maybe change the required rpm to 0?

You’re welcome, sorry no luck again! So this set, new1 gave you the HII error, or no change on all and same error as original? Yes, it’s possible only some bold boot bug, this is common for many boards and random issues.
Or yes, could be RPM as you mention. I doubt I can find and change, since no RPM minimum is known and no RPM message given. Do you think 1500 is this minimum? If yes, maybe I can find, but not sure

Dell drives the cpu fan at 1000 and the case fan at 1500. Regardless of what fan I put in they’re always at those figures.

None of the 3 new bios gave the HII parsing errors, they all displayed the normal error. Only the first bios to try gave the HII parsing errors.

I had hoped maybe there’s a check in there for rpm and if it doesn’t pass the check it throws the error. In the IFR the fan speeds are listed in hex, maybe that helps. As far as I can Dell Dell uses only 2 speeds, low and high.

0x4C3FE 		Numeric: Active Trip Point 0 Fan Speed, VarStoreInfo (VarOffset/VarName): 0x1BA, VarStore: 0x2, QuestionId: 0x16A, Size: 1, Min: 0x0, Max 0x64, Step: 0x1 {07 A6 26 03 27 03 6A 01 02 00 BA 01 00 10 00 64 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00}
0x4C424 Default: DefaultId: 0x0, Value (8 bit): 0x64 {5B 0D 00 00 00 64 00 00 00 00 00 00 00}
0x4C431 One Of Option: Active Trip Point 0 Fan Speed, Value (8 bit): 0x64 (default MFG) {09 0E 26 03 20 00 64 00 00 00 00 00 00 00}
0x4C43F End {29 02}

0x4C53B 		Numeric: Active Trip Point 1 Fan Speed, VarStoreInfo (VarOffset/VarName): 0x1BB, VarStore: 0x2, QuestionId: 0x16C, Size: 1, Min: 0x0, Max 0x64, Step: 0x1 {07 A6 28 03 29 03 6C 01 02 00 BB 01 00 10 00 64 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00}
0x4C561 Default: DefaultId: 0x0, Value (8 bit): 0x4B {5B 0D 00 00 00 4B 00 00 00 00 00 00 00}
0x4C56E One Of Option: Active Trip Point 1 Fan Speed, Value (8 bit): 0x4B (default MFG) {09 0E 28 03 20 00 4B 00 00 00 00 00 00 00}
0x4C57C End {29 02}

I think 0x4B is the high speed and 0x64 the low one, but it could be the other way around. I'm going to contact Noctua too, they must have other customers with the same issues. Their fans spin up so slow compared to others. But they're the quietest fans I can find and they push around a lot of air and perform great. Just the slow spin up triggers bios warnings. I doubt Dell will fix this if I would report it to them lol.

Thanks again!

So Noctua just says the problem is not theirs despite other fans I tested not triggering the Dell warnings. Their fans spin up so slow it triggers the warning but according to Noctua their fans are ok. So I’ll just return them and try some other quiet fans as replacements for the Dell ones. I do find it amazing they not once considered the Noctua fans I got might be faulty, nope it’s 100% customers fault in Noctua’s world. Pretty arrogant stance to take.

Still it would be cool to find out how Dell actually checks this but I guess that would require reverse engineering the BIOS which is not something I can do or expect anyone else to do but it would be super interesting to know at what rpm the warning gets triggered. I tried a lot of old case fans and only the Noctua ones spin up so slowly they cause the error. I have to manually add resistance to other fans to trigger the warning.

How hard would it be be to reverse engineer exactly how Dell drives the fans?

Maye have to use a dell fan or other on that connector, and hide it in system, or try some other 3-4 pin fans, I see some luck with random fans being used in these threads…Fan/td-p/717588…/3444006/page/2

I checked using 64 00 and 00 64 / 4B 00 and 00 4B, and it seems those are not what is used at the check values area, or at least not in the delllogconfig module
I’m sure someone could figure this out, but it’s above my skill-set in assembly, sorry

Thanks and please don’t be sorry! It is a pretty unique ‘problem’ and I was thinking out loud on how to tackle it. I tried many fans and only Noctua branded one are this slow to spin up. Others spin up faster and rear whatever rpm the bios checks for before it checks it. IMHO it is a Noctua issue and up to a point a bios issue. But we can’t really expect manufacturers to allow us to enter/bypass rpm checks on these kind of pre-build systems. On a normal motherboard however it is a different story and if you go for water cooling there must be a way to disable all fan related warnings. the only thing that does annoy m is that even more expensive Dell workstations do have an option in the bios to ignore any warning and try to boot toi the OS regardless. Like the Precision models have that option but the Optiplex (a tier lower) doesn’t have it. Thanks for all your help so far!

Exactly same issue remain with my 3020m: [Request] Mod for bypass “Press F1 for continue” in 3020m and not idea over advanced bios edits.

Trying to replace the button battery model CR2032 on the main board

@stovorsen - I’m sure it can be bypassed, I just don’t know how or where to do it, the RPM amount could probably be changed too, but same, not sure where to find that to edit it

Sorry to hijack this thread but I’d be very interested in a bios mod for optiplex as well.
I use an optiplex in my arcade machine and the way it’s wired means the pc is unplugged from power when the machine is turned off. This means the CMOS battery runs out of juice every year basically.

The problem is i can’t see the Bios screen normally because the optiplex is outputting a 15khz signal to a CRT. So whenever the “Press F1 to continue screen” comes up after the battery dies it renders the arcade cabinet unusable. And if I’m not around nobody knows what the problem is (planning to install it in my office)

Would it be possible to mod the bios to remove this message for battery failure? I hope this would be more straight forward than the fan failure…