C246 WSI Bios Unlock (AMI)


recently got my hands on an ASRock C246 WSI board for a small home server.
However a lot of the performance options are hidden.
AMIBCP 5.02 shows a OverClocking Performance Menu, but i wasn’t able activate it (did not show up in bios)
Also I can not select 2666MHz dram frequency, even thought the option is also available in AMIBCP.

So I’d like to ask for help activating those options. (or better, all available options…)
I do have a ch341a flash adapter and a full dump. (sorry can’t post links yet, but here it is: drive.google.com/file/d/1uH0AQzyzmSYk9NS6XeNOcvoQd3rPRxmQ/view?usp=sharing )

Also just out of curiosity, are there any guides outlining the process to unlock options in case AMIBCP fails to do so?


Hi~MagicSmoke! I have some questions to ask you.
1.Could you capture bios screenshots ,sorry i can’t found out any bios screenshots about this motherboard in internet .

2.Or let me take a guess ,currently you can see tabs on bios interface are Main , Advanced , Security , Boot , Event Logs and Exit??
Can you see IntelRC Advanced tab and IntelRC Chipset tab on bios ?


Hi genius239,

you guessed correctly, I can see the tabs you mentioned but not the IntelRC ones. I’ve attached some screenshots for you.
Also, most the submenues are shown in the bios manual ( download.asrock.com/Manual/C246%20WSI.pdf ) but they are based on a previous bios version.

c246_wsi_screens.zip (76.4 KB)

Try thismod and respond the result to me ,thanks.

bios seems to work fine, but I could not spot any difference. ( no new tab / menu )

It’s weird ,i thought it should show IntelRC Advanced and IntelRC Chipset in bios screen.
Do you re-write mod via ch341a?

Ok~Try this one again ,and check whether there are any changes under Main tab or others.

Hey, thank you. Just tried the _2 and _3 and they show an updated main page with a lot more information.
They also have a “main” option, which opens the normal main page. Other than that, I could not spot any differences.

I’m currently flash with the ch341a, as the bios normally prevents me from flashing modded files. ( Although the “how to flash guide” now seems to include a method to allow it, I might try that one)
Flashing procedure is quite slow (with AsProgrammer: 20 mins for write + verify).

Okay! now we can know where stock Main tab is under new Main tab. Please try this one again ,and check what changes in this stock main tab or others.

I still manage to think way to let IntelRC Advanced and IntelRC Chipset show in bios screen ,but still no luck ,so on this mod i used a temporary modify method to swap the stock main tab ,please reply the result to me ,thanks.

Working great! The Main tab shows the “IntelRC Advanced” option instead of the “Main” option now. So I’am not that familiar with bios mods, but if relinking menu items is relatively easy, this would be perfectly fine:
Keep everything as in _4 and replace the “Advanced” option from “IntelRC Advanced” to "IntelRC Chipset"

Whats the difference between _4 and _5, as I could not spot any difference while testing them.
Can you share what tools you are using? (just out of curiosity)


Good news~
What i used tools are uefitool and winhex ,tool is not point understand how to edit is just best important. Please capture unlocked screenshots about IntelRC Advanced tab let me check them ,thanks.

On no.4 and no.5 mod ,in addition did swapped Main tab to IntelRC Advanced tab ,i still tried different methods to let both "IntelRC Advanced’ and “IntelRC Chipset” appears in bios screen ,but still no luck . I could confirm where blocked these two tabs in bios and edit it already ,but i don’t know why it still can’t appears on bios screen.

My beautiful plan is that let tabs [Main] [Advanced][IntelRC Advanced][IntelRC Chipset][Security][Boot][Event Logs][Exit] concurrently show in bios screen. But i still got a failure.:frowning:

Good plan, if you like the challange we move on with that :slight_smile:
I’ve attached the screenshots of the Main and IntelRC menu.
If you need any other screens, let me know.
Oh and sorry for the rather long reply delays, it has been a busy week so far …

45screens.zip (83.1 KB)

Test this new mod.

Seems perfect, “Advanced” Tab is replaced with the two IntelRC ones. Thus, “Advanced” can still be accessed through the “IntelRC Advanced” tab.
6 and 7 behave the same again. I’ve attached some screenshots. Thank you very much!

67screens.zip (119 KB)

Good news ~ you’re welcome.
This result is what i expect to see in bios screen. On my understanding , change major tab is a formal modify method ,swap sub-items is only a temporary way and it’s not perfect and it has flaw and many restrictions. Your case was done!

Good luck~!

Sorry for resurrecting this thread. Do you possibly still have the modded BIOS and could you share it with me? I have this motherboard and hope to get access to more ASPM settings. Asrock support will not provide a BIOS file with ASPM suppprt for internal nic, m.2 slot and chipset.