Can Resizable BAR Support be ported to older Intel Chipsets?

I just tried this again, to make sure I hadn’t made any mistakes. the flash completes. but when I go bak into the bios after flashing it the Bios Ver: displayed still says : E7885IMS.P71 instead of E7885IMS.P72 is that a mistake in the bios or what? and where in this new bios do I “Disable CSM” at? I know where to enable Above 4 G Decoding" that is in " Sewttings\Advanced\PCI Subsystem Settings" but I can not find anyting that refrences “CSM”. Enabling above 4G decoding by itself results in a bricked system. It’s a 2 bios Mother board, so I can recover. but just giving the information.

usually its on Settings/Boot you’ll see LEGACY + Uefi option in boot select, select UEFI only, then enable above 4g decoding and see.

But you could try to enable windows 8.10/10 whql support, then enable secure boot to user/custom mode, save and exit, go to bios again, and install secure boot keys, that way you could get a Full UEFI system as secure boot works only on uefi afaik, and then affter install secure boot keys it would ask to reboot, reboot, and go to bios again and see if you could enable above 4g decoding. Also dont mind the versioning its just my rename, wont affect anything.

So to be able to get this to work I have to enable secure boot? If so I guess I will never have it because it leaves me without many options for multi boot.

You dont, if you’re sure how to make the boot for the bios to only use UEFI instead of LEGACY+UEFI.

Found this while google searching so thought I’d chime in here.

I have an Asus Rampage V Extreme which is an X99 board and I was able to patch BIOS and enable ReBAR with the typical caveats (UEFI, Secure Boot, Above 4G, CSM Disabled). I can upload the BIOS (4101 the latest available I believe) if anyone needs it. I did read many of these replies though admittedly not all.

I have a couple of questions if anyone has the time:

  1. what’s the ideal ReBAR setting for my setup- ASUS Rampage V Extreme; Intel i7 6850k; 32GB Quad Channel RAM; Asus RTX 3080 TUF. I have ReBAR size set to 8GB at the moment (2^13) and seems to be working well. Should I attempt unlimited setting (32)?

  2. I’ve seen a few screen shots in here and comments about setting BIOS default settings hardcoded… is it a relatively easy process to set the hardcoded settings I prefer? (for instance, when CMOS is cleared/battery removed/NVRAM cleared, have CSM disabled, Secure boot, and 4G decoding on as default value)

Apologies if this has been asked already.

Hello @nasch007,

The Bar Size should be set to accommodate the full VRAM size.

4GB → 4GB
6GB → 8GB
8GB → 8GB
12GB → 16GB
etc etc

There is a tool to change the defaults that you require. It is called AMIBCP.

There is a version for AMI4 and AMI4.5 (AMIBCP 4.55) and another for AMI5 (AMIBCP 5.02.0031) BIOS types.

Best regards,


Sorry for the late reply!

I appreciate the response. I was able to set ReBAR size accordingly using the tool (10GB VRAM so 16GB is nearest). I also found the software you mention and was able to open and edit defaults with it, or so I think. AMIBCP did mention it saved the bios/capsule file without signature/unsecured. I believe this is the same for when I initially patched the BIOS with UEFITool/Patch, but it was so long ago. In any case, I can still apply this BIOS file using the FlashBack USB port method, correct?

HJello @nasch007,

I normally use AMI AFUWINx64 to program my boards.

There is a section on this page for ASUS boards and there is a link in there to a version which has support for modified files.

run the exe with the /GAN options

Any problems, I’m happy to help

Affirmative, I see on that page he recommends to use the BIOS flashback feature for ASUS. So it should work without issue.

I can be a little reckless since this board has A and B BIOSes that I can alternate with the flip of a switch.

Thank your for the linky and the information!

Hello, I have a Gigabyte Z97X Gaming 5 motherboard. I purchased an Intel Arc A750 graphics card. If I provide you with my BIOS, can you activate rebar for me?

I have i7 4790 Haswell
32 GB Ram

This motherboard doesn’t have above 4g decoding toggle in the bios itself, you might have to contact gigabyte support and see if they would give you this option (add above 4g decoding option. just ask them for it). If they did give you, you could post the bios here so that it would get archived and we could get it working.

Hello @mustafavw ,

Gigabyte often have Beta bioses for their boards that never end up on the main product support page.

If you ask them nicely, they may have a newer file than on their main page.

Good luck,


Hello, please could you share your modded bios for this board (ASUS Rampage V Extreme)?

Thank you!

Edit: Never mind, I managed to do the mod myself by following the ReBarUEFI guide on GitHub.

Sorry I just saw this in my email. I will go ahead and attach the file anyways, in case others are looking for it. Just as an aside, it does appear my motherboard/cpu combo accepts the “unlimited” setting within the ReBAR enabler. Even if you should only use 8 or 16GB (my video card has 10GB).

In one of my BIOS files I tried to have the Above 4G Encoding and Secure Boot enabled by default. I can’t recall if it was this one or not. Either way, for anyone else searching, find the modified BIOS for ASUS Rampage V Extreme in the attached .zip. (8.3 MB)

Thanks a lot!
I have checked with AMIBCP, the Above 4G Decoding is disabled by default in your BIOS, Secure Boot is also untouched.

I only tested unlimited (value 32 in ReBarState), GPU-Z got 32GB in BAR Size with 32GB of DDR5 and 24GB of VRAM.

I also share mine, I started from the latest 4101 modded BIOS I could find on Win-Raid which has slightly more recent OROM and cpumicrocodes (All bios parameters are untouched). I have not done extensive testing but its seems stable even with overclock. As always use it at your own risk!
RAMPAGE-V-EXTREME-ASUS-4101_MOD_RB (HWE 0x49, BWE 0x40).zip (8.3 MB)

You’re right. I remember what happened. I was messing around with it when I started getting blue screens and random errors. First I had to replace CMOS battery, and then come to find out that my command rate (think it was 2T, or 1T) was causing crashes.

I’ll go ahead and download yours at some point. My base was stock ASUS file, I didn’t touch oproms or microcode. For a while I was going without the meltdown/spectre updates, but that seems foolhardy to me now.

Thanks for sharing! I’ll give it a try when I have a chance.

You are welcome!

The official 4101 BIOS has these microcodes:
HWE 0x43
BWE 0x36

I believe these microcodes are already patched for meltdown/spectre.
If I remember correctly the latest microcodes solved some overclocking issues that occurred after some windows updates. The workaround was to rename mcupdate_genuineintel.dll from C:\Windows\System32

In any case with GRC InSpectre tool you can enable/disable the protection as you wish.

Seems the bios flashed successfully, and ReBar does work but it under GPU-z, ReBar shows disabled, I also checked under device manager > Display > Resources, to see if any large memory is present, there was none.


I checked under GPU-z again, under Resizable Bar:

This is what it says on my own end:

Resizable BAR enabled in bios: Unsupported GPU

Graphics Driver Support: Unsupported GPU

PCI-Express BAR Sizes: Unsupported GPU

All others says yes, using a Titan V, graphic drivers: 551.61.

I’m not sure what to make of that. It sort of sounds like ReBAR isn’t enabled in your GPU’s VBIOS. I’m not familiar with that particular card so you’d have to research it more. I know for my card, ASUS TUF Gaming 3080, there was a VBIOS update enabling ReBAR. I thankfully didn’t have to mess with it since I bought my card second hand.

Might be worth looking in to.

Got working with RTX 3060 ti and I5 8600k on gpu-z