Can‘t flash AsRock boards with CH341A

Hi there!

So I embarked on the journey to get a QTJ1 working. I got an AsRock Z370 Professional Gaming i7, had it for years with a i5-9600K. It‘s a nice board, so I wanted to use it for the QTJ1. Got myself an CH341A and got to work. I followed so e guides I found. They told me to have the power supply attached and powered (without board turned on) and to have nothing else on the board. I can read the B BIOS chip (board got two), verifies fine, but I can‘t get it to unprotect, erase or write (well, write runs through, but does nothing). So I thought AsRock dd something there to keep it protected. Then I read about people having success with the AsRock B365 Pro4, so I got one. Here the problem is that the CH341A only reads FFFFFF when the supply is turned on, reads ok without it, but every verify fails. Read five times, five different results. Unprotecting and writing doesn‘t work either.

Does anyone have any idea of how to fix this with any of those two boards? I soemt days to get this to work and really could use some help…

The B365 Pro4 could be returned. Any other recommendations if both boards are definitely no go? Preferably below 100 bucks. I also got an Asus Z270 TUF Mark 2. Any luck with that one? I don‘t know what to do

U can try the Bios_PH/1 header but…
Generally a desktop motherboard doesnt need the 3.3v/5v stand-by-power for this operation and also it can damage the SPI/Flash Programmer.
Presumably u already identified the brand/model of the SPI and checked for its specs…
Also theres plenty of software for the CH341 some works some dont, start digging and try outs as this is never a one time successful operation unless we r working on something that we already know.


Alright. I tried the Asus Z270 TUF Mark 2 today, which I could read, verify and after modding the BIOS write without problems. The QTJ1 runs on the board, but only on fist boot after powering up the supply. A shutdown and even a reboot leads to a state where the board‘s lights only flicker shortly when I press the power button, but te board won‘t start. Turning off the supply for 30 seconds and turning it on will let the board boot again. Did I do something wrong when modding the BIOS with Coffee Time 0.99? Is there a BIOS setting that‘s a no go with the QTJ1?

But I‘d still like to use the Z370 Professional Gaming i7 instead. I saw it has a connector that looks like the one in your pic above. It is just marked as J1 and isn‘t described in the manual. Can the CH341A be used for that port as well? Is there an adapter I need to buy or build?
As for the programming software: Yes, I saw a lot of programming software for the CH341A, but I couldn‘t make out which of them are suitable for flashing BIOS chips on boards. I‘m pretty new to this as one might recognize. Do you have some recommendations I could try? Could they work where AsProgrammer which is the one I tried fails?

Try NeoProgrammer. It is superior to any that came with your CH341A.

Uh, my CH341A came with none. I used AsProgrammer, it was recommended in a CH341 BIOS flashing guide. I‘ll give NeoProgrammer a try.