CH341A Cannot Find Chip after Programming, Board Bricked again?

I have an ASUS Zenbook U330AU with a bad bios, or was bad but now is worse. It is a W25q64fv chip. Before I did anything, the laptop would power on and off (lighting up the caps lock key, spinning the fan, and that’s it). The screen wouldn’t turn on or anything else. I used a ch341a programmer and a dumped bios (labeled U330AU U330AK) for my board and reprogrammed, seemingly without any real issues. Without the hard drive or battery attached, I plugged in the power and turned it on. After a few seconds the screen turned on and it went into bios. I saved settings and turned it off. Then I plugged in the hard drive, attached the battery, and put in a few other screws I had taken out of the motherboard previously. I plugged it in, but the power light didn’t come on. I tried turning it on, and nothing happens.

I have spent hours trying to reprogram the bios, but the chip is never found or detected. I know my programmer and soic8 is good because I can find and read a bios chip from another laptop. I have no clue what has happened. Right now I have nothing attached to the motherboard and it is removed from the laptop. I do not have the means to replace this bios chip. Does anyone have any theories what may have happened or if there’s anything else I can try?

For W25Q64FV use software version 1.30 and W25Q64BV as ID (1.34 works too I think, but 1.30 I know for sure) -…257455007472602

Sounds like you have a short somewhere after putting it all back together. Break it down again to how you had before you added hard drive, batter etc, and see if you get it running

System may need power cable, and or battery connected, some do sometimes, some do always. Try again with power connected. And often connection is just not good, so you need to keep reclamping until you get it, it’s not easily done on one grab usually (That’s rare in my experience)

Thanks. I first thought a short too, but I have the board completely removed and nothing has changed (there’s not much to these boards, so I don’t know what I could be missing).

I am certain I have the clamp on right because I can get it with another laptop’s bios chip, and the amber light turns on from the programmer when i get it attached just right.

It’s not about clamp on right, it’s about clamp on with good connection. I often have to grab and reclamp sometimes 10+ times before it gets that perfect connection.
The other system it may simply grab that chip easier, so you think this one should be just as simple.

It may be, whatever settings you changed bricked the BIOS again, and then you put back together and couldn’t get it started. So now, it may simply need reprogrammed again is all.
But yes, without a short I wouldn’t know what it could be, other than to try the things as I mentioned (more clamping, do with main battery, CMOS and power supply cable connected too)
Be sure you are using same software version you used before, or follow what I mentioned above, I have these chips and have tested them at length.

There is another little detail - when I plug in the power cord (or attach the battery), the little power LED light flashes on for a split second on the board. If things were normal, the light would stay on (even when not powering on the laptop).

Something is shorted then, this is sure sign. Did you release any magic smoke while placing the clip on in any previous attempts? If not, make sure nothing can be shorting and try some more

No signs of smoke, nothing is getting hot when plugged into power, nothing is dark or black. It’s a very small and compact motherboard. I’m going to call around today and see if I can find a place that can repair motherboards.

When I have the battery or power supply hooked up to the board, I can read the following voltages on the bios:

pin 1 - 0.1
pin 2 - 0.0
pin 3 - 0.0
pin 4 - 0.0
pin 5 - 0.26
pin 6 - 0.52
pin 7 - 0.0
pin 8 - 1.0

When I attach the SOIC8 device to it, I can read those same voltages off of it. That leads me to believe I probably do have it on correctly. By the way, the bios chip is a WinBond 25Q64FV. Still can’t find a short anywhere.

Those are all incorrect voltages, I don’t know which but some of them should be reading 3-3.3V

Yes, I know the chip, read back, I told you that you need to use a different ID to write to that chip (BV instead)

It’s good nothing is hot, that usually only happens if you have programmer cable on backwards, which gets hot but usually doesn’t short anything at least not the chip anyway.

I’m done playing around with this tonight. I tried each of the versions of the software you shared, plus I tried manually setting the chip to the version you recommended, but no luck. No matter what, the chip cannot be detected.

I have noticed if I ever hook up the wires wrong (like the wrong orientation for the SOIC8), it will kick off the programmer from the USB port. I never left it on that way to see if anything would get hot. This is just so maddening. If there’s a short, I should still be able to read and program the bios chip, right? Afterall, I can unplug everything (battery and charger) but nothing changes as far as detecting or reading the chip. But from what I’ve seen before, if the bios chip is bad beyond repair, the power LED should be on. ARGH!

I’d be willing to be this is due to clip/connection then. I get that a lot, and have to reclamp until I get it again. Often, but not always, system needs power supplied too (battery and or main)
Good you noticed the LED goes off if backwards, yes that usually will instantly heat up the chip super hot. In some cases that may blow a tiny resistor near the BIOS and you’d never be able to tell.

No, if there is a short, or blown resistor on the board, now the BIOS isn’t receiving the full power it did before when you could read it. Were you able to, before, read the chip without the battery and main power connected, or did you always have to have one or both?
If you always had to have one or both, and then it worked, but doesn’t now, then probably some tiny 0402 or 0603 resistor blew (you can’t tell on these when that happens, unless visible short which only happens in extreme cases, often with blow trace you see on PCB too)

Yes, you are correct, even fried BIOS you’d see more signs of life and even similar LED actions you saw before, that is why I kept thinking something is shorted or blown.

Thanks for the suggestion to check resistors near the chip, I’ll search for that later today. When I was able to read the chip before, I had the battery out of it and the charger unplugged (so no supplied power). The programmer provided all the power itself.

I took the laptop to a place that said they can repair motherboards and all they told me was you need to replace the motherboard for for $450. They didn’t try to find where a short was or what else could be going wrong. What a waste of my time. This weekend I’ll get back to trying to track it down.

That sounds like usual response from such places! I’ve you’ve reclipped many times, and all like you did originally that worked (ie no power as you confirmed now), then sounds like something shorted out which is usually not the BIOS chip.
You’re only real option now is to remove the chip and see if you can read/write ib it then, which if you are not setup for and familiar with lead-free soldering will be a pain and you may damage the BIOS legs and the pads/traces on the board.
So not ideal, but that would be my next move to confirm if chip is dead or not, if it’s not then something on board is shorted as mentioned.

Well I have progress to report. I purchased a reflow heat gun and removed the bios chip pretty easily. When I plug in power to the board without the chip on it, nothing changes (the power led momentarily fires up for a split second).

I hooked up the bios chip to my SOIC8 adapter and viola, it is recognized now. It looks like the chip is good afterall. Now I’m left to figuring out where a short must be on the board. I also was able to confirm, when I hook up the bios chip to the SOIC8, the amber light is not active on the programmer until I try to read from the chip. While the chip is in the SOIC8, if I touch it to the motherboard where it belongs, it picks up power from pin 8 and turns on the light. I would expect with the battery and power disconnected from the board, there should be nothing coming from pin 8 of where the bios chip would be. I’m left to believe a capacitor must have enough charge that’s feeding it and shouldn’t be, or should there be some charge still going to it (and if so on which pin) to keep the chip from forgetting its settings?