Change Dell logo on splash screen - Dell 5415 Rugged

Hi,

Need help to change dell logo on splash screen. My laptop is Dell 5414 Rugged.



I download bios update from Dell website. HERE THE LINK.

Extract the EXE bios update with PhoenixTool 2.73. And i get HDR file and also i found dell logo on DUMP folder.





But i dont know what is next step to flush custom bios file after i modify the dell logo. Please help me.

I send you info in PM about using FPT. Please dump BIOS region with FPT and send me that. Also, please let me know exactly what error you get when you try to write it back after you dumped it, as mentioned in PM.

* edit - After you get BIOS lock disabled, actually, before you do that. Please check if Intel Boot Guard is enabled on this system, if it is you cannot modify anything usually. Sometimes something might no be in a protected area, I’ll have to see if your logo is or not.
Anyway, check this by running MEInfoWin from the ME System Tools package, in the MEInfo folder, run this command from admin command prompt >> MEInfoWin.exe -verbose
Look at the end of the report, and see if you see Measured or Verified Boot enabled on the Left/PFP side, or show me image of the end of this report.

* Edit 2 - It doesn’t look like it’s in protected area, and made a test edit and no warning on the post-edit so I think it will be OK (in regards to BootGuard if enabled)

Please attach the image you want used, make it 1280x1280 8-Bit Indexed color BMP

However, before you can flash the BIOS I make with the new image, you have to get BIOS lock disabled and have a successful flash of BIOS region first.
Then, after that, you will have to disable BIOS lock once more, since you reflash in the stock BIOS with it locked for the confirmation of unlocking test,

Hi @Lost_N_BIOS

Continue our discussion on PM and follow your instruction, below my resut dump test

1. Create DOS USB Bootable

2. Copy Tool FPT to USB

3. Restart laptop Dell 5414 and boot laptop with USB DOS

4. Dump BIOS with command: fpt.exe -bios -d biosreg.bin (SUCCESSFUL)

photo6224341552998755037.jpg



5. Restore dump bios with command: fpt.exe -bios -f biosreg.bin (ERROR 368: Failed to disable write protection for BIOS space. FPT Operation Failed)

photo6224451422557153637.jpg



And my dump bios can download here: https://mega.nz/#!cV1mEQ4C!mEsL49c1AC778…aIOE5qFydahyDas

I got error 368 when restore dump bios. Need your help. Thank you.

Yes, I already replied about all the above in a PM. Please read my first reply today, you will find answer to above.

Alternatively, I can give you tool, that “Maybe” can flash HDR on this system, I don’t know. But for that, you will have to install windows.
But, you can disable the BIOS Lock which is causing error 368 easily, I sent you info how to in a PM.

Also, there is a trick that some BIOS have a bug that will disable this too, but for that you need windows install. Put system to S3 sleep for one minute, wake it up and try to FPT flash again, only in windows this works and only if BIOS has the bug that allow it

Hi @Lost_N_BIOS

To solve error 368 i will follow your tutorial on ==> [GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

But let say i success to flash custom bios with my own logo inside. Is possible to use same custom bios to other 5 laptops 5414 ?

Could you please share to me tutorial flash HDR with operating system ??

Thank you

No, if you flash via FPT, you will need to send me dump from each of those 5 systems, and name them so you can keep track which is which.

For BIOS Lock, again here is your variable, so you can start on step 6 of the guide - 0x542
You will need to follow the second link method I gave you, for setting up your USB to use for Grub, if your BIOS does not have an “Launch EFI Shell from filesystem device” on the exit page.
I see it there, but unsure if this is visible to you or not. If you can see it, then just follow the guide, and Rename your .efi file to >> Shell.efi

To flash via HDR, you have to do from inside windows, install an app, run it, and then it uses the HDR and creates an EXE per that system.
This, I do not know if you can use on all other systems too, probably not, it may gather asset tags and include them I’m not sure, you’d have to try 1 then 2 and see if it messes with anything.
All this also only helps if that method can actually work on your system, it does not work on all Dell systems. Here is the tool and how-to (Simple text)
http://s000.tinyupload.com/index.php?fil…649223448168866

Hi @Lost_N_BIOS

Below, what i did

1. Create a bootable USB EFI Shell. Step #6 in [GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash
Put biosreg.bin on root folder usb

2. Run command “setup_var 0x542 0x00” on the efi shell

1590e06a-1a21-4e65-9c28-69da68ef4538.jpg



3. Reboot the laptop

4. Boot with another bootable USB DOS

5. Move to FTP Tool folder and run command "ftp.exe -bios -f biosreg.bin". But i still get same error 368

8edc3733-f1c1-4ffa-b9cf-6e1e2ae36db4.jpg



I have try re-dump bios and restore dump for 3 times. But result always error 368.

As you noted, it’s already set to 0x0 No need to redump/restore etc, same original dump can always be used, once it’s unlocked.

Let me check your dump, this BIOS may be using variable from NVRAM or AMITSE/SetupData instead.
If it is, then we can try SCEWin and see if you can get dump from that, and if you can see if it’s locked there or not, if it’s 0x0 there too, then only way will be flashing via HDR method or with flash programmer.
Please wait, I will check NVRAM volumes and AMITSE/Setupdata and see if I see it locked there or not. I will edit in my findings and SCEWin for you to try too.

* Edit - yes, AMITSE/Setupdata holds BIOS Lock Enabled setting - still looking at NVRAM. Your BIOS must use this value or NVRAM one, instead of setup, so setup_var change isn’t going to help.
Please wait for further edits if you are reading now - * Edit - Yes, it’s also set over 100+ times in NVRAM Too, so your BIOS is relying on one of these things (AMITSE/Setupdata, or NVRAM) instead of value in setup module.
It’s also in 2-3 other non-standard modules too, stuck in two randomly more secure areas, as well as a “DellPolicy” module too. Seems like they are trying really hard to lock this BIOS down, you will probably need flash programmer.
And, editing all these instances will likely cause bootguard to set-off (Especially the ones I refer to latter above). Did you check MEInfoWin -verbose yet as I mentioned above? Please check now. @freddymanullang
We can probably edit your logo’s one by one, with a flash programmer, but probably cannot edit BIOS to allow unlock BIOS lock if Bootguard is enabled.
Please wait, SCEWin info coming shortly

Here is SCEWin, this must be ran from windows, preferably Admin CMD Prompt (May require this, unsure). I’d setup Win7 if you can, not XP and unsure on Win8-10
Please run 32 and 64 command in the text file, from each versions folder, do not move any files it creates, then upload entire package back to me once you are done.
http://s000.tinyupload.com/index.php?fil…597366784876205

Hi @Lost_N_BIOS ,

Im stay and monitoring your reply right now. Always refresh this page every 1 minute

Ok, now i installing windows 7 basic on the laptop. Will reply you soon. Thank you.

OK, yes, I’m done editing above now. And sorry, I believe there is a MEInfoDOS you could have ran too, I keep forgetting you didn’t have windows installed when asking for the MEINfo -verbose

Hi @Lost_N_BIOS

Get trouble on ISO file windows 7. I must re-download iso and install the laptop . I will back after it done. Thank you

Hi @Lost_N_BIOS

Sorry for late reply. I have problem with internet connection when download iso Win7. My thethering GSM has connection not more 128 Kbps. Right now my laptop dell 5414 running in windows 7 64Bit.

1. I run MEInfo on command prompt Administrator. I attach result meinfo.txt

2. Run SCWIN 2.01.1029 on command prompt Administrator

scwin-2.01.1029.jpg



3. Run SCWIN 5.00.1048 on command prompt Administrator

scwin-5.00.1048.jpg



4. Run SCWIN 5.03.1107 on command prompt Administrator

scwin-5.03.1107.jpg



5. Run SCWIN 5.03.1111 on command prompt Administrator

scwin-5.03.1111.jpg



Your help very appreciate. Thank you.

meinfo.jpg

meinfo.txt (12.5 KB)

Thanks for info, MEInfo shows Intel BootGuard is enabled, so some or all/any edit may cause failure due to this, only thing we can do is try (on changing logo) and see what happens.
For that you need flash programmer, like CH341A and SOIC8 test clip with cable. Here is cheap examples at ebay
https://www.ebay.com/itm/332735579991
https://www.ebay.com/itm/382486015977

Other than that, we can try edited HDR flash, if that method works for you (you can confirm yes/no with stock HDR).
But really, you should wait for flash programmer in case HDR flash is possible but mod HDR causes bootguard failure, if that happens you may not be able to recover without programmer