Changing the Build Date on AMI Bios?

Hi Gents,

I’m a bit of a geek in that I build & repair PCs for Family & Friends. (Probably done about 50 or 60 in the last 10 years.) It’s just a hobby. (I don’t do it for any money.) I don’t know if I’m at the level required here, but I may have to give it a try based on the project at hand. I’ve not had a lot of experience with Secure Boot enabled Bios, and normally just turn off that option to allow for Win7 installs. Almost all of my Friends and Family never wanted Win8, and a lot of them bought Win8 boxes and had me “dumb them down” to Win7.

A friend handed me an Asus S56CM Ultrabook that wouldn’t boot, that supposedly was sold with Win7, with a Free Win8 upgrade that was never acted upon. My friend thought the OS had gotten corrupted somehow. It had American Megatrends Bios Version 206 installed from Asus. It was a bit flaky in that sometimes when I went into Bios, the Cache 24 Gig SSD would be there, and other times not. But all the other devices and screens seemed to be there. So I decided to wipe the Hard Drive with it’s numerous partitions and install Win 7. Beforehand I installed Win7 63 SP1 on a spare 500 Gig HD (from the DVD) as a precaution, and it installed routinely. So I did the original drive with Win7 64 SP1 as well. Then I updated the Bios to the latest version (209). I had installed Asus’s WinFlash, and installed Version 209 quite routinely from within Windows. Typically I’ve not been a fan of doing Bios upgrades from within Windows, but it seems to becoming more as an accepted norm. And sometimes the only realistic option.

I knew that a re-flash would probably cause defaults to be set, and I expected to have to tweak a few things, but the result was terrible. Upon reboot it doesn’t boot to either Hard Drive (when installed), the Bios sees them but just won’t go there. Similarly it sees the DVD, and reads any Disk put in it upon reboot, but there’s no way to direct the Bios to boot from it. Nor will it Boot from a USB Stick even though it can recognise one when it’s plugged in. On the Boot TAB (Aptio Setup Utility) the Boot Configuration & Driver Options Priorities are grayed out and there are no options like shown in the Asus Manual.

I suspect the Bios is corrupted and I’d like to go back to Version 206. I downloaded it but the Bios won’t let me use Easy Flash as it says the Build Date is too old! So I’m asking if it’s possible to edit the Bios to show a different Build Date.

Can you advise? Any help would be appreciated.

@ Jim:
Welcome at Win-RAID Forum!

It is certainly possible to change the BIOS date within the BIOS file by using an Hex Editor, but I do not recommend to try that, because this manipulation will change the internal checksum of the BIOS and a flash may brick the mainboard completely.
Have you already done a look into >this< thread?

Regards
Dieter (alias Fernando)

Thanks for the suggestion but that is far to involved for my setup. I may just return the Laptop and advise them to go to Asus for repair.

Hy! I have the exact same problem as him and was thinking of the same solution…how big of a chance to brick the mainbord do you think there is if i change the date? Can’t this checksum be reinitialised? The notebook isn’t in waranty period anymore so sending it back to asus is the last option. Thanx!

@ Bogdan11:
Welcome at Win-RAID Forum!

Since I have never tried to change the internal build date of a BIOS and haven’t yet seen any statistics about the success/failure rate of such operation, I cannot answer your question.

Regards
Dieter (alias Fernando)

Changing the date and version is easy. Use UEFITool and check in file DAF4BF89-CE71-4917-B522-C89D32FBC59F, section AB56DC60-0057-11DA-A8DB-000102EEE626. Just replace version and/or date, while making sure nothing is shifted. That is, no addition or cutting, just replace the fields. Repack with UEFITool. The problem is that Asus is locking the regions and require secure update, only USB Flashback would work, which is missing. You have better chances with checking the options of BIOS Flash Utility or patching BIOS Flash Utility to ignore date.



Hello.

I own an ASUS k75VJ laptop, which has the very same problem as Jim told on the first post, for the same reason, I wanted to update the BIOS to the last version (Aptio K45VMAS234, I don’t remember which version it was before, 230 or 232 I think), I did it with the Windows flash utility provided on ASUS’s website, the process seemed to go without any issue, then the PC rebooted, and here we are as told in post #1

The PC boots directly to the BIOS, and once there, there’s nothing much to do or nowhere to go, the BIOS sees the hard drive (but for some reason, it seems that it can’t see anything on the second hard drive SATA port) and the DVD-drive, or even an USB key, but I can’t boot on any of these, I just can’t go to any boot-screen.

So I thought “let’s try to downgrade to a previous firmware”, so I’ve downloaded the 2 previous versions, extracted the files on an USB key and tried to reflash the BIOS with the “easy flash” tool included in the BIOS… but for each one of them, I have the same result “build date too old”, even when I try to flash again with the latest one…

So I though “OK, let’s try to find a way to change the build date”… and here I am, I’ve read your post, and I’d like you, if possible, to tell me step by step how you do that, as I know nothing about editing a firmware file.

Thanks a lot.

@ Carlos Borges:
Welcome at Win-RAID Forum!

Before you are going to modify the BIOS of your laptop yourself, I recommend to contact the ASUS support. It is their task to offer their customers a flawlessly working BIOS.
If you should get a bricked laptop by any BIOS manipulation, ASUS will not help you.

Regards
Dieter (alias Fernando)