CherryView BIOS Mod Help

Any idea and/or solution will be apriciated




@ Hackerjac:

UBU doesn’t support CherryTrail systems. You can use UEFITool to manually update modules or MMTool (not at the A032… GUID though!). Attach your SPI image or BIOS. I can check what it has inside and attach any updated modules provided that you do any updating yourself using the aforementioned tools.

Thanks alot, i’m pretty new to this, so i will try to update it myself, only way i will learn, have spi programmer so i can program bios externerly if something goes wrong

bios can be downloaded here

Ok, not a lot of stuff inside. Here is the quick rundown:

Contents 1.PNG

Contents 2.PNG



cpu000406C2_plat01_ver00000221_date18-02-2015 (Latest)
cpu000406C3_plat01_ver0000035F_date10-11-2015 (Old)

I have:




ASIX USB Lan UNDI AX88179 2.4.0 (Old)
ASIX USB Lan UNDI AX88179 2.4.0 x86 (Old)

I have:

ASIX USB Lan UNDI AX88179 2.7.0
ASIX USB Lan UNDI AX88179 2.5.0 x86



Intel CherryView GOP 8.0.1038 (Old)

I have:

Intel CherryView GOP 8.0.1040


BIOS: (Old)

I have:

There are no modules under GUID A032 so I think you can use MMTool for Microcode, LAN & GOP. For the GOP Addon (VBT) you need to adjust settings first based on your BIOS VBT using Intel BMP Tool and thus the guide by SoniX found here. The guide is for VBIOS OROM but the GOP VBT Addon is basically the same. I have included the full GOP packs for both 1038 and 1040 so that you can use the .bsf configuration file to transfer settings. For TXE you need to follow my guide here using the latest TXE firmware.

I want to thank you for the link to the tuts, the files and explanations about it, but i have now all day long been sitting, trying, trying and trying, but haven’t done anything besides replacing the lan bios and GOp GUID, tried to modify the GUID addon like in the tut, never worked, got alot of red errors and coulden find a reason why, can’t seem to find a way to replace the microcode, and the TXE is complete russian for me, so guess i just have to live with the bios as it is, but thanks again for the things you have done

I will look into it later. The toughest thing is the GOP VBT, everything else is relatively easy, including TXE. From a quick look I can see that MMTool v5 is buggy at Microcodes as well since it does not allow anything but extraction. UEFITool will work just fine though.

After getting some sleep and then looking at it again, it went better than first time, now the microcode and also TXE is done, only strugling with VBT now, will have a look at it later, and thanks again for pointing me in the right direction


I have moved this discussion at a separate thread.

Besides the GOP, which is pending for now, I have replaced the Microcode, LAN and TXE without issues. You said you did the same for MC and TXE. For MC, what procedure did you follow exactly?

I found this guide…he-x99-ami-bios

Yes, that is correct. You need to use UEFITool by replacing the bodies. Same for LAN and GOP (remove ffs container to get the .efi and replace body only). I made a SPI image with updated Microcode, LAN and TXE. The GOP is pending due to issues. Try the other three updates first. Validate the new MC by some tool such as HWInfo and the TXE by TXEInfo and TXEManuf. Not sure about LAN, maybe set it to boot from network and check the ASIX SignOn message or something to see that it works.

After 1.PNG

After 2.PNG

bios_txe_mc_lan.rar (2.81 MB)

Thanks alot, gonna go a couple of days before i try it after my dog tried to eat me ch341A programmer, so have ordered a new one, not gonna try before i have one again

unfortenly i can’t boot from lan, the tablet is locked in many options in bios, so can’t change boot sequence, and don’t have boot from lan option in the boot menu i can choose from when starting the tablet

have also tried comparing your file with mine, i must have done something wrong curse there is alot of mishmash between them, so going to ride the horse again and try another time

If you do not use the LAN PXE and, even more so, cannot even boot from it, there is no point in updating the ASIX modules. Even though it would have worked just fine with the updated (but unused) LAN modules, there is no reason to add more points of failure, so I have attached the SPI with only MC and TXE. I would use that instead when your programmer arrives.

As for differences, the MC is fairly easy because the file I gave you is not encapsulated or compressed in any way so extract body > mod > replace body should produce the exact same result. For LAN, the files I gave you before were ffs containers so you need to take only the .efi executable (body) from them and use that at "replace body". Maybe you added the entire ffs at "replace body" which is wrong. The new archive includes only .efi modules instead.

Hackerjac BIOS r2.rar (3.17 MB)

Finaly i’m starting to get the point of this, after some trail and errors i finaly figureded out how to prosses the ffs files so they where identical with yours, well it wasent as hard as it sounds

The biggest problem for me was the txe file, it kept being difrente than yours, coulden really figurer out what i did wrong, then i took a look at the command pic you have postet, noticed "Platform based on socket 1170 Braswell"
I have every time i tried to make the txe file choose CherryTrail when loading the bios, curse every where i read about the tablet and its clone the say its a x5 8300 cherrytrail, but after choosing Breawell insted the bios matchd yours
I can honestly say i have learned alot doing the last couple of days, and it has been really fun