Clean install of Windows 8 BSOD whenever I try to load Intel RST software in raid 5

I am currently setting up a new system:
Gigabyte GA-x79-up4 (rev 1.1, Bios F5)
5x250 Gb HDD in RAID 5 (boot drive/only connected volume)

I configured the BIOS for UEFI boot.

I have tried installing Windows with the iRST settings first.
My irst OpROM is 11.6.?, and I tried using the 11.7 & 12.8 F6 drivers from the Intel site during a clean Win8 install with a bios break/recreate of the raid array between attempts.
Both of these installs hung for a long time and had to be aborted. I let the first one sit for 2 hours of the HDD light flashing briefly every 5 mins or so. I aborted the second one after it started showing the same HDD activity patterns since I know this stage should have been making reasonable progress with indicators that I wasn’t seeing.

After that I broke/recreated the array and let the MS default drivers take over. This install went quickly and I made a system image on a removable disk to test from further.

I was getting very slow writes 20MB/s (previous system on ICH8R would get 80-100) and had no drive status/array status indicators, i.e. I couldn’t tell if it was still initializing except by listening to the drives make noise.
I decided to try installing the RST software from within windows. After installation, the computer booted choppily, login screen I could move mouse, but click was delayed a lot, after login, systray clicks were very delayed (30sec - 1 min).
The moment I tried to load the intel software to check the configuration, it would BSOD, consistently, but the BSOD wouldn’t even be able to write the log, so it hung there.
This scenario happened with 11.7, 12.8, & 12.9.

I started over with the RSTe BIOS settings (opROM 3.5.?), broke/rebuilt the array, started installation, used the 3.5 F6 driver.
This F6 installation worked without hanging and booted into windows.
After installing the RST software and rebooting, the computer still operated in a normal fashioin, but the systray icon took a long time to connect and display that it was still initializing.
When I actually tried to load the software, it BSODed. Consistently.

All BSODs were of the IRQL_LESS_THAN_EQUAL (iastorA.sys) variety.

This is a new system, clean install, with only drivers installed. I don’t think I installed the chipset inf on the RSTe attempt if that might be a hangup, but the iRST attempts all had clean device managers.

Has anyone had problems installing the RST drivers in Win8?
Is this something that I could reasonably think may be fixed with a modified BIOS to a newer opROM/RST matched version? I’ve honestly been trying to avoid modding my BIOS, but am considering it since I have a dual bios backup.

Almost forgot, I did an initial driver test with just 1 drive (BIOS still set to raid mode).
I added 3 drives to this and installed RST to see if I could build the array in windows. I’m assuming I couldn’t because it was a boot drive with the UEFI partitions from Windows (EFI/MSReserved/Restore), but the software loaded when I was not booting from a RAID 5 array.


@ rleidal:
Welcome at Win-RAID Forum!

You cannot use the Intel RST drivers v11.7 or v12.8 as F6 drivers, because none of the original Intel RST drivers do support Intel X79 Chipset systems running in RAID mode.
So you have to use any of the Intel RSTe drivers v3.x.x.xxxx as F6 driver, if you want to get Windows 8/8.1 installed onto a drive or an array, which is connected with Intel SATA ports running in RAID mode.
Once the OS is up, you can update the Intel RSTe driver to an Intel RST driver by forcing the installation.

Enjoy the Forum!

Hmm… the readme for 12.​0.​0.​1083, 12.​5.​0.​1066, 12.​8.​0.​1016, 12.​9.​0.​1001 from the Intel download site indicate x79 support.
I’ll try installing the RST driver over my RSTe f6 drivers when I get home.

For this situation should the BIOS still be set to RSTe?
Whole Flow:
Install Windows with F6 RSTe 3.7 driver
Install iRST 12.9 driver from within windows.

I can get Windows installed onto the array without doing anything as the Microsoft default drivers work with slow writes, but once I install any RST so far it’s been crashing when I load the software. I really just want to turn off the write flushing for increased write speed since I have a UPS.

X79 Chipset systems are only supported in AHCI mode.

If you want to use the Intel RST drivers v11 or v12, you should set the BIOS to RST support.
After having done that, you will probably be able to use the original RST drivers as F6 ones, because the DeviceID of your onboard Intel SATARAID Controller will be altered from DEV_2826 to DEV_2822.

That was actually what I tried on my first attempt. BIOS RAID=RST.
Once I loaded the F6 drivers in the Windows installer it started getting very sporadic HDD access and took hours without completing the installation.
I left one overnight to complete, but it had the choppy response in windows of 30+ sec to recognize a click.

@ rleidal:
There is another method to run the Intel RST drivers with an Intel X79 Chipset RAID system.
Precondition: You have updated the Intel RSTe RAID ROM v3.x.x.xxxx by a specially molded Intel RAID ROM v11 or v12.
In this case the X79 Intel SATARAID Controller will keep its DeviceID DEV_2826.