Clover hangs at *** scan entries ***

Attempting to boot from an nvme on an asus m51bc computer. I haven’t been able to successfully mod the bios.

I have tried the BDU tool to create a Clover bootable usb. I have also tried to download an existing clover usb image and apply it to the usb drive with Rufus.

Either way my clover is stuck at scanning entries.

I have tried searching the forum and found two others who had posted about this in the past but no solution was found.

Updating how I solved issue - never got Clover working but I used the instructions from this thread [Guide] NVMe-boot for systems with legacy BIOS and UEFI board (DUET-REFIND) to install DUET and REFIND to bootable usb. Easily booting to the nvme drive this way. Bought a low-profile usb key and have it out of the way in the back of the pc for booting.

was also struggling with the Scan entries… screen hangs there forever…
and debug log logged as


with many random try i got blessed…
I added EmuVariableUefi.efi along with NvmExpressDxe.efi… in EFI\CLOVER\drivers\UEFI … it worked for me.