CMOS checksum bad warning at boot - Can it be caused by borked BIOS flashing?


If I unplug the cord&battery, the below error message is displayed at BIOS start:

0271: Check date and time settings
0251: System CMOS checksum bad - Default configuration used

After that it starts fine. If I don't unplug error message doesn't appear.

My question:

Is it possible that Crisis flashing (or winphlashing modded bioses) somehow "borked" some checksums in some CMOS are that are not touched by regular flashing?

Would it be the reason for the checksum errors instead of a faulty CMOS battery?

I know the best way to check for the battery fault is actually changing it, but unfortunately 1. cmos battery is in a very inconvenient place 2. it is soldered and not replacable


- Last summer I flashed modified BIOSes
- Before flashing them I also exercised the Crisis recovery method with phlash16.exe (I've had a thread on that How can I change values in *.wph bios platform configuration file)
- Issue only appeared after messing with bios
- Serial number etc. are intact.

I tried:
- Changing bios settings, saving, restoring defaults etc.
- I re-flashed the original unmodified bios again and again
- I tried various flashing options of Winphlash (clear cmos, don't clear cmos, preserve DMI, renew DMI etc.)

None fixed the problem.

Real problem:

I know the situation screams IT'S A DEPLETED CMOS BATTERY.

But bear with me.

I was actively using this laptop before starting any of these modding stuff. I'm reasonably sure it didn't have this issue before messing with various BIOS jobs.

I even remember hibernating the windows and unplugging everything for doing cleanup stuff on hw. It resumed just like nothing happened without an error (and I even have screenshots with timestamps so I'm sure CMOS date wasn't reset.)

- Lenovo 3000 N200
- Phoenix Secure* BIOS (not UEFI)


Yes, you know the real problem, and it’s only that! Your first comment means CMOS battery is dead, replace with new CR3023 battery. BIOS is resetting to old date and fail safe settings once you remove power due to dead or faulty/low CMOS battery.
Flashing BIOS will not cause this, of course sometimes after a flash you may see same or similar message, due to CMOS settings are purposefully destroyed and you should always load optimal defaults once you get into BIOS
But the symptoms you described at start = faulty/low/dead CMOS battery

It’s not soldered in, no one would do that. Maybe the holder or clip is yes, but the battery should be able to be replaced. if not, and it is for sure soldered in, you will need someone with skills to replace it for you
They do not last indefinitely, all batteries can only be charged so many times before they start dying, holding less and less power, and then eventually cannot be charged at all.
Once CMOS battery voltage drops below 2.5/2.7V usually all settings will always be lost on power removal, it should always hold 3.0-3.2v

Show me image of the battery, I’ll tell you if it can be easily replaced, maybe you just don’t see how it pops out?

I see these come with PM965 chipset (OLD) and were sold when Vista came out, so yeah, it’s about time for dead/dying CMOS battery

I took some pics when I teared down it last year. Luckily cmos battery is visible. I’m attaching the picture.


I’m also attaching a screenshot of the relevant section from the mainteinance guide.


It says “backup battery” but it’s not clear whether it’s talking about CMOS battery or the laptop battery pack.

On top of that, even though it tells to “replace” it, there’s no section in the guide explaining on how, and there’s no FRU for a replacement part, either.

Judging from the pictures and the guide, even if it could be replaced with a CR2032, the mainboard would try to recharge it and it’d explode?

I know the best way to be sure is tearing it down again and measuring the voltage, but I’d really avoid it as much as possible since almost the whole laptop needs to be torn down. And again it was actually working fine until I started the bios mod project


Oh wait, you’re saying CR 30 23. It’s button like CR2032 but rechargeable, right? So you’re saying it’d plug right in. That might be worthwhile.

Thanks for image, yes, that does look like type you have to desolder to replace, unless you can pop that coin holder open maybe?
It looks like gummy or hard epoxy holding the lead to the battery, you may be able to crumble all that off and get the leads loose, pull out the battery and put in a new one and then reglue the leads back to the battery.
If not, you need someone that can solder good, to remove this, and put in a two wire type hanging replacement. Normally those go into a plug in clip, but you can just cut the clip off and solder wire directly to the pads on the board
Then double sided tape the battery in place, or hot glue it down etc

I don’t see anything mentioned in that guide snippet that looks like "Battery is not replaceable"
Anyway, it’s replaceable, just not the easy normal way. If you don’t know anyone that knows how to solder/desolder (lead free), a shop can fix this for you, probably pretty cheap.
Whoever fixes it can leave that battery in place too, for ease of doing this, in case it’s glued or epoxied down. Just cut the leads to it and leave it there, then set the new replacement off to the other side

* Edit - We already know for sure, your first comment = this and only this, always
No, mainboard always recharges CMOS, this is normal and how it always works, until battery can no longer hold a charge or be charged etc (Then you are where you are now)
Yes, CMOS is CR3023 rechargeable batteries

You messing with BIOS would give you this message once on restart sometimes, but not always, and definitely not when main power is removed each time would cause that.
UNLESS, maybe, if you erased the EC FW chip? That could possibly cause this, maybe not allow the board to know how to charge the battery etc (or that it even exists)
But this would only be if you erased some other than the BIOS chip, or messed with etc.


I’ve only now realized CR3023 is different than CR2032.

So based on the image, are you saying it’s not CR3023 (which I assume would be replaceable?)

Actually, I may have done something like that.

I applied patched bytes from Middleton’s FN-CTRL swap mod (hole0.rom) in my modded image. The laptop may have combined EC/KBC image.

I reverted it back and forth several times by flashing original bios. FN-swap reverts in that situation, but checksum errors arent.

Checksum error doesn’t occur anymore. I didn’t replaced the CMOS battery, so it looks like battery wasn’t depleted, actually.

First, I turned off “stop on error” settings in Phoenix BIOS Editor. Hovewer it didn’t stopped the errors.
Later I created a CRISIS disk and put the original BIOS file in it. I performed the recovery steps.

Now the strange thing is, it didn’t flashed the original BIOS. My customized BIOS was still intact with fn-ctrl swap and everything else. However I stopped getting CMOS checksum errors after that, and RTC is keeping up perfectly well, also.

I suspect the crisis (or the phlash16 used in crisis) may be doing something different than the winphlash I’m using normally. Though I’m still puzzled because the modded bios is kept untouched.