Coffee lake on dell optiplex 5250 All In one (7th gen)

Hi Guy’s,

I currently have a optiplex 5250 aio with i5-7500 cpu (65w).

I’m tempted to try a i5-8600 in this little gimmick.

So I extracted the hdr with the python script. → Link
With pfsextractor I get 2 8MB files → & however, none is opening in ubu.

p.s. I know that 6-core cpu’s pose a higher risk in not working then the quadcore sku’s. However, moving to a coffeelake i5 quadcore isn’t worth the upgrade imho.
So I’ll try with bridging the 2 pins and masking the nc ones.

My optiplex has no radeon m7 onboard, so only the intel igp.
If things go wrong, I have my ch341a at hand.
The chipset in this pc is a Q270. Have to check my current me version as well.

any advice in extracting my bios the right way?

thnx in advance

Intel ME is: (bios 1.11.4)

anyone can extract something usefull out of the bios?
I uploaded the original bios as well.

last option is to dump it with the spi programmer.


I dumped my bios with my spi flasher.
Now I can open it with ubu.

Seems like something goes wrong with the python script to dump the dell bios. (or dell changed it’s format)
Bios seems ami aptio V (according to ubu). However I get this with ubu on my bios dump: (not sure anymore now)

edit doesn’t seem good:

Can someone shed a light on this? I have no clue now.

Fitc does however parse it as a valid bios:

Intel (R) Flash Image Tool. Version:
Copyright (c) 2013 - 2018, Intel Corporation. All rights reserved.
1/11/2019 - 9:52:02

Using vsccommn.bin with timestamp 20:58:37 05/01/2018 GMT

Command Line: C:\Users\gebruiker\Downloads\Intel CSME System Tools v11 r19\Flash Image Tool\WIN32\fit.exe

Log file written to fit.log

Loading C:\Users\gebruiker\Desktop\optiplex-5250-aio-dump.bin

Decomposed SKU Value: "Intel (R) KBP H Series Chipset - Intel (R) Q270 - Desktop".

Decomposed PCH Strap Length: 0x5a

Warning: The ME FW image loaded has been pulled from a previously booted system. Some FW settings will not be allowed to be changed.
Writing map file C:\Users\gebruiker\Downloads\Intel CSME System Tools v11 r19\Flash Image Tool\WIN32\optiplex-5250-aio-dump\

I can find various AMI strings in the bios resembling aptio V

@ns_ripper - Are you sure your SPI dump is verified and valid? If you are not 100% sure, don’t write anything to the chip with the programmer.
All those errors in UEFITool may be normal, or not, depends on the stock BIOS. Please link me to Dell’s page for Exe download for the BIOS version you are using and I will check it
Please also upload your dump for me to look at too. I’ll let you know what I think once I can see it all

Also, with your SPI dump, use Intel FPT and dump bios region for me too, and include that with your programmer dump >> FPTw.exe -bios -d biosreg.bin

Hi, i’ve put all the files in my Google drive link.( first post). The executable is the original bios, the one with dump is the dumped one with the flasher. The HDR is the extracted drom the original. For Some reason flash tool cannont communicate.

I’ve got more succes with fptw.…lvq?usp=sharing

The biosreg.bin is the biosregion dumped with fptw.


seems like I need to lookup the pinout for the realtek audiochip on this mb.
locked descriptors …
Otherwise I can’t flash anything with fptw either.


it has a service mode jumper!

fulldump-fptw.bin is the full dump with fptw.

So tasks to be done:
- Downgrade the ME to 1.7.x
- Update vbios
- Update Microcode
- Buy the cpu
- Pin mod
- swap cpu
- Power on
- pray

I do worry a bit about the vbios.
Since I don’t have a dgpu, would the new vbios still work with my kaby lake cpu? (i5-7500)

@ns_ripper - GOP+vBIOS would need changed even if you don’t use, I think. Just make sure you leave Kaby compatibility in there if you need it, you may need to swap in kaby microcode after using the AIO Tools
I did test run with your BIOS and @Revlaay tool and it does OK, but gives error and skips HT patch, you’ll need to ask him about that in his thread, rest worked OK and original microcodes left in place + new ones added

We have AIO tools here on the forums for this kind of BIOS mod, here is links to both
AIO Tool by Revlaay - [TOOL] Easy automated Mod tool for Coffee Lake bios
CoffeeTime by Svarmod -[GUIDE] Coffee Lake CPUs on Skylake and Kaby Lake motherboards (47)

Since you have jumper, take your current FPT backup and edit the FD to unlock all regions, then you can reflash entire mod BIOS all at once with FPT, including FD and ME region too (Make sure FD unlocked again still in mod BIOS before flashing)
If you change SKU when changing ME FW (it’s required for your CPU I think), you will have to re-write FD region, so above is really a must anyway, plus with unlocked FD everything is easier later.

I checked your full FPT dump, and it looks OK. All those errors you saw previously was due to files extracted from ME are not complete BIOS regions

@ns_ripper Do you know the bios version of the fulldump-fptw.bin on this thread?

@Lost_N_BIOS Great CH341A guide and tools. I wish I had found this site and read the detailed guide before I tried the dump and then program the chip. I also have the variant W25Q128JV not listed in the software.
Long story short have a optiplex 5250 what looks to have a bad screen. Want to use external screen/monitor but unfortunately bios version didn’t allow. So I went and tried to extract dell 1.9 which fixes the external screen issue following some youtube video. Bottom line nothing worked after even when trying to program the original dump I did using the tools. This full dump seem to power back up system normally I think but still no external support.

update: Ah, I just realized the version of the bios is 1.11