CoffeeLake mod help

Hello I have an Fujitsu q556/2 small form factor computer which came with a skylake cpu. I would like to put a coffee lake cpu into it. I have dumped the bios with a hardware flasher, I then ran the dump through coffee time and added all the fixes.
I can boot the computer with my i3 8100T the only problem is I can not see the bios or the boot menu but when Windows loads everything works as expected.
I have attached my coffeetime modded bios which boots just I can not access the bios
Can anyone help me in the right direction to correcting this (4.5 MB)


Hello I have since tried a i5 7500T kaby lake on the computer and the splash screen/bios are now showing up I think the vbios for the i3 8100T is missing from the bios for it to work with it. I am at a bit of a loss as when I try to update it in the coffee lake application it makes no difference. I am not sure what I can do to fix this. :frowning:


Looked at the bios file and noticed the VBIOS was incompatible. Tried updating myself and it kept failing. Went back to a 2017 bios file (R1.14) and it succeeded.

Very limited space for microcodes so I added 906EB for 8th gen i3, 906E9 for 7th gen i5 and only had one slot left so 906EA for 8th gen i5 and i7.

Still couldn’t get the SKU hack to apply which will probably be important for higher core CPUs but should be ok for the 8100T. Might be worth looking at older revisions. (4.4 MB)


Thank you for taking the time to look at my bios. I have flashed the one you provided and it worked first time I am able to see the fujitsu logo and enter the bios with the i3 8100T.

I also found with coffee time I was unable to apply the SKU Hack its a shame the newer bios does not want to work but I am happy with it how it is now.

Thank you for taking the time to have a look at it for me! :slight_smile:

Well in case you ever want to try 6c+ cpus I did get the SKU hack to work on the r015 bios (earliest release from 2017). I think coffee mods work best if you try to use the earliest Kaby Lake bios you can find. (4.4 MB)