Current version of AMIBCP?


does anyone know what the current version of AMIBCP is?

I want to set some hidden BIOS options on a Skylake board. I’m using AMIBCP 5.01.0014. In it I can browse all the options and change them, but when I try to save the BIOS image I first get “Saving defaults to NVRAM area failed.” and then “Error occured in BIOS rebuild (#0000C00E)”. The BIOS file is empty afterwards. The last time I had problems like this, my version of AMIBCP was too old and using a newer version fixed it. So I guess it is the same here.

Or does anyone know another way to change hidden options in the NVRAM area of the flash? I have no problems unsoldering the flash IC and flashing it with an external flasher.


@robberknight :
Welcome at Win-RAID Forum!

I cannot answer for everyone, but AFAIK the latest version is dated 03/11/2015.

Dieter (alias Fernando)

Thanks for your answer. As I wrote I already have this version.

Any other ideas why saving the BIOS from AMIBCP fails?

I have the same error message "Saving defaults to NVRAM area failed." when i try to save my settings (i want to change "USB Keyboard and Mouse Simulator" from "default" to "USER"). After clicking "OK" the program stops working.
AMIBCP5x64 v5.1.0.14, BIOS v3401

Could anyone provide me with a backup copy of this AMIBCP version? :>

Check attachment

AMIBCP attachment removed:

Attaching or linking paid AMI software is not allowed!

Thank you for your understanding.