D-Link Wi-fi Dongle Stopped Working on Win 10, all of a sudden!

I am using Dlink DWA-131E1 on my PC. It is only 5 months old. It was working perfectly, until one unfortunate day, I boot up my system only to find that I am not getting any internet. It was connecting to the wi-fi, but no data is transmitted. I connected it to a different PC, and it was working fine. So, nothing wrong with the dongle. I borrowed another dongle from a friend, which was also working fine. So, somehow, that particular Dlink dongle was not working with my win 10 PC.
Things I tried but didn’t work:
Putting the dongle into a different USB port.
Restarting the system.
Reinstalling the drivers (the dlink software that comes with it)

But none of these worked. I tried putting it in a different

latest driver version is 5.12B02 for DWA-131 (E1) and this is the manual
you dont need to reinstall drivers each time.try using D-Link Diagnostic Tool and let it troubleshoot your problem.
since another device works,see if your device is not disabled in device manager,check your adapter setting if there are any unusual changes (ip configuration,device properties etc)
then check your modem’s setting.see if its blocked (by its mac adress etc)