Dead Asus N580VD laptop (GigaDevice 25B64CSIG) - "Data size smaller than chip size" warning

I modded my laptop UEFI to show extra settings like CFG Lock etc. This firmware worked perfectly for months until I changed a wrong setting. The laptop never reached the boot logo. Only the fans spinned and the keyboard back-light went on.

This laptop doesn’t have a CMOS battery to reset the UEFI(BIOS) settings to factory. Online I found info about shorting jumpers to reset to factory. I only found one called JRST2001 under RAM but this only restarted the device without booting.

So I got a CH341a flasher. The NOR chip automatically gets detected as a GD25Q64x chip, but the markings on the chip say it’s a 25B64CSIG chip.
When I make a dump the file size is 8,192KB but the .bin files are 6.144KB. Even the original .CAB file from the Asus website is only 6,146KB.

I’ve tried these 3 programs to recognize the NOR chip and write to it, but now the laptop doesn’t do anything anymore. Not even an LED when connecting the AC adapter.

These are the errors:
- AsProgrammer 1.4:Writes, but also gives a size error when clicking “Verify IC”
- Ch341a V2.2.0.0: Data position/length out of data bounds.
- CH341Programmer Special Edition: Warning! The data size is smaller than the chip size! Continue?

Am I missing something? Thanks in advance!

You should read about UEFI firmware structure. 8MB = UEFI firmware, 6 MB possibly bios region, missing FD, ME, (GbE). Open files in UEFItoolNE and compare structure!

I think I screwed up and don’t have an original dump anymore. Is there anyway I can still fix this? Ex by finding a donor from another laptop or contacting ASUS?

Please backup of the chip before overwriting it, maybe you weren’t succesfull. Read it twice, compare results, I’d recommend to read it with two different programs. Attach the file here.

Try the attached file. It’s the combination of stock bios from asus and the first 2 MB from a dump found. It’s written that ME was cleaned, and of course all your machine specific information contained in bios is lost.

After having written the file to the chip read it back twice, compare both resultswith original file there shouldn’t be any differences. I’d recommend to read it with two different programs.

stock 317.zip (1.84 MB)

Thanks for the fast response!

I’ll try that when I get home and keep you posted!

The thing is that the modded firmware was already flashed with FPTW64 and the settings were set wrong. So I read the chip to make sure it was working and I wasn’t only getting back FF values. Then I flashed the stock .bin realized it didn’t work, so I wanted to write back the dump, but I accidentally overwrote the original dump file… Very stupid, I know I normally have 3 backups of everything!

What machine specific information are we talking about? device serials, windows serial, mac-address etc? If so I might have that information.

I attached the dump I have, but I assume it’s the wrong one.

N580VD-CH341A-Dump.zip (4.32 MB)

Ok I tried the attached file but when I click verify IC I get these errors, device doesn’t boot either.




The dump you attached is consistent with what you wrote/ did. File is directly beginning with bios region, 2 MB empty (“padding”) at the end.

Open the dump you attached in Hxd, check first byte, or open it in UEFItoolNE and right click highest level, ‘Hex View’, file begins with “21 C3 FF…” Now since at least one program tells you that the first address still is ‘21’ and not “FF” as it’s supposed to be…

[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!) (19)

Thanks for all the help man, but I don’t understand this stuff at all. Even enabling the hidden BIOS settings and changing splash screens was already a challenge.
If I find someone with exactly the same motherboard and dump his/her chip, would I be screwing them over? Would there be any disadvantage for them? (If I change MAC-Address, Serial and Windows Serial afterwards)

Or do you still think I’d be able to recover without the need of a donor dump?

You should be able to recover with the file I sent you. Another file wouldn’t help you any better since you did not write the file into the chip!



I did write the file to the chip. After writing it with AsProgrammer “Unprotect > Erase > Programm > Verify” I was able to turn on the laptop again. But now the laptop just shows keyboard backlight and the fans are spinning, but it’s not booting. So I’m back at the situation I was before I had the CH341a flasher. I tried shorting JRST2001 again but that still doesn’t work.

So current state, laptop detects power and starts, but doesn’t boot to anything.


Try this file, different ME settings from different dump. That’s the problem with foreign dumps, you never know if someone might have felt the urge to be creative with the settings

Take one step after another!

Erase
Blank check
Program
(Verify)

Read content of SPI again after write
Save to file
Compare newly read file with original file (HxD, Analysis, Data comparison- or command line: fc /b file1 file2)

Stock 317_2.zip (5.33 MB)

Thanks! I can’t get the clip to stick anymore, I tried 50 times… It always jumps up. When I push it down it still recognizes it. Nothings broken off, everything still looks normal and the laptop is still powering on.
I’ll just have to hold down the clip while someone else is doing the clicking. Else I’ll have to use my soldering iron.

No luck even with the new file :frowning: Maybe because there’s no CMOS there is still another jumper that has to be shorted to clear NVRAM or something?
The laptop stays like this.

https://imgur.com/GC6ReHy

Did you read the content from SPI and compared to the original file?

Yes I did, I tried flashing it again and making 2 dumps this morning, doesn’t work. I guess contacting ASUS won’t be much of help?

Dump1.zip (5.49 MB)

Dump2.zip (5.49 MB)

I’m sorry, I doubt that I can help you here. The bios dumps I could find are different in the way Intel ME is configured, half of them has a ME configured for H110 chipset, the other halv for HM175 and some other settings different, but unsure if these differences are enough to keep the system from booting. Normally taking stock bios should be good for booting again (sometimes you’d have to boot several times since stock bios has empty NVRAM), but it seems that this bios has in addition EC firmware in the first padding. How this firmware normally would be transferred to the corresponding chip is unclear, but one can’t be completely sure that it’s not corrupted Programming/ checking this chip directly requires more advanced programming hardware. In addition are your two dump a little different, 2 characters are different. That leaves an uncertainity regarding flashing which makes it even more complicated to work in a structured way.

You might search yourself for bios dumps and flash them- maybe one will work, wait for @Lost_N_BIOS being back- maybe he has some older dumps collected, or try the pc-shop next door, maybe they can fix it. Good luck!

Could buying a BIOS chip online be a solution or would I need a whole new motherboard?

Thanks for all the help! Where did you find these dumps?
Maybe @Lost_N_BIOS can still help me.