dead windows tablet, due to wrong bios.

hello all

my tablet is cube iwork 8 air pro (i1TFD32GB17432730654). Intel Cherry Trail X5-Z8350 64bit, 2gb ram , 32gb flash. came with dual boot android and windows, and later i removed all android partition and just installed windows.

it was working perfectly till two days before, had a little issue though. The charging led was lit up all the time, and windows was showing charging always. but if otg adapter is plugged, it will turn off, and when it is unplugged, the charging indicator and red led comes back. it was also getting hot in sleep mode, and consuming battery, a full charged tablet will empty its battery completely in two days, even if completely turned off.

so i thought it was some problem with the windows, and reinstalled windows 10 again after completely wiping all partitions. but the problem was still there.

so i decided to restore bios to factory settings, again the problem did not solved.

so i downloaded firmware 酷比魔方I1-TFD(P)双系统安装文件及教程 from baidu, and flashed it. ( both windows and android) the tablet again booted with factory os. no problem at all. but the charging indicator issue was there both on windows and android.

so at last i decided to flash the bios. downloaded amibios flashing utility from ami bios website, took a backup and flashed the bios came with the above firmware package. everything finished correctly. and when i rebooted the tablet, it is dead!!!

seems like, it was the bios for iwork 8 air, and not air pro … or something else…

and so i opened the tablet and connected a ch341a programmer, detected the bios chip, flashed the same bios again, but didnt reboot.

so now i decided to flash back the backup bios. then i realised a strange thing. the backup was only 4MB, instead of 8+Mb ( the one came with the firmware).

so, now i am stuck. no bios , dead tablet, led light still turned on…

desperately searching, i found this forum. and i am attaching the zip containing the files i got. 3 bios, one of which is the partial backup of the original bios. can you people check and tell me the problem? i tried to open the files on some tools, and it all seems same to me!!!. surely because this is my first ever attempt in opening a bios file.

if some one can mod the non working bios using values from the partial backup ( i will never forgive you amiflash utility) bios to create a working bios, it will be a great help. ( those bios files should be 90% similar, because those are from same models with slight change in hardware components like lcd/wifi/ etc)

any and all helps are welcome.

NB:- due to size and file extension limitation , i had to compress the files two times in 7zip. ( 7zip first then zip it ) (3.94 MB)