del xps 730

Hi to all

I hope that this is appropriate place for my request.

I have Dell xps 730 (nvidia chipset) that is missing one option in bios. I can not enable or disable setting for AHCI. It is simply excluded. I have tried to edit bios using various tools but was unable to even open it. According to bios is is Phoenix Award bios but neither tool can open it. I have dumped bios using universal bios tool but even that can not be opened. I’m surely missing something but what i can not understand.

Is there someone who can modify bios to include ahci and sata setting (if they exist)? i can provide original exe file with bios update, original bin file that i have used and a dump file.

Thanks in advance

@ cetverooki:
Welcome at Win-RAID Forum!

According to what I have found in the net, your Dell XPS 730 has an nForce 790i (MCP55) chipset, which natively does not support AHCI at all. If I am right, it is impossible to get any AHCI support by modding the BIOS.


I believe that you are right about chip-set type. I will check tomorrow.

Only hope that I have is small info is that on this pc i have installed Samsung sata ssd and its software (Samsung magician) is reporting ahci as disabled. Not unsupported but disabled. Software might be wrong.

I doubt, that the SSD tool Magician is able to detect, if AHCI is possible or not. "Disabled" obviously means the same as "Not available".

Damn. Oh well as for now this system is working fine,

Thanks for info.

Out of curiosity how the heck do You open this bios for edit? I have tried every type of editor available and non of them can open it

If you give me the link to the BIOS file, I will try to open it.

here are both original and dumped file. A06 is original.

On other note: can I flash bios from another n force 790i ultra sli motherboard? According to pictures that i could find on web every motherboard looks same as Dell one. It is probably manufactured by Nvidia and just re branded.…LIC_v2.1%29.rar

here is bios of HP BlackBird system that uses similar chipsed and might be compatible. This was taken from…-SLP-Activation)

I was not looking right. that HP system is using 780I chipset

I was able to open the BIOS file with CBROM155. This is what I got:

Dell XPS 730 BIOS.png

As you can see, there are no Option ROM modules inside the BIOS.
The A06.BIN file can easily be opened by a Hex Editor like HxD.

This may work, but the chance to brick your mainboard is very high.

There are different bios files for same chipset. I have checked every model (visually from pictures that are on internet) and they all look same. Minor changes are in cooling solution but every component and every connection is in same place on motherboard. Nvidia is known as company that produces boards and then lets partners slap on name and model.

I will try to flash one of those bios’s. If I screw up there is raspberry pi waiting for flashing bios…

just for the record. bios for xps 730 can be substituted with bios for EVGA / XFX / Zotac 790i BIOS. Even HP Blackbird 002-01B Gaming System bios is working on this motherboard. No AHCI but still it is far better than dell bios

@ cetverooki:

Thanks for your report, which may help other Dell XPS 730 users.