Dell Dimension E520 (BIOS DM061) ICH8R ROM Upgrade 4TB disks

I Currently have a Dell Dimension E520 with the ICH8R SATA RAID Controller ROM v6.0 with BIOS rev. 2.4.0 (Latest Versions From Dell). I am wanting to turn this into a media/file server with 2 X 4TB disks in RAID1, however as I have been reading I need to upgrade to ROM v10.5 or higher to be able to use disks >2TB. I have tried the CBROM Phoenix tool with it just hanging there and not doing anything and the MMtool says it can’t load the ROM. I am pretty sure that dells from 2006/7 use Phoenix BIOSes, I would be surprised if this was an UEFI BIOS. I am also unsure if I extracted the ROM & HDR from dell EXE properly, I used “dm061-020400.exe -writehdrfile” & “dm061-020400.exe -writeromfile” from cmd.

Any help would be very much appreciated.


@ nc_e520:
Welcome at Win-RAID Forum!

Now to your question:
I doubt, that it will be possible to update an Intel MSM RAID ROM v6.x.x.xxxx to an Intel RST RAID ROM v10.5.x.xxxx or higher.
If you want to try it nevertheless and need help, you should give us the link to the BIOS of your system.


Thank You for your response.

Here is the link to the dell BIOS EXE:

I have read on people upgrading to RAID ROM v8.5 to support an SSD with success here:…-ROM/td-p/39884
In the second post of that forum there is a link to download the BIOS flash EXE with the v8.5 ROM.

Thanks again

Thanks for the link. I will try to extract and to open the BIOS file.

The v8.5.x.xxxx RAID ROM belongs to the same Technology (Matrix Storage Manager) as the v6.x.x.xxxx one, but the jump from the very old v6 MSM to any Intel Rapid Storage Tecnology RAID ROM may be too big.

@ nc_e520:

Meanwhile I have tried to open your BIOS file, but neither CBROM32_198 and CBROM_155 nor the AMI MMTool v3.26 worked.
So I am not able to help you myself.
Maybe you will get the needed support for your Dell BIOS modding project >here<.

It is a Phoenix BIOS, so you will need to run PhoenixTool, by selecting the DM061-020400.EXE file. But the OROM size might be a problem in the modding process itself, let alone in the flashing.

@ nc_e520:

You can get Andy’s PhoenixTool from >here<.

I ran the PhoenixTool and I am able to install SLIC 2.3 and save it to a new EXE, however I can’t seem to find an option to replace the Intel ICH8R firmware file. I get this message, which doesn’t seem to be a bad thing, and I’m not sure what to do from there.


I am fairly new to BIOS modding.

Thanks again

The update of any Option ROM module by using the PhoenixTool is not as easy as with official tools like CBROM or MMTool.
At first step you have to search for the Intel RAID ROM module within the DUMP directory, where the PhoenixTool has extracted all BIOS modules. The module named 20_15.ROM is the Intel RAID ROM v6.0.0.1022.
What I do not know is how to replace this module by another one and then to repack the complete EXE file.

Maybe rename new rom to 20_15.ROM and let the tool repack it once done?

Maybe rename new rom to 20_15.ROM and let the tool repack it once done?

Yes, that would be my advice as well, but I do not recommend to do things, which I have never tested myself.

Me too, I have no Phoenix bios knowledge but it seems like the logical thing to do. It was just an idea.

@ nc_e520:
Although I would really like to know,
a) how the Intel RAID ROM update will be done by using the PhoenixTool and
b) if the flashed modded Dell BIOS and its updated Intel RAID ROM module will properly work,
I do not recommend to try it.
The current Intel MSM RAID ROM v6.0.0.1022 has an uncompressed size of 57 KB and the Intel RST RAID ROM you want to insert is more than twice as large (119 KB uncompressed).
I don’t think, that your Dell BIOS, which has only a size of ca. 450 KB, will have the needed space for such a big RAID ROM file.

If I were to attempt to upgrade, and the image would be too large for the ROM would the upgrade fail and the old BIOS not be upgraded? Or would I be able to restore the BIOS to OEM via a ROM file on a USB drive or dare I say floppy disk? I have had a similar problem on my old server where the every time the power went out the BIOS went corrupt and all that was on the screen was a flashing cursor, so I had a ROM file on a USB drive that I would use to restore it.

Also the RAID “ROM” files from here are BIN files after I uncompress them, I am guessing I would just change them to ROM files by renaming them.

The worst case is a bricked mainboard (if you cannot even enter the BIOS anymore).
What you can try is to let the PhoenixTool repack the BIOS by using the updated Intel RAID ROM. It would be interesting to see, if you will get an error message from the PhoenixTool ("not enough space").
The really dangerous part is the flashing procedure.

Yes, that is what I would do as well.

I just tried replacing the file in the DUMP folder and interestingly enough it packaged an EXE for me, however it is 1KB smaller than the original! I am wondering if it packages the files in the DUMP folder or if it takes the original files out of the EXE and replaces the SLIC file only?
I cannot try flashing for another day or two as I am away and don’t want to flash over teamviewer.

I will let you know the results in a few days.

You can easily verify it by moving the .exe file into another folder and letting the PhoenixTool open it again. Then open the DUMP folder and look for the size of the Intel RAID ROM module.

I built the EXE file with the new RAID ROM and flashed the BIOS, however now the raid controller is completely gone from the system. I can only boot in ATA mode so I was able to restore the OEM BIOS and get RAID ON mode back, however strangely enough in ATA mode I can use the full 4TB, probably since I am bypassing the ICH8R controller, so I can’t use RAID 1 like I originally hoped. I think I’ll just go pickup one of those cheap PCIe RAID cards, I found a nice one that supports 4TB disks in RAID 1. Thanks for all your help.