Dell Latitude e6320 enable ME


i’m new in bios modding. I try to activate the Intel ME. Sadly i don’t ordered vpro in the past :frowning:
There is no Ctrl+P Option on Startup.

I tried fpt -d xxx.bin -> Error 26.

MEInfo says

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2011, Intel Corporation. All rights reserved.

Intel(R) ME code versions:

BIOS Version: A19
MEBx Version:
Gbe Version: 1.3
VendorID: 8086
PCH Version: 4
FW Version:
UNS Version: Not Available
LMS Version: Not Available
MEI Driver Version:
Wireless Hardware Version: 2.1.71
Wireless Driver Version:

FW Capabilities: 17897568

Intel(R) Anti-Theft Technology - PRESENT/ENABLED
Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED

CPU Upgrade State: Upgrade Capable
Cryptography Support: Disabled
Last ME reset reason: Power up
Local FWUpdate: Enabled
BIOS and GbE Config Lock: Enabled
Host Read Access to ME: Disabled
Host Write Access to ME: Disabled
SPI Flash ID #1: EF4017
SPI Flash ID VSCC #1: 20052005
SPI Flash ID #2: EF4015
SPI Flash ID VSCC #2: 20052005
SPI Flash BIOS VSCC: 20052005
BIOS boot State: Post Boot
OEM Id: 00000000-0000-0000-0000-000000000000
Link Status: Link down
System UUID: 4c4c4544-0053-3410-8031-c8c04f5a4e31
MAC Address: 00-00-00-00-00-00
IPv4 Address:
Configuration state: Not started
Provisioning Mode: PKI
Capability Licensing Service: Enabled
Capability Licensing Service Status: Permit info not available
OEM Tag: 0x00000000

Is there any Chance to activate them?

greets Ralph


The ME region needs to be reflashed in order to enable Manageability features. Your flash descriptor is locked so unless you use a programmer or some other way to unlock the FD (BIOS option which enables ME Reflash or “pinmod”), nothing can be done.

Wow, big thanks, the punmod works!

Can you help me? What’s my next job?

I dumped the ME part with fpt -d xxx.bin -me
load it into FITC
set permanent ME disable to NO
write the image

result, the written image is bigger than the source image - i’m not sure but i think there is an failure.

Another problem, i’m not able to extract the bin from the dell bios exe.

Attach the dumped me.bin file after command fpt -d me.bin -me for me to create another one with proper settings. Don’t flash anything in between, you might damage the system. You want to enable all manageability settings, correct?

ok, here is it.

yes, i want to enable all manageability settings.

big thanks :slight_smile: (3.19 MB)

Ok, all AMT/MEBx settings are enabled with AntiTheft Disabled (EOL). Flash with fpt -f me.bin -me followed by fpt -greset commands. Let me know if everything is ok afterwards.

hmmm flash was sucessful, but no ctrl+p option on boot up available :frowning:

The settings are enabled so it should have worked from the ME standpoint. Maybe it’s BIOS related with an equivalent option or non-inclusion of MEBx module. It has worked for all previous Dell users who were seeking the same result though without any BIOS changes. Attach your whole SPI image with command fpt -d spi.bin to check the bios and verify that the flash occurred.

here is it.

while Dumping there was an error 51, i solved it with length Parameter, it seems an locked part on bios chip.

EDIT:[remove SPI File]|addpics|992-1-4f40.jpg,992-2-6279.jpg|/addpics|

That system has two SPI chips, the first 2MB of the BIOS are stored at the 1st chip whereas the latter 2MB at the 2nd chip with a total BIOS size of 4MB and a total chip size of 8MB + 2MB = 10MB. That’s why the Flash Descriptor shows a full size of 10MB and why FPT shows that error. Basically the current dump is incomplete. Try FPT v8 which should work on your system, maybe that will detect both chips properly.

Regardless of the above, the ME region is at the first 8MB chip, so we can work there without touching anything else. I still advise you to use FPT v8 if it does indeed detect both chips properly. Other than that, the stock Dell BIOS does include MEBx (as expected). However, it seems I forgot to enable one option at the ME which is probably why it doesn’t work. Try again, fpt -f me.bin -me followed by fpt -greset commands. It should be ok now.

me_fix_2.rar (2.97 MB)

hey guy, you are great!

it works, big thanks!

for my mind, this file works for any e6320 now? I only had this one but i’m really interested in new things :wink:

The ME region I attached, yes, it works for all E6320 systems from Dell. But not for example the one you produce after fpt -d because it can contain system specific adjustments which can be harmful to others.

It’s actually one of the very few times that I’ve seen the “pinmod” work that “easily”. Today’s Realtek chips are so small that it’s almost impossible. For the record and to (maybe) make someone else’s life easier in the future, how did you do it?

that’s no problem, and here my report:

At first, in my case there was no Realtek chip. It was an IDT Chip. I recognized that for pinmod the soundchip is the solution. In my Modell there is an IDT Soundchip.

The tools you need:
-2 screwdrivers, cross, one small, an one very small
-a small tool to remove clips, in my case there was a penknife with no sharp edges
-a metal tweezers with a fine head
-maybe a small knife
-USB Keyboard
-USB Mous

OK, let it start.

The chip you are looking for is located on the left corner under keyboard, approximately under the key “1”.
So you have to remove the cover at the back, keyboard and touchpad (touchpad is a big unit that covers the mainboard). You will find some tutorials on internet, keywords “remove mainboard dell 6320” or “replace touchpad dell 6320”.
You don’t have to remove WLAN / WWAN or something else, only keyboard and touchpad. Just for you, In back cover you will find an marker “3 ME disable” - it’s from Dell :wink:

OK, i was looking for an jumper, so i removed mainboard completly, that’s not necessary - here a picture of it :wink: I marked chip and the location of pin 1

Connect pin 1 and 5 with help of tweezers and turned on notebook. Hold tweezers until Windows Logo appears.
Now it is possible to flash ME region. If not, pin 1 and 5 wasn’t connected correctly.

Here is the time for USB mouse and keyboard :wink:

At this point you had to use me region file from plutomaniac and flash them via fpt.

Short reboot, test if Intel ME is available. If yes, reassemble your notebook.

Important: Pimod works only until the next reboot, don’t reassemble without testing!

Have fun and a great THANKS to plutomaniac for supporting me.

greets HoRa


Great, thx for the instructions which will help other users of such a system. The fact that you have an IDT chip is probably why it was easier to perform, with Realtek things are harder based on my own and other user experience. Anyway, enjoy your AMT enabled system.