Dell M6700 A20 Bios Recovery Help needed

Dear All,
I have a Dell M6700 which was working fine until I changed the bios from legacy to uefi boot. I was in the process of setting up a jitsi server on ubuntu 18.04 but when I rebooted the fans were whirring but there was no Dell logo and no access to the BIOS any more with the F12 key. The hard drive was definitely active as there was lots of hard drive activity but no logo and a totally black screen.
After some googling I removed the battery, then the CMOS battery and held down the power key with the AC adapter unplugged to take all power out of the system. Plugged it all back in and now I still get no Dell logo, the fans whir for about two seconds and then the hard drive light comes on, so I am assuming that my BIOS has somehow got corrupted.
I even removed both hard drives from the machine and the result is the same.

I did some more googling and followed these instructions

Please copy exe bios file to the Drive C root
Go to RUN , Write CMD
write this

C:\cd<br />c:\filename.exe /writeromfile
c:\filename.exe /writebinfile
c:\filename.exe /writehexfile

" Filename.exe is the exe of the Dell bios downloaded file. "

bios file is onthe Drive C crated !

The file I am using is from the Dell website M6700A20.EXE

The only Windows machine I have is a windows 10 one from work and when I run the command it asks if I wish this program to make changes to my machine, even if I say yes the files are not in the c drive, I have tried making a tmp folder and the files things arent there either, I am assuming that if I can extract all the required bin, hex and rom files and shove them on a formatted hard drive which I can stick in the machine it might boot.

This is my first experience of a corrupted bios so any help greatly appreciated on what to do next and advice on how I might go about restoring the BIOS to its original setting.