Dell Optiplex 9020M bios error

On a normal day like any other, I open my machine and… oh, it won’t open, even though the hard drive, ram…, the fan still works but I can’t get into its bios. Then I found out that maybe the bios was faulty. i bought CH341A Bios Kit to reload bios, i searched for different bios rom (.bin) but couldn’t fix the error. I tried a shared bios .bin, I can install win, but got error Fan, Front I/O Cable failure, wrong Model of Optiplex 9020M (it recognized as Optiplex 9020), Service Tag changed. And especially no ethernet LAN.

The Original Service tag of this machine is:

  • Service tag: 8B93CB2
  • Reg Model: D09U
  • Reg Type: D09U001

Here is the bios file I found and tried to flash but failed: (4mb + 8mb)

8mb + 4mb

And here is the bios file I extracted from the .exe from dell driver web:
bios extract from .exe

Someone please help me or guide me, thank you so much!!!.

The symptoms you describe fit quite well for flashing a not completely compatible bios (9020 <> 9020M).

Please post/ attach the backup of the chips with the original “bricked” firmware.