Dell Optiplex BIOS Information

Hi all,

I’m on 4 forums and have asked the same question with zero response so far, hoping @CodeRush might be able to shed some light on this.

I am willing to try ANYTHING at this point to make the necessary modification to my PC. I had an old PC motherboard fry itself after a storm and was able to get an old working Dell OptiPlex 9010 motherboard for free from an eWaste Recycling Centre. I just want to remove the main identifier now that it is no longer under warranty etc which is the Service Tag.

I have tried the following:
*Flash BIOS to latest version A26 with silent switch ‘-wipeall’:
https://downloads.dell.com/FOLDER04326356M/1/O9010A26.exe
(http://mickitblog.blogspot.com.au/2011/0…s-switches.html)
*Dell.BIOS.Reset.iso with asset.com/asset209.com using silent switches
*Dell Command Configure command prompt using cctk.exe --svctag
*DMIEdit

Issues with those tools:
*asset.com & asset209.com appear to not support newer OptiPlex builds (OptiPlex 9010 circa 2013).
*cct.exe --svctag returned a ‘read-only’ error when trying to mod the file.
*The silent switch ‘-wipeall’ & ‘-wipeclean’ were not recognised with the new Dell BIOS exe updates.
The ‘-wipeall’ switch seems to indicate that it would do what I need “Cleans the DMI Data Area, Password, Service Tag, and Asset Tag”. It seems to put the BIOS back to a blank factory type state.
*DMIEdit throws "can’t update smbios data with pnp function on current system"

I have even tried to use an AMI tool to try and reflash the BIOS but I get a ‘BIOS write-protected’ error.

Surely someone, somewhere can find a way to wipe 6 digits?

Is the Service Tag stored in the BIOS? Or is it in SLIC? If it is in the BIOS there must be a way to flash it and blank the field? In CrystalDMI.exe I am able to see the ServiceTag and asset data.
I also found this but I’m not sure what it is or how to use it: https://github.com/dell/libsmbios

Can’t you just swap the bios chips on those motherboards- if those are in sockets?
Well… NVRAM with this Tag could be on another chip but it’s worth a try.

service tag is an editable field INSIDE the BIOS.
just enter the BIOS and delete/edit it.


No the field is greyed out, the Asset Tag field is blank and editable but the Service Tag field is not. I was able to remove the Asset Tag using the asset209.com tool from Dell but when I tried to do this to the Service Tag it couldn’t and threw a ‘Write-protected’ error?


I’m no expert but if the chips below the RAM slots are the BIOS chips you refer to then they are soldered to the board: https://c.76.my/Malaysia/dell-optiplex-7…ginner28@14.jpg
I did read that if you short the right legs on the chip using a paperclip you can reset the BIOS password, wonder if it is possible to get it to revert to factory state? I wouldn’t know how to do it on my board or which chip to do it to: http://icheckinu.blogspot.com.au/p/blog-page_4111.html

Any other ideas?

I managed to remove several service tags on Optiplexes, from 755 up to 960 and 790, inside Bios did you remove all security and passwords before any attempt?

I don’t understand what is the issue here.
Service tag doesn’t affect platform’s function in any way, it doesn’t prevent anything from working as expected, why touching it?



Licensing, I want to put my Windows 2012R2 SSD in it which is all preconfigured ready to go. When I called Microsoft to reactivate it they could see it was a new mobo and they must have some sort of link with Dell as they asked me and said is it a Dell OptiPlex 9010 and they advised that it was already registered against another volume license to a previous company. They said without authorization from the company technician they could not change the license or activate a new one on that motherboard, now as it was eWasted the company policy is to recycle/destroy not give away free tech so they won’t transfer the Service Tag.

I have managed to get the BIOS .rom file and can open it in AMIBCP v4 as it appears the Dell BIOS is Aptio 4, I can see the data fields that I want to modify and think I have done that successfully but I am not quite sure on how to reinject the .rom back into a Dell BIOS update executable?



Yes there are no BIOS passwords, what other security would there be? This is what my BIOS looks similar to: http://en.community.dell.com/cfs-file/__…8/5481.BIOS.jpg

Got it. Can you provide the dump and the value of service tag so we can search for it there?

Hope this is what you mean by dump? https://www.sendspace.com/file/3pard9

I’ll PM you the ST

Just an update I’m still working on this, think a solution has been discovered and will provide a full write-up once it’s worked out.

Did anyone figure out how to change the service tag?

What was the solution please?

What is the solution???

Give BIOS dump and changes you need made, and you probably need a CH341A flash programmer and a SOIC8 test clip jumper cable to write the BIOS back once it’s edited. You may not need programmer, but order one now anyway since they are $3