Dell Precision 7540 (ES) bricked by BIOS update

Hello, long time lurker, first time poster here, looking for some help.

I have a Dell Precision 7540 (Engineering sample) with an QQLS cpu, and up until now it was running without issues on a 0.6.1 or something like that engineering BIOS.
I’ve tried to update the BIOS in the past because the fan curves on this version are a bit annoying but i could never do it, since the laptop would not flash it, it would restart when trying to install BIOS, but then get stuck in a couple restarts and then come back on with same old version.
Then i thought to myself that there is most likely a protection placed since production BIOS-es probably don’t have the microcode for the ES cpus, so i’ve stopped trying and settled with what i have.

Fast forward a couple of months and after a reboot of windows i get to a BIOS update screen. I guess Windows update somehow managed to sneak in the BIOS update, and the laptop let it get thru.
To my surprise it flashed everything one by one and then gave the green text saying that everything has been updated successfully. After a reboot however, the laptop doesn’t POST anymore.

It starts, leds turn on, stays on for about 40s, then the fans ram up to max and a second later it turns off and turns on again, constantly repeating this cycle.

I’ve tried doing the Ctrl + Esc flash but it looks like the system doesn’t access the USB.

Does this sound like a microcode update might help, and if so, what should my next steps be?


Well, get a programmer, dump the fried bios, maybe there’s something of the old firmware or the machine specific data still recognizable. Try to find your old bios again from Dell, and flash via programmer. There might be recovery procedure, but it’s better to save what’s left of the firmware first and check which regions got overwritten…

Regarding the engineering sample- that might be bad luck, if you don’t have a backup of the old bios/firmware there might be no stock bios available that works with ES hardware. In addition these Dell bios don’t contain a complete firmware image.

I have a programmer, i’ll disassemble the laptop today if i get the time. Old bios is nowhere to be found, the oldest version i’ve found was 1.0.0.
Yeah that’s what i figured too :/… and as i understand i can’t just go around changing thing in the bios dump thanks to the “bios guard”?