Dell Precision T1700 Bios Recovery

I tried updating a T1700 to A28 Bios. It appeared to go successfully but after reboot I get no output on the screen and no post beep. If I take all memory out I do get the beep for no memory.

After going over some of the update details, on Bios A10 it says “We do not recommend you to upgrade to A10 BIOS if your system doesn’t support Thunderbolt hardware.” Which this system doesn’t have. Not sure if that is the problem.

This is the link to the A28 Bios
dl.dell.com/FOLDER05650668M/1/T1700A28.exe

I believe ME Version │ 9.1.45.3000

2 Bios chips.

25Q064A 8MB
25Q032A 4MB

I believe I was able to get good reads using CH341A programmer.
I followed the cleanup guide but don’t want to overwrite without someone checking my files.

This is my “cleaned” up file.
drive.google.com/file/d/1T0wAPQlaMRAD0yIfeKP0RDN2FWmZRKn-/view?usp=sharing

n25qo32a-1st.zip (2.38 MB)

n25q064a-hasgoodinfo1.zip (4.12 MB)

Although I doubt this is ME firmware related, the ME-cleaned SPI image is correct. The only thing different from my own outimage is that you forgot to disable Anti-Theft Technology, as explained at step 5. Other than that, exactly the same.

Thank you!. I will revisit Step 5. Initially I was following the wrong guide, then jumped to the correct one but overlooked step 5.
Sorry if I posted in the wrong section. I had information overload, wasn’t sure were to put it.

Cleaning ur ME FW image has nothing to do with bios recovery…unless ur cleaning a dirty image from another dumped system as not urs.
Or corrupted…but according ur description wot failed was the bios update procedure.
No Dell recovery procedures worked or tried?

I guess it would fall under failed bios update procedure.
As far as I can tell, this model doesn’t have the bios recovery. From what I read they started in 2015 with certain models and this one wasn’t on the list, system is from 2013.



If the 4MB file code is the same as when I read the 25q032a do I still need to write it?

If the system still does the same as before, can I try a bios downgrade? Any recommendations on which version to try to downgrade to or can downgrade to?


The 2nd SPI chip (part 2 of BIOS region) does not hold ME firmware data so its contents are probably exactly the same before & after the guide. Of course you don’t have to re-flash it if it’s the same. But as I said, this should be a BIOS issue, not ME.


You can do anything with a programmer at hand. I can’t recommend on what to choose for that specific model, you’ll have to test it. Use UEFITool to “Replace as is…” the 6MB (0x600000) BIOS region from the stock Dell update and see what works or not. You can extract the Dell BIOS update images via Dell PFS BIOS Extractor.