Dell Precision Tower 7810 BIOS Problems

@MeatWar I’m sorry, I wrote some responses in his second thread:

There are at least 5 threads about the same machine:

This hopping over several threads makes it impossible for me to follow / see what he already had done, in addition it’s unclear what he wanted to achieve- modding, repair, modding and repair?

ME config was different in some of his images I looked at, at this point i stopped following these threads.

1 Like

hi sorry about different threads can i merge them all to one

this was a full spi read in windows fptw tonight after dell fw bios flash it didnt flash correctly
not sure what i should try.

and thank you im learning as i go
fullspi.rar (6.5 MB)
what im trying to do is remove the microcode and unlock over clocking i can only ever seam to get one or the other and when i try to go for both i end up messing up.

Hi quick question can’t seam to find an answer anywhere

I have a dell 7810 my soic clips is not holding the bios chip very well and don’t want to solder

But I saw this service mode pins are they usable

Well that worked service mode enabled

still getting error 284 failed to load driver pci access for windows

Install the MEi 9.x driver for the OS, nothing related to fw but the tool needs the driver.

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (

EDIT: If cant see nothing in the device manager the driver fails to install as there no device present, the ME is disable, did you?
You need to put the machine back on normal, NOT in Service mode, i guess, i cant remember all those peculiar details/methods for every fxxxxx machines around the world…
And users in order to help could enjoy some capture screens running the tools/errors/device manager etc…helps a lot and saves time and brains you know…
When a user says oh can see this or that, we really dont know if he knows what to search for or his
knowledge of it…

EDIT: humm i guess that… better no comments. Good luck.

Platform not suppoted cant see anything in device manager either

i have checked in hwinfo and dont even see anything to do with me im guessing i broke it somehow

I think im getting little steps forward it’s fun learning all this
Me still not working but i can flash from dos so going to try flashing me from dos

So I just got new soic clip making sure I have my wires correct but a few different sites say different pins on the pi

That’s my chip but flashrom site says

25 GND
24 /CS
23 SCK
21 DO
19 DI
17 VCC 3.3V (+ /HOLD, /WP)

So 3 wires to pin 17 on pi which is 3.3v

W25Q128BV Datasheet PDF Download - Winbond (

EDIT: Not an easy task for inexperienced users… the issue is the firm contact and a good clip will help.

Yer same pin out so I’m just trying to get the 3 wires to pi header 17 on pi.
Pins on the soic clips so close together

Now flashing is it advisable to flash twice

flashed successfully and verified turn pc on not changes what am i missing i did clean me but still not working
newdump.rar (6.5 MB)

What did you want to achieve and what’s not working?

hi so my intel me has stopped working so i followed the clean me guide and connected the pi and it flashed loaded pc back up to no change am i doing something wrong?

just to confirm
pc is unplugged when i have the flash programmer connected and once it says verified i power down pi before disconnecting but it doesn’t seam to flash the whole chip

Your image does look rather OK, but you didn’t follow the guide to the point since Intel AntiTheft is still enabled. But that doesn’t cause thiese symptoms.

Regarding flashing: If not sure just read the chip in a separate process and save the spi- content with a different name. Compare it to the original file intended to flash, they should be a 100% identical (if the system wasn’t started in between)

The jumper has to be removed again.

Btw- why a new separate thread?

which jumper do you mean and the pc is off when i flash it

Didn’t you bridge the service mode pins?

yes but that didnt work a second time for some reason