Dell Precision Tower 7810 BIOS Problems

So I just got new soic clip making sure I have my wires correct but a few different sites say different pins on the pi

That’s my chip but flashrom site says

25 GND
24 /CS
23 SCK
21 DO
19 DI
17 VCC 3.3V (+ /HOLD, /WP)

So 3 wires to pin 17 on pi which is 3.3v

W25Q128BV Datasheet PDF Download - Winbond (

EDIT: Not an easy task for inexperienced users… the issue is the firm contact and a good clip will help.

Yer same pin out so I’m just trying to get the 3 wires to pi header 17 on pi.
Pins on the soic clips so close together

Now flashing is it advisable to flash twice

flashed successfully and verified turn pc on not changes what am i missing i did clean me but still not working
newdump.rar (6.5 MB)

What did you want to achieve and what’s not working?

hi so my intel me has stopped working so i followed the clean me guide and connected the pi and it flashed loaded pc back up to no change am i doing something wrong?

just to confirm
pc is unplugged when i have the flash programmer connected and once it says verified i power down pi before disconnecting but it doesn’t seam to flash the whole chip

Your image does look rather OK, but you didn’t follow the guide to the point since Intel AntiTheft is still enabled. But that doesn’t cause thiese symptoms.

Regarding flashing: If not sure just read the chip in a separate process and save the spi- content with a different name. Compare it to the original file intended to flash, they should be a 100% identical (if the system wasn’t started in between)

The jumper has to be removed again.

Btw- why a new separate thread?

which jumper do you mean and the pc is off when i flash it

Didn’t you bridge the service mode pins?

yes but that didnt work a second time for some reason

so my file for flashing checked the vcc volage im getting 3.1v but my chip can go 2.7v to 3.6

C:\Intel ME System Tools v9.1 r7\me_cleaner>me_cleaner 7810.bin
Full image detected
Found FPT header at 0x15010
Found 1 partition(s)
Found FTPR header: FTPR partition spans from 0x160000 to 0x210000
ME/TXE firmware version (generation 2)
Public key match: Intel ME, firmware versions 9.0.x.x, 9.1.x.x
The AltMeDisable bit is SET
Reading partitions list…
FTPR (0x00160000 - 0x000210000, 0x000b0000 total bytes): NOT removed
Removing partition entries in FPT…
Removing EFFS presence flag…
Correcting checksum (0xf9)…
Reading FTPR modules list…
UPDATE (LZMA , 0x1c6487 - 0x1c66b1 ): removed
ROMP (Huffman, fragmented data, ~1 KiB ): NOT removed, essential
BUP (Huffman, fragmented data, ~70 KiB ): NOT removed, essential
KERNEL (Huffman, fragmented data, ~226 KiB ): removed
POLICY (Huffman, fragmented data, ~99 KiB ): removed
ClsPriv (LZMA , 0x1c66b1 - 0x1c6a8a ): removed
SESSMGR (LZMA , 0x1c6a8a - 0x1d2413 ): removed
SESSMGR_PRIV (LZMA , 0x1d2413 - 0x1d7d03 ): removed
HOSTCOMM (LZMA , 0x1d7d03 - 0x1e0035 ): removed
TDT (LZMA , 0x1e0035 - 0x1e53fa ): removed
FPF (LZMA , 0x1e53fa - 0x1e6ef9 ): removed
The ME minimum size should be 1560576 bytes (0x17d000 bytes)
The ME region can be reduced up to:
00015000:00191fff me
Checking the FTPR RSA signature… VALID
Done! Good luck!

7810.rar (3.7 MB)
nope still didnt work with verifed flash im out of ideas bios part flashed

ME cleaner removes afaik as much as possible of the ME, that’s completely different to what is described here:

Dude as soon as I read that I knew I messed up but just home now and I’ll try again.
That will teach me to try bios modding while smoking blame Canada haha

this was the back up of my bios from the pi after verification it doesnt look right to me
pc booted back up but no change

Fixed: Yes

Base: 0h

Address: FF000000h

Offset: 0h




Full size: 1000h (4096)

PDR region offset: 1000h

GbE region offset: 11000h

ME region offset: 15000h

BIOS region offset: 800000h

Region access settings:


GbE: FFh FFh

BIOS access table:

Read Write

Desc Yes Yes

BIOS Yes Yes

ME Yes Yes

GbE Yes Yes

PDR Yes Yes

Flash chips in VSCC table:

1F4700 (Atmel AT25DF321)

1F4701 (Atmel AT25DF321A)

1C3016 (EON EN25Q32)

1C7016 (EON EN25QH32)

207116 (Micron M25PX32)

C22016 (Macronix MX25U16)

C25E16 (Macronix MX25L32)

20BA16 (Micron N25Q032)

BF254A (Microchip SST25VF032B)

EF4016 (Winbond W25Q32)

EF6016 (Winbond W25Q32)

EF3016 (Winbond W25X32)

C84016 (GigaDevice GD25x32)

1F4800 (Atmel AT25DF641)

1C3017 (EON EN25Q64)

1C7017 (EON EN25QH64)

207117 (Micron M25PX64)

C22017 (Macronix MX25L64)

20BA17 (Micron N25Q064)

EF4017 (Winbond W25Q64)

EF6017 (Winbond W25Q64)

EF3017 (Winbond W25X64)

C84017 (GigaDevice GD25x64)

C22018 (Macronix MX25L128)

EF4018 (Winbond W25Q128)

EF6018 (Winbond W25Q128)

C84018 (GigaDevice GD25x128)

It’s not meaningful to write in two parallel threads and to post dumps in both threads, that does make it impossible to follow what you did and what the original state was.


Seems in addition that you have changed ME configuration several times. It’s not possible to follow what you did and what the original state was.

In case of problems with ME: Use your first ever dump, follow that guide to the letter:

So went back to the first ever dump and got the me onto new bios and it worked me info was showing and meb showed up in boot select.
Turned it on today and it’s back to locked.

Yer my bad I tried to close it but not sure how.

thanks for the help man im not at the stage where i get past post and into boot select then dell loading screen crashes, automatic fix doesnt work either

so load the efi shell
run me info the as above i did see the gbr config lock is enabled still would that stop a complete write and stop boot
also oem id and system id are different would that matter