Dell Precision Tower 7810 BIOS Problems

hi so i did something on my first flash with the intel me and now i cant get it to work tried flashing back to oem bios and reflashing but i must be doing something wrong

Fixed: Yes

Base: 0h

Address: FF000000h

Offset: 0h




Full size: 1000h (4096)

PDR region offset: 1000h

GbE region offset: 11000h

ME region offset: 15000h

BIOS region offset: 800000h

Region access settings:

BIOS: 1Bh 1Ah ME: 0Dh 0Ch

GbE: 08h 08h

BIOS access table:

Read Write

Desc Yes No

BIOS Yes Yes

ME No No

GbE Yes Yes

PDR Yes Yes

Flash chips in VSCC table:

1F4700 (Atmel AT25DF321)

1F4701 (Atmel AT25DF321A)

1C3016 (EON EN25Q32)

1C7016 (EON EN25QH32)

207116 (Micron M25PX32)

C22016 (Macronix MX25U16)

C25E16 (Macronix MX25L32)

20BA16 (Micron N25Q032)

BF254A (Microchip SST25VF032B)

EF4016 (Winbond W25Q32)

EF6016 (Winbond W25Q32)

EF3016 (Winbond W25X32)

C84016 (GigaDevice GD25x32)

1F4800 (Atmel AT25DF641)

1C3017 (EON EN25Q64)

1C7017 (EON EN25QH64)

207117 (Micron M25PX64)

C22017 (Macronix MX25L64)

20BA17 (Micron N25Q064)

EF4017 (Winbond W25Q64)

EF6017 (Winbond W25Q64)

EF3017 (Winbond W25X64)

C84017 (GigaDevice GD25x64)

C22018 (Macronix MX25L128)

EF4018 (Winbond W25Q128)

EF6018 (Winbond W25Q128)

C84018 (GigaDevice GD25x128)

im tring to unlock the bios lock with local FW and a few other offsets i have found but in order to do that i have to have Manageability Application Configuration enabled but with me disabled i cant do anything
been reading [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
but im getting lost and my file size is messed up now can anyone help
i have pi spi flasher

backup1.rar (3.7 MB)

now i cant get the soic clip to stay in place i think this is ready to be flashed if someone wants to have a look
7810.rar (6.5 MB)

hi all after lots of reading and help from people on here i managed to dump bios with pi and soci clip i have no problem getting my fd unlocked or any other locks off now i have modded the mb to make the service pins usable.

my issue is every time i flash bios back even with minimal changes - remove microcode for the Haswell, enable overclocking feature/overclock lock, i tried to enable a few bios features but that never works even after changing to user,
i cant get past dell recovery logo just hanges and crashes but i can get into bios and f12 boot menu

the procedure i use is

  1. power off pc
    2.unplug pc attach soci clip
    3.conect soci to pi
    4.power pi up
    5.flash chip now errors
    6.turn pi off before removing soci clip
    7.clear cmos
    8.plug pc back in

am i missing something in my procedures.

i reverted to the latest dell bios A34 and want to try again.
i few places i have read the smbios version 2.8 has been leaving user with the same boot loop problem can anyone shed some light on this if possible.

thanks for help

How are you “touching” those features? AMIBCP tool?
Are you modding an original dell bios update file, a full spi backup or a bios region?

AMIBCP wont work on all modern Aptio V bioses as it was in Aptio IV, thats why you can see a lot of users that must use RU/IFR extract tool and hex edit the variables/strings.
This is due NVRAM DEFAULTS and other modelas besides the SETUP, this must be done with RU/IFR extract tool and edited. The strange part is only modding the mcodes, your issue still persists…

Its better to work on a bios region and use the FPT tool to flash only the bios region, not touching other regions.

EDIT: I said Bios_region only, not the full spi dump. This dump has ACM/RSA…this is not welcome in modding.
Try just the mcodes with AMI MMtool or UEFItool besides UBU, on the region.

According to the ME of your system:
Dumping: FPT -bios -d biosreg.bin
Flashing: FPT -bios -f biosreg_mod.bin

This is not an easy bios to mod…too much Dell in it, in structure/modules/NVRams…

EDIT: Ok then you understood it… but here it gives 8 388 kb not 8 192…
HEX edit was not ment to mcodes, that was used in older 1/2/4Mb bioses.
I opened the file with MMTool and UEFI…too much of Dell DXE/PEI in it, not a bios to touch myself, sry.

1 Like

thanks for reply MeetWar

yes full spidump of orignal dell bios read advise to always use orignal bios before flash

yes i was enabling features in AMIBCP thanks for the info it wont work on Aptio V wont use anymore

i have tried the RU and Setup_var
RU changes vales but found i get maybe 5 mins in the program before it crashes and pc restarts
modgrub it changes the values but some wont change
Setup_Var_CV IntelSetup 0xEB is my bios lock varible set it 0x0 to disable but doesn’t seam to work.

this is the bios dump it got from fptw if i editor this bios and flash this back either with fptw or spi flasher?

not very good with hex editiing will read more about it now
7810-bios.rar (3.7 MB)

just ran this through ubu extracted the microcode’s
mod_7810-bios.rar (3.7 MB)

thanks MeetWar
Im confused what you mean bios region when i do full dump the file is 16384kb the dump i did was fptw -d 7810-bios.bin -bios
and it game me the 8192kb bios file.
I have the mcodes extracted but been looking into what you said about hex editing.
this is what im trying to read up on today as im lost so far

0x38335 Setting: Overclocking Lock, Variable: 0x1271 {05 91 6A 12 6B 12 75 0C 01 00 71 12 10 10 00 01 00}
0x38346 Option: Disable, Value: 0x1 {09 07 41 0A 00 00 01}
0x3834D Option: Enable, Value: 0x0 {09 07 40 0A 30 00 00}

thanks for looking im gonna to remove mcodes with mmtool and flash back then try with ru to do overclock.

this may be beond what you know but there is an overclock feature in the dell bios i wonder do i have to enable that first to be able to enable overclock lock

So I took the bios region extracted the mcodes with mmtool shut down Pc
Service mode jumped on
Fptw -f biosregion -bios
It worked all verified I flashed it first with rewrite
Did greset
Cleared cmos load default bios

Still stuck on preparing dell automatic recovery and then reboots

hi after a bit of help so im goin throw my UEFI and came across this
Section_PE32_image_PchBiosWriteProtect_PchBiosWriteProtect.rar (1.5 KB)

i cant seam to extract it anyone give me a hand thanks

I should be able to see it in the ifr extracted platform but all i get is Intel Ref.code setup hide

this is for the AMI AptioV UEFI EDITOR i get my bios lock sorted but trying to see if it possible to remove the FPRR from my bios

i have 5 7810 all with dual xeons and 2 5810. 3 of them i salved from going to a skip and the others i have aquired when my client upgrade there workstations

Are you still fighting with that Dell 7810? If so why new posts… users will see it (The origianl post) when updated or edited and this way a new user can get a clear picture of the initial issue else is gonna ask you again the background of it…

1 Like

hi MeatWar

the reason asking is because i dumped the bios from fresh dell via flashrom on my pi with
–wp-disable got the bios only removed the microcode checked on me analiser all looked good reflashed back it then
Verifying flash… FAILED at 0x0001cd81! Expected=0x4e, Found=0x6e, failed byte count from 0x00000000-0x00ffffff: 0x1af Your flash chip is in an unknown state…
so erase reflash this time all verfied no errors

power off unclip.
boot computer
MESPILOCK failed ME FW VERSION downgrade failed
Error sending End of Post message to ME

i tried to run dell bios flash update from F12 menu it deosnt load

so i did the clean dumped intel engine guide reflashed via flashrom but still errors on boot cant get into bios flash upgrade.

that’s why i was asking was trying to figure it out on my own but i cant seam to do it.

So I managed to get dos bootable usb flashed dell original bios back checked the me same FW but still didn’t clear errors and take ages to boot what would your suggestions be now

ok so is F12 back to normal again or you have this again?: MESPILOCK failed ME FW VERSION downgrade failed
Error sending End of Post message to ME

The “ages to boot” usually is an issue in the ME FW image of the system and most users get it solved by the procedure you did before, cleaning the ME following the guide on this forum.
There could be issues of NVRAM and/or Dell specific system ids/tags/security chip…these systems/motherboards are not easy to work with…

Gonna be honest with you, my in depth knowledge in this recovers of this kind of motherboards is limited.

EDIT: I dont want to point out to the SPI chip but… ive seen a bit of all.
There are 2 methods to clean, using full spi dump or just ME dump…try both cleaning methods.
I found that ME issue on many 100 series motherboards when they came out, cleaning the ME always fixed.

Hey buddy can you give your opinion in this user issue, thank you.

No still get ME FW version
And failed to send end of post message to ME

I can’t now get into windows again but takes a long time

Yes used the guide on here

I even compared a dump from fptw and one from a working backup and they are the same which leads me to think the bios chip is corrupt

So fptw -I shows all regions unlocked on the FD I can do full backup and flash it back but when I try to flash I get hardware sequence error

@MeatWar I’m sorry, I wrote some responses in his second thread:

There are at least 5 threads about the same machine:

This hopping over several threads makes it impossible for me to follow / see what he already had done, in addition it’s unclear what he wanted to achieve- modding, repair, modding and repair?

ME config was different in some of his images I looked at, at this point i stopped following these threads.

1 Like

hi sorry about different threads can i merge them all to one

this was a full spi read in windows fptw tonight after dell fw bios flash it didnt flash correctly
not sure what i should try.

and thank you im learning as i go
fullspi.rar (6.5 MB)
what im trying to do is remove the microcode and unlock over clocking i can only ever seam to get one or the other and when i try to go for both i end up messing up.

Hi quick question can’t seam to find an answer anywhere

I have a dell 7810 my soic clips is not holding the bios chip very well and don’t want to solder

But I saw this service mode pins are they usable

Well that worked service mode enabled

still getting error 284 failed to load driver pci access for windows

Install the MEi 9.x driver for the OS, nothing related to fw but the tool needs the driver.

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (

EDIT: If cant see nothing in the device manager the driver fails to install as there no device present, the ME is disable, did you?
You need to put the machine back on normal, NOT in Service mode, i guess, i cant remember all those peculiar details/methods for every fxxxxx machines around the world…
And users in order to help could enjoy some capture screens running the tools/errors/device manager etc…helps a lot and saves time and brains you know…
When a user says oh can see this or that, we really dont know if he knows what to search for or his
knowledge of it…

EDIT: humm i guess that… better no comments. Good luck.

Platform not suppoted cant see anything in device manager either

i have checked in hwinfo and dont even see anything to do with me im guessing i broke it somehow

I think im getting little steps forward it’s fun learning all this
Me still not working but i can flash from dos so going to try flashing me from dos