Dell R210 ii - bricked bios, maybe

Hello folks,

in my desperation and research I stumbled upon this forum, where you could maybe help me, or at least shed some light on the matter.

I bought a used Dell R210 II for my homelab, popped in the bootable ISO to update all the firmware - it flashed some things, said to wait, the screen got black… and eventually I rebooted - only to find out that the machine doesnt post.

Those of you familiar with Dell servers, will know that they have a remote management solution called iDrac. IDrac reports the last boot as 0x0 No POST… it also reports the BIOS Version as 1.2.3, the flashed version should be 2.8.0, so im not sure if its really bricked since idrac can “detect” the version…

on reddit, someone offered to dump his chip, all i needed was a usb programmer and a soic8 test clip to write the dump… ive ordered those, but the person hasnt responded in a few days, so my question is:

1) would this even work? looking at the forums, there might be more this, like something called the ME region…

2) would anyone happen to have a r210 ii, who could dump the bios?

3) i dumped my “broken” flash, is there a way to validate the dump… to check if the bios is indeed screwed? here is the bios with the chip name detected by the ch341a:…LZxB9KteHQGmmXz

I appreciate any help and/or other suggestions

@NeXs :
Welcome to the Win-RAID Forum!

Since I cannot help you myself (I am not familiar with Dell BIOSes), I hope, that you will get support by someone else.

Good luck!
Dieter (alias Fernando)

Danke Dieter, hoffentlich findet sich jemand der mir helfen kann:)

I cannot download your corrupt dump (private sharing maybe), try compressing and attaching it here. Either way, the Dell BIOS for that model includes an entire 8MB SPI image (Flash Descriptor + ME + BIOS) which you can flash back with a programmer such as CH341A. That’s the best solution as other people’s dumps might have system-specific initialization BIOS and/or ME data or similar.

811E-020800_extracted_SPI.rar (2.04 MB)

thanks for the quick repsonse! ive adjusted the viewing permissions for the link… and ill try flashing your attached file as soon as i get home

Judging from the messages shown by UEFITool when parsing the BIOS region, it looks corrupted indeed:


The FD and ME look ok so something went wrong during the BIOS update and corrupted it. I believe the SPI image from Dell will work just fine. Not sure about serial keys or similar stuff, if they matter for that model, maybe not. We’ll see. Either way, these are are secondary at this point.

kind stranger, thank you so so much, consider yourself internet-hugged!
it worked like a charm, flashed the rom, dumped it again to verify it has the same contents - cleared cmos - booted like a kitten!
the service-tag is missing from the bios, but that doesnt matter since this is for home-labbing and the support expired a long time ago…

would you be kind enough to tell me how you extracted the rom from the exe? Also, I’m a bit confused about the OEM version of this server… the server has all the dell branding, the previous bios boot logo had the dell logo when it was on the 1.2.3 bios… but my searches suggested that only OEM boxes had a 1.2.3 release… you linked me to the download page for the OEM stuff, a page I never once found in my hours of googling… do you happen to know a way how I can verify for sure if this is a OEM version of the r210 II or not?

again, I can’t thank you enough… I was already contemplating of buying a replacement board, to dump the bios, and sell it again if it worked.

you are awesome.

edit: fixed the missing service-tag with a hex-editor, works like a charm!

If I remember properly, in this case the rom is just appended to the exe, no extraction is needed. You can use a hex editor to search for the Flash Descriptor begging (FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF5AA5F00F) and select 0x800000 (8MB) which should end at the EOF.

The OEM of that machine is Dell so the BIOS from their website is as official as it gets. The Dell Downloads page has all their models and if you search for “R210 II”, you’ll find the page I linked earlier.

You’re right about those OEM versions. I totally missed it before but there seem to exist three R210 II models (A, B, C). I don’t know their difference but we can see that only PowerEdge R210 II (not OEMR R210II or OEMR XL R210II) ever had BIOS v1.2.3 so maybe you have that? Honestly, the machines are probably identical with just visual differences when it comes to Logos or similar.

I already flashed the regular BIOS over the OEM version, but I did the selection on the regular BIOS file as instructed, and the BOF and EOF do line up - so I’m assuming it would work. As luck would have it, in the meantime somebody else on had the exact same problem today on r/homelab, and I’m glad I was able to pay it forward by giving him a rundown of the whole process to fix the issue… thanks to you.

Danke nochmals!