Dell Vostro 3500 (no grapchic card onboard) W25Q32BVSIG impossible to write on it

I have A Dell Vostro 3500.It had a A12 bios version but it was acting in a weird way. After looking for the bios files,at Dell site, I found that the latest bios for my model, according to its service tag (45JDSP1) was A10. Maybe that was the cause of that behaviour. I managed to update the A10 version using the recovery method (Extracted the HDR an Rom from the exe file, renamed them and using an fat32 formatted USB, powering on while pressing END key) but after 2 or 3 boot…no screen signals. So I desoldered the bios chip, a W25Q32BVSIG, and using a CH341A black Edition programrer. After several tries, I got erase the chip, now all FF on it, but when a try to write on it I always get errors, like unprotected and check datasheet,chip main memory with the contents are in disagreement…and so on.I can´t even write the dump I made before erasing it.I tried every program: CH341A all version, Colibri,AsProgrammer,Postal,SPi Flash Programmer with no luck.SPI Flash Eprom Programmer shows me a " Windobond W25Q series provide OTP functionality (on special order) - once programmed became READ ONLY! If you can programm them this is probably the case".
With AsProgrammer I do this: Read SREG and untick everything and write SREG,erase,blank,open file,write,veryfy…no luck
I attach you several screen captures, 3 bios dump found on the net and my dump (not sure whether is in a good conditon or not)

A12 (I guess it´s supposed to be used with Vostro 3500 with a graphic card on board)

A10 (Mine,according my Service Tag)

Somebody here got write this chip, but using a new one, on an Acer, but I want to know if I can write this one. Is it in some how protected? Will I need to program EC bios too, or will it work only writting the Main Bios?Thanks

Screenshots.rar (1.72 MB)

DUMPS.rar (5.65 MB)

My Dump.rar (687 KB)

@blackrider1 - It would not be read only, unless you set it that way??? Otherwise company would not be able to put out BIOS updates.

Many Dell have two BIOS chips, you need to dump both, append BIOS, work on it, then split and program back. You can’t just write one only, 99% of the time, if there is two.
Are you sure there is only one BIOS chip on this board? Which file name above is your originally dumped BIOS chip contents “My Dump”? If yes, is that from right after it bricked, before you tried to do anything?

And, it’s not entirely clear, when you did the A10 backflash/recovery method etc, did it EVER boot to BIOS or windows again, or was it bricked right after that?

What is the CPU? It probably has onboard graphics in it, even if this model was also shipped with PCIE graphics card.

What software and version are you using to read and or write to the chip? Besides ASProgrammer I mean? “Untick everything” is not the correct move there wit SREG.
Hit Unprotect and that is all, some of the SREG needs ticked, so you may need to reset that, if auto unprotect does not

Did you try to write with 1.18 or 1.30?…213094641136166
Usually, BIOS from Dell is only a partial BIOS update, so you can’t put that on with programmer anyway.
Please link me to your BIOS download page, not the BIOS directly, but the page to choose version and download from.

* Edit - I checked your dump, looks like this BIOS is all on one chip, so you may be OK. Just need link to stock BIOS and I can fix this for you, then you write with 1.18 or 1.30
Errors you mention may be due to power too low while writing, cable moved, wrong software version etc. Try with main power connected 24+4/8pin from PSU and then 1.18 or 1.30
But of course, you need proper complete BIOS first, so wait on me to give you that (you’re original dump is incomplete/bricked, that will not boot even you can write it, so don’t waste your time trying, missing main DXE BIOS volume)
You erased chip already, so you know it’s not write-protected

@Lost_N_BIOS Thanks in advance, I´m sending to you 2 links A12 and A10 Bios (A10 is the Bios is supossed to use)
The mobo uses the I5-480M(2.66GHz) integrarted Intel® Integrated Graphics Media Accelerator HD. Some of the other models were shipped with Nvidia Chips, soldered on board (Non a dedicated graphic, like PCI Express…)

The "My Dump" file is the reading I took using the clip adapter,out of the board.I tried to read it when on board but the red light of the programmer looked weak,less brightness, so I thought in desoldering the chip (I dind´t think of power the laptop on and try…sorry)
When I used the recovery method, I got bios screen again, to make the recovery again…I tried 2 times and suddenly, I couldn´t boot any more, I mean, it boots, fan is working a couple secondds and then, it rebbot again and again

I use, under Windows 10 x64:
AsProgrammer (1.4.1,2.0.0a.14 and
CH341A (1.41,1.34,, and v1.31(1.4)(CH341AFree). Not sure about 18,29 adn 30 versions.
Colibri ( and
Postal (2 and 3 ) Confused to me,afaik
SPI Flash Eprom Programmer
I located another spi chip, using the schematics, on the cpu side of the board, just right aside of DDR banks.It is MXIC 25L2005C. EC chip???

Files attached:

"Dell Bioses for my laptop" contains the 2 files Dell shows me for my laptop (A09 and A10).
"Schematics" contains schemas of my motherboard, to locate the second chip you´re talking about, if needed (U6203)
3500A12.EXE is the bios the laptop had (A12), although according to my Service tag, it was suppossed to be A10

By now, I have the chip soldered to the board adapter of my CH341A , not onto the main board of the laptop, so, I can´t try powering the laptop for testing. DO I resolder to the mobo,or wait for your hints.?
Thanks again

Dell Bioses for my laptop.rar (4.29 MB)

Schematics.rar (2.26 MB)

3500A12.EXE.rar (2.15 MB)

Do yo need some pics of the mobo, ?I can not still publish external links. Do you want them on a txt file?

This is my product page on Dell (Service Tag 45JDSP1)…FDdz090/drivers
You can see there are two BIOS options: A10 and A09 (The A09 has a warning :If you activate this Bios Version, yon won´t be able to go back earliers versions. If you do that, will damage NVRAM)
and here you have the link to the A10 bios page, sorry it is in spanish.
A10 :…ode=vostro-3500
Btw, A12 is the bios the laptop had, although according to my Service tag, it was suppossed to be A10

Thanks again



I never said power ON the laptop!!! Sometimes, you need either one, or both >> Main battery connected, or power cable connected, or both. DO NOT POWER ON SYSTEM!!
Anyway, did you see and try this method in your adventures -…ed/td-p/4437548

Service tag does not specify what BIOS you “should” have, or should use etc, but it may tell you what was on it when shipped out though, or simply tell you what latest BIOS is, I am not sure.
You can use whatever BIOS you want (NVRAM is data space inside the BIOS, you cannot damage that ) But generally when you see a warning like that, and you’re above F9, then stay above it
They just explained that incorrectly, it may mess up NVRAM, but really it probably causes more of a conflict with ME FW and EC FW than an NVRAM problem, but maybe easier for them to explain simpler that way
I see they pulled A12 off the main download area, only A10 and older versions are there, you only get A12 via searches, maybe there is some issue with A12, but if so, why would they not remove it from the site fully I wonder!?!?

There is not a second BIOS chip here, sorry for any confusion on that, I mentioned it because it’s the norm for many Dells, and I had not looked at your BIOS yet.
I don’t need any pics, or schematics etc. Give me a bit and I will fix BIOS for you.

Use 1.18 or 1.30 to program it in, they are in the package I linked above, I’d use 1.30, but if you want me to test for sure, I think I have some of these chips? Let me know
Not all software works for all chips, and some read OK for one chip but fail at write, and visa versa.

You have chip soldered to your programmer? If yes, have you done that before, and used it without issue?
I am not sure if you need to move jumper on the programmer when doing that, I assume not, but you never know, and you’re having issues, so it makes me wonder.

Failing during recovery is bad, that may have messed up EC FW, hard to say. Go ahead and dump that other chip (in-place) and let me see contents
Generally, if EC FW is updated, it would match the BIOS, so EC FW for A12 may be in chip and not work with A10, or it may have corrupted mid-recovery etc, hard to say, and I may not be able to tell since there is no software for EC FW inspection other than hex editor comparing

Please explain, what was system doing on A12 that made you think A10 was going to fix it?
BIOS A12 is what you dumped, I just confirmed this was still the on-chip version (what’s left of it, as mentioned, it’s half gone) - So, I will fix A12 for you probably, waiting to hear more info though

Yes, with no issues,everything worked fine.All the programs I tested, recognize the chip,so the coenctions are right.

I just tried 1.18 AND 1.30: erase ok,blank check ok, the a load my dump and on writing ok but on verifying I get the disagreement message about the contents…the chip is still blank

the laptop didn´t boot…I tried at lest a dozen times, and suddenly I got to get into the bios and move arround. When I closed it …again no boot up…I mean, it booted, you can hear the fan…but thast all.I just got to get into the bios twice…and when a tried the recovery metod (using power on + end key…and bla bla bla, icould update the bios but in next boot, it took me to the bios recovery screen again…and so on.No more options, only if i wanted to recovery the bios

I´m attaching the MX25L2005 DUMP I just read. It was impossible to me detecting it with my clip, so I desolder it and soldered into an adaptor, and now it´s fine

Still triying to write my dump back into the W25Q32BVSIG… with Asprogrammer, nao and I get this:

Current programmer: CH341
ID(9F): EF4016
ID(90): EF15
ID(AB): 15
ID(15): FFFF
Current programmer: CH341
Old SREG: 00000000(0x00), 00000000(0x00)
New SREG: 00000000(0x00), 00000000(0x00)
Current programmer: CH341
Old SREG: 00000000(0x00), 00000000(0x00)
New SREG: 00000000(0x00), 00000000(0x00)
Current programmer: CH341
Erasing memory…
Execution time: 0:00:49
Current programmer: CH341
Programming memory(verifying)…
Verification error on address: 00000010
Execution time: 0:00:00

MX25L2005.rar (61.5 KB)

Stop messing with SREG and or ASProgrammer!! Use 1.18 or 1.30 as I mentioned, before you use, go into “Operate Options” and on 25/26 chip tab, make sure ONLY “Main Memory” is selected

You said erase OK and blank check OK with 1.18 or 1.30, that is a write to the chip! You wrote all FF’s to entire chip, anything you fail at verify later means cable moved
Or possibly software is not good for write to this chip - in that case, try 1.29 and or v1.31(1.4) (CH341AFree) from package I posted, choose correct chip type (25) and size first
If/when you get a failed verify on write, no need to waste your time checking to see if it will boot or not, it will not, ever, that error means BIOS you wrote was corrupted on write so it would not be bootable.

MX25L2005 dump looks “OK” that is all I can tell you, does not look corrupted, but I have nothing to compare it with so I cannot say if it’s exactly as it should be or not.
I’d have to have dump from system running A12 BIOS. I did compare it to the ones in your random dump grabs, looks similar, so I think it’s good/OK
Put it back for now.

Also, stop trying to write back your dumped BIOS, that is bricked, and only half a BIOS, it will never boot the system.
Here, this is 100% stock A12 (And A10) BIOS for now, later, we will have to fix your serial etc.
I suggest you try A12 first, and then if it fails to boot after you get a successful verified write, then try A10…175971285185082

YOu may need to use another new/different chip for the BIOS, if you messed up the registers in that chip (can’t put them back to original, since you don’t know original contents)
The following flash ID’s are compatible, these ID’s may cover many chip variants than the exact names listed beside them
1F4700 (Atmel AT25DF321)
EF4016 (Winbond W25Q32) << Very common, you can get on ebay cheap, but 3-5 for best deals << I’d get this
BF254A (Microchip SST25VF032B) << Avoid
C22016 (Macronix MX25U16) << OK, but more $$ than others usually
207116 (Micron M25PX32) << OK, but pain sometimes
1F4701 (Atmel AT25DF321A)

Thanks Lost_N_BIOS for your time.
Nothing changed, I´m still getting errors when wrtting your files, (all FF). I really erase it .Tried 1.18, 1.29 and 1.30. So I´m thinking on buying a new chip for best option.When I get them, I´ll tell you. I´ll follow your recomendations about similar chips. Thanks again

I got the chips today…reprogramed with your A12 and now, the laptop is booting and I am installing Windows 10 right now. SO, everything seems to be ok by now.I´ll keep A12 if everything goes right.I guees I´ll need to introduce asset tag later, into the bios,will I? ( I have that option).Will I need anything else?Thanks.