Dell xps L502X BIOS mod and RAID problem (HM67)

Hi, I’ve been struggling with l502x modded bios for about couple weeks with 3 other bios guru and no results achieved.
Originally there is no support for RAID for this laptop, we managed to unlocked this bios so RAID menu appeared, BUT unfortunately when SATA is changed to RAID no SATA devices is found whatsoever and RAID OROM is not showing on the start, however we have almost same system on L702X laptop and we managed to launch it in RAID mode through UEFI console which haven’t worked out for l502X, but proved it can be done!
We have added module from this site: “Universally TRIM modified” Intel RST(e) RAID ROM v12.9.0.2006 with TRIM in RAID0 support… but that haven’t give us any results…
Maybe Fernando or someone else can guide me and put some comments on this issue or even help with modifying the bios,
Any help with launching in RAID mode would be appreciated.
Also can Intel EFI “SataDriver” be any help? or it’s a wrong way too?

My finall goal is to successful launch in RAID mode and make Intel Smart Response working.

I’ve attached original and modded bioses if anyone can help with modifying them in a right manner to make RAID working…
so modded bios is with Universally TRIM modified" Intel RST(e) RAID ROM v12.9.0.2006 with TRIM in RAID0 support
Thanks in advance.

L502XA12(original).zip (3.45 MB)

L502XA12(modded).zip (5.21 MB)

@ determo13:
Welcome at WinRAID Forum!

Although I doubt, that you will be able to get RAID 100% working with your laptop, I will do a look into both attached BIOS files tomorrow.
After having done that, I will try to answer your questions.

Regards
Dieter (alias Fernando)

thanks for a quick reply, waiting for your response.

I am sorry, but I cannot help you with this sort of BIOS modding.
The AMI Aptio MMTool v4.50.0.23 is able to open both files, but doesn’t show the Option ROM modules.
Then I extracted the contents of both BIOS files by using the PhoenixTool, but I don’t have the needed experience with that tool.

@ Fernando:

It’s a Phoenix BIOS inside a typical Dell EXE package. So PhoenixTool is the way to go here. Open the EXE with PhoenixTool, do any changes to the DUMP folder (be careful to not alter names, mind the size), go to Advanced and select No SLIC (to let you continue) and click GO. This should reconstruct a new modded Dell EXE package. I took the stock EXE and just run it through PhoenixTool with no changes, the result file had the same SHA-1 hash. So it’s working properly.

Other that that, HM67 supports RAID according to Intel. How to enable it on this laptop if it was disabled by the OEM, I don’t know.

Well you see, the modded bios has that RAID option enabled, but the problem is with SATA devices, when RAID is on, bios cant see any SATA. So is there any chance to force it to load some drivers or anything to make it see.

I’ve made an experiment, booting from windows startup disk and loading intel RST drivers, and my SATA appeard, but I could not install OS on any on them as it was said ‘devices not available at the boot time’ or something.

Any thougts? maybe BIOS has some drivers missing?

As long as Windows detects the SATA connected devices, everything is fine.

Which Intel RAID driver did you load?
Which Option ROM settings did you choose within the BOOT section of the BIOS?
Did you get the Intel RAID Utility popup (CTRL+I) while booting?

I don’t think, that there is an Intel RAID module missing within the BIOS.

If you want more informations about the use of the PhoenixTool, you may look into the start post of >this< thread.

I wish to believe it’s fine… but can not install OS on my drives…
here are drivers I’ve loaded.
https://downloadcenter.intel.com/Detail_…eng&ProdId=2101

here is error
http://de-server.no-ip.org/shared/IMG_5813.JPG


Yes the intel RST splash screen would not appear… and pressing (CTRL+I) does nothing…

here is the options I have in BIOS and the load screen

boot menu
https://drive.google.com/file/d/0B5ecoUy…iew?usp=sharing

hdd, once saved and restarted NO SATA devices will be available…
https://drive.google.com/file/d/0B5ecoUy…iew?usp=sharing

Tried to enable/disable all options available etc…
https://drive.google.com/file/d/0B5ecoUy…iew?usp=sharing

and here is the boot screen
https://drive.google.com/file/d/0B5ecoUy…iew?usp=sharing

@ determo13:

At first I would rather like to know, why you want to get the SATA mode “RAID” option with a laptop, which natively does not support any RAID features and usually doesn’t even have the space for a second similar sized HDD/SSD (a RAID array requires at least 2 storage drives).
Do you want to create a RAID array at all? If yes, which sort (RAID0, RAID1)?

Here is my comment:

  1. I doubt, that you will be able to get full RAID support into a BIOS of an Intel platform laptop, which natively doesn’t support RAID at all.
    It is not enough to unlock some BIOS features and to insert an appropriate Intel RAID Option ROM, the system BIOS components have to be modified as well.
    Furthermore the on-board Intel SATA Controller has to physically support all SATA modes (IDE, AHCI and RAID).
  2. Some of your BIOS settings seem to be not the best appropriate for a LEGACY mode RAID system:

So here is the deal, I’ve replaced cd/rw dvd drive with odd caddy with small sized ssd 32gb
Now in AHCI mode I have 2 drives as on the picture with windows error,
My goal is to setup intel smart response and cache my 500gb hdd with 32gb ssd for that no need to build RAID array, but need to set drives to work through RAID controller.


if I choose different partition nothing changes, as much as I know bios cant see SATA devices and there for no boot device available…
I’ve tryied all suggestions you offered and no change…
F12 call boot option list, wich does nothing too…

"Furthermore the on-board Intel SATA Controller has to physically support all SATA modes (IDE, AHCI and RAID)."
Judging by intel hm67 description its should support RAID… There are other laptops with same board supporting RAID… So the question is what have in example l702x dell laptop different from l502x
As both laptops have almost same configuration bioses, board, just laptop vide card and screen size is different, but if you unlock l702x laptop bios, change sata to raid, its brings up raid option rom normally and array can be created etc…

Guys do you have any knowledge to compare bioses?
In general I’m interested in RAID modules, bioses should be really similar,
but something is missing in L502x, so maybe if to find that difference,
module exchange can be made and
L502X will be able to work as L702X and then SATA devices can be found in RAID mode…

L502XA12.exe.zip (3.45 MB)

L702X_A19.exe.zip (3.52 MB)

I neither have the knowledge nor the time to compare BIOSes from different laptops…

They can be rather similar, but that does not mean, that you can successfully flash a BIOS, which has been developed for a special laptop model, into another model with another hardware configuration.
On the contrary the risk to get a bricked laptop is very high. I am sorry, but I am not willing to support your plan to get RAID support into a sytem, which obviously not even has an operable on-board RAID Controller.

Just out of curiosity, how did you managed to open files with AMI Aptio MMTool v4.50.0.23
I’m trying to do all kind of things, but no results… or maybe main question how did you extracted that exe file?

Please read, what plutomaniac has written within post #5.