Disabled Intel ME and now I cannot reenable.


Maybe @plutomaniac can help me with this one hehe (Thanks for your help in the other post I made asking about with FW and drivers to install as I was concerned about the performance on the laptop)

The laptop is an MSI gt72vr 6re and it was running fine with the ME FW provided by the MSI with is I used their “ME UPDATE tool” to flash and it worked.
The computer was perfectly fine until I found an option in the BIOS called “PCH-FW Configuration” (attached) and switched the option called ME State from Enabled to Disabled. I think it “partially” disabled the ME, but that’s not the point, what maters now is that I cannot reenable again.

Here are the things that I’ve tried:
Reflash bios to older/newer versions - something strange about it, is that now after selecting the bios file through the bios, and clicking on update/flash, it says “wrong image 11”, I’m sure that’s only because of disabling the ME. As that never happened before when flashing the BIOS. But I did found a way to
force the flashback and it works by doing the following: After that message appears, I just press Ctrl+Alt+Del, the laptop restarts and goes to the bios again, but this time straight to the bios update/recovery ALLOWING me to hit enter flashing the bios without any errors.

So I am still able to flash the bios back and forwards with that method, but it updates the bios ONLY, and not the ME. It stills shows as the ME version.

I tried many times to use the same tool provided by MSI, (it worked before this issue) with uses the FWUpdLcl64.exe to flash the ME, and this time it gives the following error:
Error 8743: Unknown or Unsupported Platform
Cannot locate hardware platform identification
This program cannot be run on the current platform.

Something important to mention is that every time that I boot the system it says “ME FW Update Failed, please try again!” after that it says “Error sending end of post message to ME: HECI DISABLE, proceeding…” After the warnings, it goes to Windows normally.

Something important about that:
If I go to the BIOS/Boot options, there is an option called “UEFI with CSM”, originally its set to UEFI. And after changing to that one, those messages while booting the system disappears.

But still, doesn’t fix the problem with the ME. I still cannot bring the ME back to active.

Lets talk about the symptoms after disabling the ME:
WIFI device turns off randomly
The clock/date changes sometimes.

So far, that’s what I’ve noticed.

Well, I hope I can fix this problem, I’ve searched others posts to see if someone had it before and it seems like they were able to fix, however, others posts did not share the same circumstances about this problem and everything is different, so that’s why I’m here.
Any help is welcome, thanks!







UEFI + CSM.jpg

You can’t update ME FW with ME FW update tool after you disabled it, it’s disabled
Enable the option in BIOS again if you can, that should fix it. If not, you need flash programmer to fix

I tried switching back to enable but it doesn’t save, after restarting the laptop it still shows disable on BIOS, maybe its a bug. But my question is, is there any other way to fix this without the use of a flash programmer. Like using a custom BIOS, or other methods of recovering the ME using UEFI or DOS, I’ve seen some other posts and they shared something in common but I haven’t tried those methods as I wanna hear something based on the exact problems that I mentioned. So let me know and thanks for your help!

Do you have dump of your bios from before you have changed that setting?
If yes than you just need to reflash full bios with programer.

If not you need to dump your current bios. Use fit insert new me fw and tansfer all settings from bios from msi web site. And than flash with programer. Btw you can also unlock bclk in fit at that time.

Or ask Svet. He will provide you his tool called "me port" for unlocking and reflashing me and than you will flash with his second tool full bios he will provide you. But you will need to pay him.

I once did that on me sold ge72 7rf but Svet helped me at that time. Now as I have programer I could do it myself.

You can disable sending DID msg in fw settings in bios. But this will not recover you from state. But all info about broken me will not be showing, boot will be a bit longer also.

@Krzyslaw PM!

Have you tried clearing the CMOS? You’ll need to open the laptop and disconnect its CMOS battery for 1 minute or so.

This will not help.
I had the same problem long time ago. And you can only make it working by reflashing with new working me fw

I haven’t tried that, but since I still have normal access to the bios and as a fact, I did flash multiple times to see it fixes the problem, isn’t effective as clearing the CMOS? I thought that was only the case if the BIOS is inaccessible?