Disabling Intel Boot Agent OROM on SuperMicro X9DRG-HTF


I am trying to use a custom bootloader in this board (BIOS available at this link): https://www.supermicro.com/products/moth…0/X9DRG-HTF.cfm

Once my code (which has replaced the UEFI shell) runs, it cannot list the network devices. I believe this is because Intel Boot Agent is running first and taking over the NICs.

The only BIOS options I can find related to the NICs/Boot Agent are under boot. I removed the “Network” boot option from the list and set the Network boot option from Boot Agent to Disabled. However, before even being show the option to invoke the boot menu/setup, I still see the Boot Agent splash screen come up.

Is there a way I can disable or altogether remove the option ROM? I have looked into UBU but it only seems to allow updating the OROM. The OROM is in the CSMCORE module which has a format I don’t understand, else I would just remove it with UEFITool.

Thanks in advance!

@HashFail - You can confirm your theory by removing the Boot Agent/PXE roms in a mod BIOS, then you will know for sure if this is the issue or some BIOS setting, or your code is not detecting the NIC’s correctly and this is the issue.
I see this oddity too, maybe disable and retest @ Boot >> Check controllers health status
In Boot >> CSM >> Launch PXE OpROM policy >> Set Do Not Launch, then no rom will be loaded UEFI or Legacy for Boot Agent/PXE
^^ This additionally located at >> Advanced >> Launch PXE OpROM policy << And there, see also >> Onboard LAN Option ROM Select + Load Onboard LAN 1/2 Option ROM (Can be Disabled) + Network stack (also disable/enable)

You may also need to disable >> Advanced >> Boot Feature >> Interrupt 19 Capture << But, this may be negated by disabling the Launch PXE Option rom policy, either one of those seem like they’d do want you want.

If you want to remove roms as test, only two are in CSM (legacy) - Use MMTool, in delete tab, select “Link Present” then choose modules based on ID below and delete
OROM Intel Boot Agent GE - 1.5.13 >> 8086.1521
OROM Intel Boot Agent XE - 2.3.04 >> 8086.1528

The other two UEFI/EFI modules are located here, these can be removed with UEFITool or MMTool >>
Intel Gbit / EFI Intel 10Gigabit UNDI - 4.5.19 >> GUID 4953F720-006D-41F5-990D-0AC7742ABB60
Intel XGbit / EFI Intel PRO1000 UNDI - 6.4.13 >> GUID E479CAB3-C0CC-4E2A-9697-3FD965E91128

Hello @Lost_N_BIOS , thank you very much for the hints! I was able to disable the intel boot agent using a combination of the options you listed (I only needed the OROM related options; I did not use health status or interrupt 19 capture). However, I was still unable to use my bootloader.

In the end, the issue appears to have been the SNP driver. My build process automatically replaces the stock SNP driver with the one from iPXE because it is much faster. Disabling that for this image did the trick.

Disabling the intel boot agent is still something I would have wanted to do anyway, so many thanks again!

@HashFail - Great to hear you were able to disable Boot Agent at startup!! Sorry to hear your bootloader is still not working
Ohh wait, you figured it out? If yes, great, and good job man!

@Lost_N_BIOS yup, everything is now working thanks again

@HashFail - Awesome you got it sorted out! And you’re welcome, but I didn’t do much here, just discuss your options