[Discussion] Firmware for Asmedia Sata 6G Controllers


I’ve got a Rampage IV bios with 0.93.1, this seems to be stuck in IDE mode, the controller is configured for ahci and force bios is specified but in windows its displaying as 2 Standard PCI IDE controllers (which means it enumerated to IDE)

Any ideas?

nvm, seems it was a fault with 0.93, replaced with 0.97 and ahci works now

@Squall_Leonhart :

It is fine, that you found a solution yourself.
Thanks for the info!

Thanks XD

I just need to play around with the bios a bit now and see if i can reduce the POST time without disabling the asm controller, i suspect having the OROM enabled is not actually necessary except for booting from the controller, with force bios enabled i see the asm orom come up twice and sit there for several seconds, unlike with JMI/Marvel you can’t hit a button to continue early.

hi. my motherboard is SATA II ports, i installed an asmedia PCIE to SATA 6g card in the hope of getting more speed from my SATA ssd. unfortunatly the expansion card made my SSD even slower then the previous 243Mb\s. yet i was hoping for
something around 450Mb\s.
is there a way around this?

What speed are then your PCIe slots (generation)? Also what is the card connection x1, x4?
Take that into consideration and do the calculation yourself (you are probably limited there too!).


I have the STLabs A-590 card with the Asmedia ASM1062 chip. I flashed the station-drivers 4.27v2 firmware which seemed to work fine. My card does not give me any kind of POST message so I can’t really see which firmware I am running. Is there any tool or utility that can report on the card/chip?


Hello! I have Sata to PCI-E X1 adapter on ASM1062 with 6xSata ports.
When i conect all 6 Sata ports, in Windows works only 2 ports, first and last sata (Sata 1 and Sata 6)
But i conect only one sata port in SATA 2 or SATA 3, 4, 5 - he work.
Please help me. Maybe need modifided driver for ASM1062 with 6xSata ports?

Drivers here: Recommended AHCI/RAID and NVMe Drivers

Drivers r not the same as a Firmware.

Now…should we guess any more info that card humm??? witch OS? Witch PCI ID? Is it AHCI or RAID?
Wot do we need for a pic from a covered chip??? Didnt the chinese seller explained to u wot ur buying with such low prices…

Windows 7 and 10 - this problem on the both.

Chip JMB575 + AsMedia1062

Hardware Ids:

click to zoom

Driver version from 24.06.2020 - Asmedia 106x SATA/RAID Controller.

That’s a REALLY bad setup for a new SATA card. For the same money you could have gotten an ASM1166 that is real SATA controller with 6 ports and not a SATA switch chip bodged to an old 2 port SATA controller chip

This contraption of a card will perform like crap and have driver issues because it’s using a SATA switch. Totally pointless considering ASM1166 costs.

Indeed… Marvin is rigth… that card uses the JMB575 as port multiplier, no more miracles here, try old versions.

EDIT: Marvin just explained and look at the pdf i linked. The JMB575 can work as 1 to 5- ports Port Multiplier or 5 to 1-
ports Port Selector. There is no somehow miracles here to a bad design product. Sell it, return it or give it to Santa Claus.

Looking closer at the picture and at the traces it looks like SATA1 is directly connected to ASM1062 and all other ports are connected to port 2 of ASM1062 via the JM575 port multiplier. Bad card, absolutely useless for a RAID setup for example. With a port multiplier only one device can be accessed at a time. And that explains your problems with combinations on connecting drives to different ports.

I don’t need a Raid. I just want all 6 discs to be visible at the same time in Windows. I know very well that they will not work at the same speed simultaneously on two channel controller.
Is it possible to somehow solve the problem?

The latest firmware for the asmedia1061 pcie cards are the 4.27 v2.
This is not compatible with Intel 600 series motherboards because all firmwares advertise that the maximum
payload size is 512 bytes but this chip in hardware supports only 128 bytes.

It is possible to someone to mod this? I attached the firmware here at the end of my post.

ahci427.zip (21.1 KB)

1 Like


Firmware v4.27 for Asm106x, Available on UBU.
I renamed it to *.rom.
I put it (MMTool and insert) in the bios of the ASUS X79-DELUXE.
On PC Boot, It didn’t show the usual message that … found Asm106x … but in Bios it saw the HDD … and in Windows 10 it worked normally.

Best Regards.

With Driver : Standard SATA AHCI Controller , of Windows → Work.
With Driver :Asmedia SATA Controller
; Edited 04/12/2013

  1. PC. Boot.
    2. Windows 10 NoT Start !!!Not Work

I believe this firmware (v4) is more suitable for add-on cards and not embedded motherboard controller.

EDIT: You can check the original ones in the stock Asus bios update files, i believe their all in the 0.9x range.

1 Like


This is !!!
But I realized it late.

Best Regards.

Do you know which Firmware,
had the original M/B Asus X79-DELUXE ?
Thank you.


Thank you for your interest.
But the Original ASUS BIOS does not have the firmware for:

Best Regards.

Sorry but it does…you can check it with UBU and you know this…

Intel® X79 chipset :
2 x SATA 6Gb/s port(s), black
4 x SATA 3Gb/s port(s), black
Support Raid 0, 1, 5, 10
Marvell® PCIe 88SE9230 controller :
4 x SATA 6Gb/s port(s), dark brown
ASMedia® ASM1061 controller :
2 x SATA 6Gb/s port(s), dark brown
2 x Power eSATA 6Gb/s port(s), green

EDIT: Your correct, my bad assumption without confirmation, there’s no OpRom as standalone module for the ASM1061, only for the Marvell.
The ASM works as standard AHCI controller.
Fernando did a test a long time ago to manually insert the ASM OpRom in his P8Z77 with no effects whatsoever, so don’t waste time with these.

1 Like

Thank you for your prompt reply and help.
It’s exactly as you wrote it.
But the Firmware, It does not exist, inside, in the ASUS Bios.

Not Found: 1b21


Μaybe … When, for the first time֍, I used AsMedia’s programs, (for FirmWare) it was already too late.
Not one was working. With Bios the Original of ASUS.
Maybe it’s because of what : Before: ( From the first time֍) I had put on the PC, the bios of Lost_N_Bios, (with Asm 0.97).

This should go in another thread…
But in which?

Now I have RST 13.1 … and HDD.
and: Event 264, Defrag
The storage optimizer couldn’t complete retrim on D_Disk (D:) because: The operation requested is not supported by the hardware backing the volume. (0x8900002A)
D_Disk (D:)
The operation requested is not supported by the hardware backing the volume. (0x8900002A) 2A000089800200008D0000009000000022B63823DBB1BD381B0700000000000000000000
If I Put RST 12.9 , There is a possibility,
me to get rid of: Event 264, Defrag ?

Best Regards.