[Discussion] Firmware for Asmedia Sata 6G Controllers

@ all visitors of this thread (edited by Fernando at 07/23/2016):

Since there is obviously a big interest in updating the Firmware of ASMedia ASM-106 SATA Controllers, I have moved all posts about this topic into this thread, which has been started by our Forum member saglamtimur in November 2013. To make it easier for you to find this thread, which now contains all informations and discussions about this topic, I have hijacked saglamtimur’s start post and customized the thread title.

On-board and PCI connected ASM-106 SATA Controllers are using a rather similar Firmware, but the Firmware is located on different places and has to be updated a different way:

  • The Firmware of on-board ASM-106 SATA Controllers is an “Option ROM” resp. EFI module, located within the mainboard BIOS and can only be updated by flashing a new or modified mainboard BIOS. >This< is the correct thread about such ASM-106 SATA 6G Option ROM modules.
  • PCI connected add-on cards have an own ASM-106 Controller chip. A new Firmware has to be flashed directly into this chip by using a special Firmware flash tool, which usually is offered by the manufacturer of the add-on card or by ASMedia itself.

This has been the original start post written by saglamtimur:

Any one tried the firmware v3.02? Any issues?

To be honest I do not recommend to flash this ASmedia 106X SATA 6G Controller Firmware v3.02, which has been offered today by Station-Drivers as "new". The Firmware itself is dated 07/17/2012 and seems to be outdated.

I haven’t used any of these, but don’t you use 095? That’s 1 year older than what the 302 shows as it’s date… maybe I’m thinking of the wrong 095x version.

What I have flashed into my ASUS P8Z77-V BIOS is the latest ASMedia 106X AHCI ROM module v095. I have never flashed an ASMedia 106X Firmware.
Unfortunately I cannot give you the date of the ASMedia 106X AHCI ROM module v095, because I am not at home.

Actually I am stuck with version numbers. 0.9x and 3.02 where is 1.x, 2.x or even 3.0?

You should ask ASMedia!

0.954 was buggy
0.951 i use actually
3.02 i can´t flash with the tool its to large 34kb and must be 32kb

Why did you try it at all?
The OROM v0.951 is working fine - or did you realize any troubles`?

I have not tried them all. 0.93 was on top of the board.
0954 is wrong, no boot from cdrom possible
0951 is the last version which also runs mooding
and the brand new 3.02 I would have liked it,
i wait for answer from asmedia, i asked what is the last official firmware?

I’m a little self-regard to the timeliness of such things;-)

but you have found a possibility to flash the 3.02 which has 34kb and is too large?

So you name a Firmware "brand new", which has been released at 07/17/2012?

yes i know but i wait the answer from asmedia

So at the end which one is "newer"?

Any response from Asmedia=?

I recently “upgraded” to the Asmedia SATA/AHCI driver v2.0.2.0 and had many BSOD’s in Windows 8.1 Pro and was forced back to version v1.4.1.0.

The driver corrupted my Windows installation twice and after using system restore I was able to analyse the crash dumps to locate the source of the BSOD’s (asstor64.sys).

Does anyone know if the Asmedia 3.02 firmware possibly resolves this issue? (I am currently using v0.954)

No it does not, even no optical boot with 3.02, I think it to be older…

The ASMedia Firmware v3.02 is dated 07/17/2012.

3.02 that I do not like is the checksum does not equal 00. I can not find byte alignment.

The ASMedia Firmware v3.02 is dated 07/17/2012.

I meant older then 0.954.
And contrery to ModRekrut, I have boot from cdrom with it.

ASMedia seems to have horrible problems with version numbers… Anyway the 0.951 firmware does appear to be the newest that’s available, but maybe there’s a newer one in a current UEFI motherboard BIOS. I tried extracting a few but didn’t succeed.

EDIT by Fernando: The ASMedia AHCI DRIVERS related part of the post has been moved into >this< freshly created thread.

@ mushbert:
Welcome at Win-RAID Forum and thanks for your report regarding the ASMedia 106x SATA ROM modules and AHCI drivers.

The ASMedia 106x AHCI ROM v0.951 is dated 07/11/2012. AFAIK the newest working ASMedia AHCI ROM is v0.954, which can be found within the start post of >this< thread.


Thanks! I have this version installed now; it does work, but strangely - attached drives are no longer scanned during boot-up and there is no OROM information screen displayed (though I enjoy this as booting is faster). However, once Windows starts loading it works as expected, with no issues so far. I’m using Win7, a P45/ICH10R board, and a SiI3726 port multiplier connected to the ASMedia PCIe card… Maybe 0954 is built for BIOS insertion and that’s why it doesn’t act as expected?

Absolutely - the information is more useful if people can easily find it. Feel free to copy anything of relevance over.