[Discussion] Firmware for Asmedia Sata 6G Controllers

Thanks! I have this version installed now; it does work, but strangely - attached drives are no longer scanned during boot-up and there is no OROM information screen displayed (though I enjoy this as booting is faster).

There should be an option within the BIOS to force the splash of the ASMedia 106x Utility v0.954 while booting.

Absolutely - the information is more useful if people can easily find it. Feel free to copy anything of relevance over.

I have done it.
Thanks for your compliance with the movement.

Only if you insert it by force like you did using MMTool, I tried it too and (of course "with show OROM while BOOT" or something similar), and now during BOOT right before Intel RAID ROM screen it shows:


Edit by Fernando: Quoting corrected

The ASMedia chip is on a PCI-Express card, as far as I’m aware inserting the ROM into my motherboard BIOS would not work.?

I don’t believe such an option is present - but even so, I don’t think that’s the issue. The boot order with 0951 is ordered as follows:
BIOS -> Intel AHCI Splash -> Intel RST Splash -> ASMedia card Splash -> DMI Pool update -> Windows bootloader.

With 0954 installed on the card, no splash screen for it is shown but the others appear as normal. Again, while this is strange, for me it is a positive point because if the card is working properly there is no need to slow down the boot process with yet another splash screen.

Edit: Oh yes, one other thing: with the 0951 ROM, the driver (v1.4.0.1) shows the “Enable Safely Remove Disk” switch on the Policy tab in Device Manager, but not the “Enable Driver Cache Mode” switch. With 0954 the latter option re-appears. I have no idea whether that means caching does/does not work with 0951.

I agree: In this case there is no reason for you to change anything.

I have a standalone 2 port SATA card using ASmedia Chipset 1061.

tried flashing the firmware provided on this site and then the 3.0.2 from station drivers.

Seems to fail erasing SPI rom.
Entire SPI ROM neeed to be re-programmed!!!

Any idea’s?


@ tg:
Welcome at Win-RAID Forum!

Because of the wellknown problems I neither have offered this v3.02 OROM nor recommended to insert it into the BIOS.

Try to reflash the original BIOS.

Good luck!

That’s abit of a problem as I don’t have the original BIOS.
It was running V0.90 Bios, and had an anoying bug on reboot the bios wouldn’t load and pc wouldn’t boot.
I would have to do a complete power off and then the BIOS would init.

The card is made in Tawian by this comany.
I have tried to contact them for technical support, don’t hold my breath though! :frowning:

@ tg:

Have you already tried clearing CMOS?


I am using on my P8Z77-V Deluxe the ASM 106x SATA controller the driver V (w7 x64 in AHCI Mode), dated 25/11/2013.
Seems to work fine.

However i would like to know what FIRMWARE is flashed inside this controller on the motherboard , and what OROM version is flashed inside the ASUS BIOS version 2104.
I assume a couple of these 2 pieces of flashed software must be respected to work fine together.
1) How can we get the both OROM and FIRMWARE versions respective value ?
2) I have tried the “AHCI.bat” command under a USB DOS bootable key and get
a) for ‘ahci302.rom’ this menu:
106spi -u ahci302.rom
DOS/4GW … version 1.97
ASM106x SPI Flash ROM Write V 2.06
Find 1 ASM106x controller
Read-ROM ID Failed !!
Program Stop!!
b)for N0951 piece this menu:

ASM106x SPI Flash ROM Write V 2.5
Find 1 ASM106x controller
Can’t find SPI ROM !!!

Any help/comments ?

@ 100PIER:

I haven’t yet done a look into the BIOS of your mainboard, but the original BIOS of my ASUS P8Z77-V doesn’t contain any ASM 106x OROM module. Nevertheless I was able to insert the ASM106x OROM v0.954 without any problem.
AFAIK the ASMedia AHCI Controllers are managed just by the OROM and not by any special Firmware (like the Intel RAID Controllers), but I am not 100% sure about that.

Fernando, given that it’s a standalone card I couldn’t see doing that having much effect but I did it anyway with no change.
The card has a jumper on it for AHCI/IDE or OFF.
Basically if the jumper is now on the card the PC frezes before POST in either AHCI or IDE mode.

Zitat von tg im Beitrag #31

Fernando, given that it’s a standalone card I couldn’t see doing that having much effect but I did it anyway with no change.

I am sorry, I haven’t read your first post very carefully.
Since the ASM106x SATA Controller is on your discrete PCI card and not directly on-board, the mainboard BIOS should not be affected by flashing any ASM106x OROM into the BIOS chip of the PCI card.

So, the ‘firmware’ vocabulary is wrong for the ASMEDIA ASM-106X Sata 6G controller, we should speak only about ‘BIOS OROM flash module’ ?

Why UBU tool does not display anything about ASMEDIA BIOS OROM module ? (for instance for P8Z77-V Deluxe ASUS board BIOS 2104)

I don’t understand well when how to use ‘AHCI.bat’ DOS tool we found on station-driver about ‘firmware’ for ASM-106x Sata 6G controller.


The UBU tool only is able to update already existing OROM/EFI modules.
If your original mainboard BIOS doesn’t contain any ASM106x OROM (like my P8Z77-V), it doesn’t show any ASM106x OROM.

AFAIK this AHCI.bat command is only usable for discrete ASM106x SATA PCI cards, but not for on-board ASM106x SATA Controllers.

Early Z77 ASUS BIOS-es had an ASMedia OROM. But later (mainly after Win 8 support has been added) they were built without one (there is still an ASMedia module in BIOS for control of ASMedia chip before OS takes over). And that is why it can bee added manually…


So, this ASM-106x Sata 6G controller on any ASUS motherboard never needs any piece of ‘flashed code’ at any time of the life of the system (booting phase, and W7/W8 phase).
Only OS driver is needed and impacst the performance.

You can use this ASM106x SATA 6G Controller as it is, but if you want to optimize or refreh the function of the Controller, you have the possibility to insert the actually latest/best ASM106x OROM module into the BIOS (for me it is v0.954 as long as we don’t see a newer/better version). Anyway the effect will not be very impressive. Furthermore your system drive should be always be connected to one of the Intel SATA 6G ports and never to an ASMedia SATA port.

Btw, just tried right now to update a bios for a friend Tpower X79
All the bios runs with UBU just fine, can update most of the OROM, but while trying for ASMEDIA
It looks for Device 611 ( OK replaced fine ) but Device 612 it gaves me error ( saying that device id ) orom was not found.
Still looking inside to understand why !

What lets you think, that the board has 2 different ASMedia 106x ROM modules (DEV_0611 and DEV_0612)?

Normally 611 and 612 are totally same. Different ID but they use the same OROM. Best is to insert them both with MM Tool directly. The problem is (maybe only for my board) that you’re maybe not able to boot from the ASMedia ports any more. This is what happened to me even when the replacement went fine. When choosing “bootable” option in BIOS the ASMedia bootscreen does not appear any more. So I decidet to use my original 0.93 rom again.

Regards hanson