[Discussion] Firmware for Asmedia USB 3.0/3.1 Controllers


Perhaps one of you can help and clarify some information.

I have a strix raid dlx sound card with 1042A controller, with device ID DEV_1142

Previously I flashed 131025_10_11_AB, which I’ve come to believe(i could be wrong) is only for 1042, without A.
Then I found 140124 firmware Fernando originally posted.

The dump Fernando posted is 128kb in size, a user posted the updater 140124.bin that’s only 64kb.
Cannot flash 128kb dump, but the 64kb bin flashed successfully.

On post @429 user @snowind posted his dump 140328_10_02_00 which is also 128kb.

Is there a way we can extract this version so I can update mine?
Reason I ask is I’ve had audio cutting out for a split second that lasts for about a min occasionally, I’m still testing 140124 to see if it fixed it.

I would like to update to 140328 if possible.

@PhatAgent : My knowledge about this topic is not good enough to be able to help you.

No worries. It seems lordkag was last online in 2018.
Is he alright?

Who else would be good to contact about this subject

@PhatAgent :
AFAIK our BIOS and Firmware expert lordkag is alright, but hasn’t been online for a long time.
I am pretty sure, that there are other Forum members, who know more than me about this topic, but until now they seem to be quiet.
By the way - a lot of years ago I have made some tests with different ASMedia 106x SATA Controller Firmware/Option ROM versions. My experience: ASMedia doesn’t care much about their customers. Higher numbered Firmware/Option ROM modules were often older than those with a lower version number, none of them worked perfect for my system, some versions were not even usable at all.
Good luck!

Yes asmedia seems to be lacking in many areas.

Unsure if 140124 is newer than the one i was using previously 131025xx, but I do know audio cutting out was an issue.

Will test the 140xxx firmware for a little while, hopefully someone else will chime in with more information.


I was able to update the ASMedia firmware on my ASUS Z170 Pro Gaming with Asmedia ASM-114x USB 3.1 Firmware Version 150707_30_02_15.

I was on 150707 30_02_10 previously. No idea of the changes, but the USB ports are working so it’s fine I guess.

Asmedia ASM1042 (without A) what is the latest firmware?


Do you backup the original Asmedia Firmware from your Strix Raid DLX Soundcard ? Bcs i forget it, and i cant find that Asmedia Firmware anywhere.
It was version 130704_10_F5_01

Do you wanted for late wake up strix raid cards? Are you sure this is the fix for that? Because I tried with 130704_10_02_01 and it didn’t fix the problem. Did you try request from Asus that spesific firmware?

Do you wanted for late wake up strix raid cards? Are you sure this is the fix for that? Because I tried with 130704_10_02_01 and it didn’t fix the problem. Did you try request from Asus that spesific firmware?

Ye bcs with that firmware 130704_10_F5_01 i didnt had any problems on cold boot… now the card is not recongnize on cold boot… i was bored and updated the firmware… and i hate it.

If you found it please share it here too, this Strix raid xxx card problem driving everyone nuts.

Hi Everyone,

I read carefully the topic and i found a lot of resources here.

Well the issue that I’m having is that the techincal support of ASMedia is not answering my email. A brief summary of the situation

I’m using the PCIe lines of a linux to connect the linux with an USB host controller, ASM1142.
The Host controller has a SPI to configure or to receive some data from an external EEPROM, ASMedia is not providing some guidelines about how to use the SPI and the EEPROM. I have read above that ASMedia need to provide a specific fw to flash into the EEPROM.
We have checked the communication between the Linux host and ASMedia . With a logic analyzer, we saw the Linux tries to communicate with ASMedia and the EEPROM’ SPI lines have some interactions, but there is no transfer of data. When we do not have the linux connected the ASMedia tries to talk with the EEPROM.
We found that the communication failed checking the log in linux, as expected

So the main issue is to get the FW to flash on the EEPROM and how to flash it, we have all the resources needed to do it, in case we do not have it, we will buy it. The PCB is a custom PCB done.
Do you have any advise or some new ideas about what to check ???

i just purchased this card: BEYIMEI PCI-E 2X to USB3.1 A-Key Gen2 Front Type-C Expansion Card,10Gbps Type-E Internal 20-pin Front Panel Connector Riser Card,PCI Express 3.0 X2 Adapter for Desktop PCs (ASM3142)

when i run the updater is does not see the card, not dos or windows, but the card functions perfectly.

here is lspci -nn -v output:

03:00.0 USB controller [0c03]: ASMedia Technology Inc. Device [1b21:3142] (prog-if 30 [XHCI])
Subsystem: ASMedia Technology Inc. Device [1b21:2142]
Flags: bus master, fast devsel, latency 0, IRQ 24, NUMA node 0, IOMMU group 51
Memory at fb500000 (64-bit, non-prefetchable) [size=32K]
Capabilities: [50] MSI: Enable- Count=1/8 Maskable- 64bit+
Capabilities: [68] MSI-X: Enable+ Count=8 Masked-
Capabilities: [78] Power Management version 3
Capabilities: [80] Express Legacy Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [200] Secondary PCI Express
Capabilities: [300] Latency Tolerance Reporting
Kernel driver in use: xhci_hcd

Dit you find the firmware in the mean time for the strix sound cards ?
I personally don’t think that it is a firmware issue as I got two Strix Raid Pro which I believe is ident to the DLX flash chip as both uses the ASM1042A and both went defective.
On one I had upgraded the FW and one stil has the original firmware on it, I can easely extract the firmware from the 25Q21BT flash chip if you want.
Just let me know.

1 Like

That would be amazing, the card has been sleeping in the cupboard for months… I was really mad at myself… please do it, i will be so thankfull. Can you check the version on the chip ?
I used the “ASM104_MPTool” you have it ? It was version 130704_10_F5_01

Here the extracted ASM1040A firmware from an ASUS STRIX RAID PRO soundcard.
SSID: 86a0
SVID: 1043
FW: 130704_10_F5_01
Please let me know if you get the soundcard working again.
GD25Q21B@SOP8_strix_raid_pro_flash-dumbp.rar (24.6 KB)

OMG thank you so much, but it will take some days to see if its working bcs it was on coold boot and sometimes the card worked and sometimes not… i will respond immediatly


It is now the second time for me that a Strix card stopped working.
First it was on a AsRock Z97 Anniversary mainboard, I only could get it to work again if I cleared the CMOS but after some time it stopt working again and I had to do the CMOS thingy again.
Now it stopped working on a ASRock Z590 Steel Legend mainbaord and clearing the CMOS did nothing.
I tried serval mainboard pcie settings without luck.
So I don’t know if it is realy a firmware problem.
Next thing I’m gona try is swapping the ASM1042A chip, mabe the usb chips gone faulty over x-time of use.

I try to update wiht your file, and it didnt work…
Something is wrong with your file, it looks empty inside when i open it with a text editor bcs all other bioses has something inside…

can you extract it in bios / DOS Mode with the DOS tool (command line) 104xfwdl
This dont works in Windows. Make a bootable USB Stick and start the PC from an USB Stick, then type in “104xfwdl.exe /a” to backup the file… dont forget to copy the 104xfwdl.exe on your stick

And i tested your file with the “ASM104_MPTool.exe” and the tool crashes, and i tested it wiht other bioses and it dont crash… your file is broken

Asmedia 104X Update Backup Tool.rar (183.9 KB)

I made a bat file… when you in bios just type in backup.bat and he will made a Backup XXXXXX.BIN file on your stick…

Here is the MPTool to check the firmware on your card and check your extracted file…
The Password to Unlock the tool is “asmedia” but dont Update your bios with this tool bcs you cant DOWNGRADE it back…

Asmedia ASM-104X MPTool.rar (468.5 KB)