Downgrade B360-I Strix motherboard bios help. "problem allocating memory"

Hi guys,

I have followed the guides and downloaded AFUWINx64 and also AFUDOS. I tried a dry run "/D" and it works on both existing and the one I wish to downgrade to. Tried extracting it using UEFItool also, but still the same. I always end up with problem allocating memory after reading the flash part.

Reason for downgrading being, ever since upgrading my bios, there seems to be a bug with my board if there are two m.2 drives.

Any suggestion?
----------------------

Just an update. I am using the command /p /b /n /k /x

I am facing an issue now that my NCB block refuse to erase. Giving the error 43

attached screenshoot
---------------------

will i brick the board if i skip the "/k" function anyone?

Capture.JPG

@nnyymm - Please use edit instead of making multiple posts in a row, thanks!
If you are having this memory issue in DOS, then you need to use other DOS type, such as use Win98 SE instead of freedos etc.
Also, if using large USB this can cause issues too. Use smaller USB Stick, such as 2-4GB not 8-64+

Try this way - https://www.sevenforums.com/tutorials/46…ive-create.html
Or try my way Win98 SE use step #1-2 only, then if still error use step 1-4 (Don’t do this first) - Here post #10

/K = "Program all non-critical blocks and ROM Holes"
So yes, if this is part of the stock flash command, then don’t leave it out!
If it’s not part of the stock command, then remove it

noted! will edit and not post in multiple posts!

thanks!

i did not know if they were stock commands, i could not find any information regarding downgrading this motherboard bios.

unfortunately, i tried without "\K" and now my motherboard seems to bricked ): this motherboard does not have flashback feature. how can i update the bios again since I am unable to get into POST now…

@nnyymm - Stock flash package would have stock commands, if AFU is used. Sorry, I assumed you got that line of command flags from the stock package or something.
I can’t advise anything more here for now, without a link to your motherboard download page and what BIOS versions you were messing with
If you had given that info at your first post, I would have looked at the stock BIOS package and normal update procedure and commented more about your use of AFU and those flags etc.

I assume this is correct download page for your BIOS https://rog.asus.com/motherboards/rog-st…/helpdesk_bios/
If yes, EZ Flash should have been used, ONLY. Or I could have helped you with FPT and some hassles on your end
I tend to avoid AFU usage at all costs, for this reason, unless it’s stock method and then only use with stock method/commands/files etc. I would have let you know this had you included more info initially.
Sorry to hear your system is now bricked! You probably need CH341A flash programmer, and if BIOS is in a socket you need U Type Flat IC Extractor, if BIOS is soldered directly to board you need SOIC8 / SOP8 test clip with cable.
I can’t see BIOS in stock images, you will have to show me image of the board with NVME heatsink removed, if you cannot locate the BIOS youself.

What BIOS did you upgrade to, and then want to downgrade to, and why did you want to downgrade? You may have downgraded to model that doesn’t support your CPU, what CPU model and SSPEC is your CPU?
You may have downgraded to a BIOS region that does not support the ME FW version you would be left with from the higher version BIOS you flashed in, that may be why it’s bricked now, or due to leaving out /K
Or it may be just due to using AFUDOS when it’s not compatible with this model at all, f you used version 3 AFUDOS and used /GAN option, that is made for BIOS 10-15 years old

Since you seem to rush around, I’ll say this now, in bold
When flash programmer arrives, ONLY read >> Verify >> Save Then upload file and wait for help

If you need linked examples to CH341A bundles let me know.
Here is gudie about using - [GUIDE] Flash BIOS with CH341A programmer
And here is software package, not all versions work for all chips, so you must give me your BIOS chip ID read directly off the chip with your eyes before you do the above mentioned read >> verify >> save
http://s000.tinyupload.com/index.php?fil…213094641136166


Try booting with BIOS on root of small (128MB-2GB) USB Stick, formatted to FAT32 and put USB in 2.0 port. Make two copies one leave as stock and other rename to >> SB360IG.CAP
Maybe you will get lucky and Crashfree BIOS 3 will kick in and recover BIOS. Let system run with that USB installed for a while. Reboot it a few times, letting it run for a while between each time (maybe 5-10 minutes each time)
I doubt this will work, but worth trying

yes that is the correct motherboard page. i 've tried ez flash to downgrade but asus doesn’t allow it, it just shows that the bios isn’t compatible

gosh guess i really need the ch341a flash programmer. my bios flash chip is winbond 25Q128JVSQ, is that compatible?

the bios 1404 is the stock bios. i am downgrading to 1404 as it is compatible to my current i5-9400f, i upgraded to 2805 and there is problem with booting up with two nvme drives on the motherboard. 1404 had no issue. i’ve used version 5 AFUDOS without the /GAN option

this motherboard doesn’t have crashfree bios 3, unfortunately, so i double the usb trick will work. ):

i guess i when i receive my ch341a flash programmer i shall update again?

@nnyymm -Thanks for more info, you should have waited for more help, sorry BIOS is bricked now

Yes, CH341A works with 25Q128JV, from the above linked software package use ASProgrammer 1.40/1.41 (OK read/write) or Colibri ver. 1.0.1.62 confirmed read/write OK (use BV ID)
Once you get it, dump current BIOS contents how I mentioned and send to me, I will make you BIOS with whatever version you want to program back (ie 1404)

Since you used AFU 5, it must either be random brick issue, or due lack of /K, or simply due to BIOS 1404 region does not work with the ME FW version that would remain in there from 2805
I will fix all this for you and make you proper 1404 back to how you had it, once you have programmer and send me the current BIOS dumped content

Yes, this motherboard has Crashfree BIOS 3, that’s why I mentioned it, all boards without USB Flashback have it.
This motherboard does not have USB Flashback though, that would be helpful here and would fix it in a hurry
Crashfree is not usually all that useful, unless you see message on the screen, but always worth trying

Yes, let me know once you get programmer and then we can fix this! You need CH341A + SOIC8 / SOP 8 test clip with cable, since I assume BIOS is not in socket on this board
Let me know if you need linked examples on ebay or amazon

Great! I have just ordered one, should receive in a bout a week or so. my bios is a soldered chip sadly. Will follow the instructions to dump the current bios content and send it to you asap

Will update again when I receive it! Thank you!

You’re welcome! Don’t worry, we’ll fix it up

@Lost_N_BIOS i got the flash programmer! and i am stuck already. I chose 128bv(even tho my chip is 128jv) for colibri 1.0.1.61, managed to read it/ compare and saved it into the bin file. is this correct?

edit 2: i am unable to upload the bin file here since it is 16mb
used tiny upload: http://s000.tinyupload.com/?file_id=06180526527457578214

edit 3: did a bit of reading, and notice that my chip is possibly protected. i tried to unprotect it using asprogramme 1.41 but it just runs infinitely. is it normal? does it take very long to unprotect the chip?

edit 4: i am going to try downgrading my windows to 7 and see how

edit 5: YES IT WORKED. NO MODIFICATION INDEED! I just flashed the bios right using asprogramme 1.41. I suspect my stupid mistake was not clipping the bios chip properly all these time.

my steps were, read the chip, unprotect, erase, blank check, flash the bios, verify.

my computer is booting once again!!!

read complete.JPG

comparing.JPG

unprotect.JPG