driver for nforce3+ATI HD3850 on Windows 7 64 bit

Hi guys, see title,

any one knows any solution of driver for nforce3+ATI HD3850 on Windows 7 64 bit.

my motherboard is Asrock am2nf3 it’s a nforce3 250 chipset , i want use windows 7 64bit, as i have 16GB ram installed, and some applications need windows 7.

do we have any options ?

first of all,make sure you have completely updated your windows (including optional updates)

for Ati HD3850, latest driver version is 13.9 which amd provides offically
but for nforce3 I need more information like hardware id’ (fernando’s modded nforce drivers might work for you,if your device id is included in the inf)
out of curiosity,which apps? I’m pretty sure most of them will work on win10,or could find alternatives

@mqlee :
Welcome to the Win-RAID Forum!
As onuracengiz already mentioned, the ATI graphics card and the NVIDIA nForce3 chipset devices need completely different drivers.
Please follow onuracengiz’s advice and wait until the Win7 installation has been completed and all drivers, which are offered by the Windows Update, have been installed.
If the Device Manager should still show devices with a missing driver, do a right-click onto them (one after the other) and check the HardwareIDs of the related device (“Properties” > “Details” > “Property” > “HardwareIDs”).
You may find missing nForce3 chipset drivers for Win7 within the “Special nForce2-4 LEGACY Driverpacks for Win7-10”, which I am offering within the start post of >this< thread. Since some of the included nForce3 chipset drivers have been modded and digitally signed by me, don’t forget to import the Win-RAID CA Certificate (is within the driverpack), before you start with the manual driver installation.
Good luck!
Dieter (alias Fernando)

many many thanks Fernando and Onuracengiz, once i get my windows 7, i will have a try and leave feedback.


Hi boys.
i just got my am2nf3-vsta board today, havent tried with HD3850 AGP, because, i met a problem ahead of gpu .
my ssd cannot be detected in BIOS, i’ve tried with SATA1/2 ports and none of them are working.

does anyone know if any switches on the board control this ? i replaced the sata cable, power cable, even another ssd.
my intel ssd is 520 180G.

anyone has any ideas ?
many thanks.

@mqlee :
What lets you think, that the BIOS doesn’t detect the Intel SATA SSD? Has this SSD been used before? Is it the only disk drive, which is connected to the nForce3 chipset mainboard? Which nForce SATA Controller setting did you choose within the BIOS?
Please post a picture of the “Advanced” BIOS section, which shows the SATA Controller settings.

Hi thanks for reply, Fernando. please find attachements.




on bios, on there sata1/2 it shows [not detected], and while install windows xp, i cannot find any disk.
this ssd is working with my other motherboards very well. i only have this one.
i have tried with the other sata port, but same issue.

weird… dont know why photos are up side down…

Now they are ok.
Which options do you see regarding the "SATA Operation Mode" settings?

EDIT: What happens, when you set the options of the "OnBoard IDE Controller" to "Disabled"? I suspect, that the "IDE Controller" means "P-ATA Controller", wich is something else than a S-ATA Controller.

Now they are ok.
Which options do you see regarding the “SATA Operation Mode” settings?

EDIT: What happens, when you set the options of the “OnBoard IDE Controller” to “Disabled”? I suspect, that the “IDE Controller” means “P-ATA Controller”, wich is something else than a S-ATA Controller.


if i disable the “OnBoard IDE Controller”, those 4 lines with keyword ‘IDE’ will disappear, only left

> SATA1 [Not Detected]
> SATA2 [Not Detected]

SATA Operation Mode : The default value of thisoption is [non-RAID]. to operate RAID function on SATA HDDs, select [RAID]

and I also tried to disable “OnBoard IDE Controller”, then there were only 2 sata lines, but they all showed " Not Detected"

i even just use my HITACHI SATA 500G HDD, but same, cannot be detected.

This indicates, that the mainboard itself doesn’t work properly.

This indicates, that the mainboard itself doesn’t work properly.

thanks Fernando,
i have returned it to seller yesterday, i will wait for another motherboard, Alive-dual esata2, it will come soon, i will test it again.

Hi there, sorry to hijack this thread, but the title is basically exactly why I’m here.

I have been reading for quite some time that the combination of nforce 3 + ATI (AGP) + Windows Vista\7\10 + Dual Core is simply impossible to get working properly.

Has the driver package you’ve posted solved this problem? I know nothing is guaranteed, but… are people actually getting proper AGP support on nforce 3 boards under Vista+, and are they doing so with ATI GPUs? Are there any serious compromises? For example, CPU must be single-core only, or the GPU runs in PCI compatibility mode?

Thank you for your time.

Dear Fernamdo,

now i just have my Alivedual-esata2 (nforce3) with Powercolor AGP HD3850.

i tried many times to install the driver (with different version of ati driver), but did not work at all, the hardware id is :


appreciate if you can give me some clues

many thanks.…1002%26DEV_9505…s=windows-7-x64…-radeon-hd-3850

thanks mate

but, i firstly, tried to install 13-9-legacy_vista_win7_64_dd_ccc_whql.exe , with files replaced from ""

but none of these are working… do we have any detailed procedures ?

let the amd installer unpack,then open up the device manager -> have disk -> show the unpacked files folder -> ignore the warning

Please check photo in the url downbelow, i tried. but no any warnings.

err is :

"windows countered a problem installing the driver software for your device "
“the parameter is incorrect”

not the "forced" one,try official one,the one from AMD (13.9 legacy)

update,browse my computer,let me pick,show the file


i reinstalled the windows 7 , after unpacking the ‘official driver’, there are 2 inf files, see video i just took :

i did not put file in the ‘forced package’ into that folder yet.

so which one i should pick up ?