Driver issue?

Not sure if anyone will be able to help me, but I recently bought a Logitech BRIO 4K webcam.

I’ve been having trouble getting it working correctly, and I’m not sure if it’s a Windows issue or a driver issue, though I suspect the latter.

First off, the system I’m running it on is an Asrock X99 Taichi with an i7-6850, 16GB ram, GTX1080ti and Windows 10 Pro 64bit (installed on Samsung 960EVO). Obviously I’ve got the grunt to run it without issue.

The motherboard has 2 USB 3.1 (gen2) ports (One type A and one type C) running off an ASMedia 1142 controller, and also has some Intel USB 3.0 ports.

Now, the problem I’ve experienced (along with others going off posts on the Logitech community pages) is that when I plug my camera in to the USB 3.1 ports, the camera displays a perfect high quality, crystal clear image within the Logitech configuration app, but has a range of issues when trying to use the camera in any other app.
Logitech don’t supply any recording software with the camera, and recommend using Windows Camera, OBS or XSplit or such for recording.

Unfortunately, all of these seem to have issues.

First off, the Windows camera app, upon opening it, simply shows an error code, with a message saying “It looks as though your camera is being used by another app”.
I’ve contacted both Microsoft and Logitech regarding this, and Logitech have ignored me completely (no reply at all) and Microsoft Level 2 tech called me yesterday to try and help figure it out, but was unable to get any results.

When I run either OBS or XSplit, either the camera just shows no image at all, or if it does, (usually very low resolution) upon trying to change the resolution to something higher like 1920x1080, or 3840x2160, results in the apps freezing for a second, and then just disappearing from my screen. This also happens with other camera apps from the Windows Store (such at AutoPic and PowerCam)

Now if I plug the camera in to one of my Intel USB 3.0 ports, the camera works in all apps, but the image looks absolutely horrid. It’s all grainy, noise jumping all over the place, the lighting is all messed up (too dark in some areas and too bright in others,) and changing resolutions seems to make no difference whatsoever. (It may show more pixels, but it’s hard to tell as the image just looks so horrendous, you can’t really tell if it actually changes res,) but at least it doesn’t crash the apps. Unfortunately though, this means I have to either record shitty looking videos/pics, or I can’t record anything at all.

I’ve searched a lot for an answer, and basically found nothing of any use so far, with the exception of one post, in which the guy singled out that his camera appeared to be incompatible with ASMedia controllers.
Obviously he’s on to something, as mine doesn’t function correctly on those ports either, but I’m curious as to why the Logitech config app shows me a 100% perfect image, only when it’s connected to those ports. Why does that app work, but nothing else? Why do all the apps (including the Logitech app) show me a shitty image when connected to the Intel ports?

I’ve tried numerous drivers for the ASMedia controllers, but have had zero luck so far, but I was recently reading that it might be possible to update the firmware for the chip? Would that be worth a try?

If anyone has any insight as to what might be causing the issues, I’d love to hear from you! If you need any more info, just ask, and I shall provide.


@welbot :
Welcome to the Win-RAID Forum!

Unfortunately I cannot help you and I doubt, that an update of the ASMedia or Intel USB Firmware will solve your specific webcam problem.
My suggestion is to contact the Logitech Support.

Dieter (alias Fernando)

Thanks. I didn’t think you’d be able to, but worth a shot given that I’m not the only one who singled out ASMedia as a problem, and even things like the Occulus Rift are known to have issues with ASMedia controllers too.
I have contacted Logitech, but until this morning, they had not replied (been about 2 weeks.) Unfortunately, their reply was basically along the lines of “Make sure you aren’t using a USB Hub or extension cable blah blah blah”. Essentially just ignored all the details I provided in my original message. Can’t say I’m surprised, but we’ll see how it goes. Going to try calling them today instead. See if that gives me better response, though not getting my hopes up.